First post, by YCH

User metadata
Rank Newbie

I have a year 2000-era PC that currently has three D3D-capable devices:

ATi All-In-Wonder Pro (Rage Pro chipset)
Diamond Monster 3D (Voodoo 1 chipset)
Matrox M3D (PowerVR PCX2 chipset)

Like many others with multiple D3D video cards I want to be able to control the active D3D device. So I downloaded two programs: first is "Tweek.exe" which is a combo tweaking and D3D enable/disable for the Voodoo 1, and second is "3D Control Center" which I believe was/is a popular program that can switch between the primary, secondary, and PowerVR video cards on the fly.

First thing I did was run Tweek.exe. I looks like it mostly made a .bat file of SST variables based on your selections of settings so I checked the settings I wanted and saved the resulting .bat file. Then I copied the SST variables in the .bat file to my main autoexec.bat for use during Windows startup. I think I also hit the Disable D3D for Voodoo 1 option in Tweek.exe.

Next I started 3D Control Center to test its switching capabilities. I selected the ATi AIW Pro as my D3D device and started Dark Forces 2: Jedi Knight. Okay the rendering is visibly different and does not show any of the faint interference pattern of my Diamond Monster 3D so pretty sure it's the ATi in use (could've disconnected the VGA passthrough cable to be super sure but didn't).

Then I went back to Windows and used 3D Control Center to select the PowerVR and this is where my problems started. Jedi Knight still used the ATi as D3D device. I tried going back to the Diamond Monster 3D but nope, still locked to ATi. Looks like 3D Control Center doesn't work anymore...or did it ever?

Anyways, there is more to it but it appears that somehow the Tweek.exe program is now dominating the settings used by Windows. Remember how I said I used the 3D Control Center to pick the ATi when I started testing with Jedi Knight? That may have been an illusion...I think I'd already disabled the Voodoo's D3D using Tweek.exe which defaults the system to the ATI (M3D's D3D is disabled in the Matrox control panel). So maybe 3D Control Center never worked for me and only appeared to work the first time because of the option I picked in Tweek.exe.

So all these dependencies are weirding me out. I used to be able to set SST variables manually in the Windows autoexec .bat and see them take effect but not really anymore. I need to use Tweek.exe to modify all my D3D and Glide related settings for the Diamond Monster 3D. The exception is that I can still control the gamma using Diamond's driver control panel which I thought basically works by writing to the same autoexec.bat in the Windows directory...but I appear to be misguided. I tested this by doing the following:

Step 1) Modify gamma in Diamond's driver control panel to 1.90. Checked Windows' autoexec.bat and verify that SST gamma was set to 1.90.
Step 2) Restart PC and run Jedi Knight. Yep game is super bright now.
Step 3) Modify Windows' autoexec.bat and changed it to 1.30.
Step 4) Restart PC and run Jedi Knight. Game still appears to be using 1.90 gamme. Super puzzled...checked autoexec.bat...and yes it's 1.30. where is the Voodoo getting its instruction to set gamma to 1.90?

So I must lack a fundamental understanding of how Tweek.exe and Diamond's driver control panel settings are dominant over the autoexec.bat settings. I'm having trouble knowing how Windows and my games decide to get their video card settings from.

Enlighten me please!