VOGONS Driver Library

Discussion about old PC hardware.

Re: The Unofficial VOGONS Driver Library

Postby Malik » 2012-2-07 @ 01:31

Voodoo3 CDs uploaded.

EDIT : SquallStrife, the picture upload is not working well. Any picture uploaded shows only the Diamond Monster 3D II CD image. It reapperas even after deleting the image and re-uploading a new one. Even when editing other sections like the Voodoo3 files. Previously happened with the Voodoo 3 3000 image which appeared in any file I uploaded.
User avatar
Malik
l33t
 
Posts: 2449
Joined: 2004-4-10 @ 14:37
Location: Malaysia

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-08 @ 22:12

OK, I'll check these things out.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-08 @ 22:17

OK, something is going wrong, the filenames are not being retained when the database is updated. There are two files in there, called ".jpg" and ".png", which are being overwritten every time an image goes up. Not good!

I'll check that out today, I might need some help to debug it. I'll let you know.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-08 @ 22:32

Alright, the image uploading problem is fixed.

The bug was that a variable was mis-spelled in the doedit.php script, so the image file was not getting a name. Every time a file was uploaded, the name was being set to [blank].jpg and overwriting the same file.

I've corrected this.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-08 @ 22:36

elianda, that is by design. If you want to link to the files, you need to link to the download page, not to the file itself:

http://www.vogonsdrivers.com/getfile.php?fileid=242

If you click the link on that page, it works fine.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby elianda » 2012-2-08 @ 22:40

Well, it does not. I got the same error whether I use the direct link or click on the link makes no difference.

Edit: Maybe it is a different problem, I somehow get forbidden 403 for any download link.
I use Firefox 10.0
User avatar
elianda
l33t
 
Posts: 2169
Joined: 2006-4-21 @ 16:56
Location: Halle / Germany

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-08 @ 22:53

Ooh OK, Interesting!

I'll install Firefox and see if I get the same bug. Could you PM me your IP so I can cross-check the access logs? Also, are you using any kind of script/plugin/addon that could be hiding the referrer when you try to download the file?

Edit: Just tested with Firefox 10.0 on Mac, and it worked just fine.

Edit: The 403 error page will now show you the referrer. Might help get to the bottom of the problem! :)
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby Malik » 2012-2-09 @ 01:28

Guys, have a look at the picture in the Voodoo3 3000 page : http://www.vogonsdrivers.com/getfile.php?fileid=316.

I don't know where it came from and who uploaded it.

Anyway, it'll be there for a limited time only. (Before I upload an appropriate picture.) :lol:
User avatar
Malik
l33t
 
Posts: 2449
Joined: 2004-4-10 @ 14:37
Location: Malaysia

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-09 @ 01:30

LOL

Sorry, that was me doing some testing! :-S Guess I forgot to change things back when I was cleaning up!
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-09 @ 02:59

2012-02-09
========
- FTP uploads are now unticked by default on the "Process FTP Uploads" screen. It's a good idea to verify each one has the correct size before hitting "Submit"
- FTP uploads that remain unticked when you click "Submit" will now be deleted. This will also apply to files showing the "FILE ALREADY EXISTS" or "INVALID EXTENSION" errors. If you want to rename a file before having it processed, you can do so through your FTP client.
- Fixed a bug causing image uploads through the "edit" interface to be named incorrectly. Image uploading should now work correctly.
- Added some diagnostic information to the HTTP 403 error screen.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby TheMAN » 2012-2-09 @ 04:40

I'm going to upload a pedobear to replace that pic! :P

I think it's a good idea to have a built in hash checker in the FTP upload processor... that way you can verify it against your own hash locally... it'll be more reliable than simply comparing file sizes :)
TheMAN
Oldbie
 
Posts: 839
Joined: 2011-2-12 @ 08:39

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-12 @ 15:40

WRT Rendition drivers, is "Release 1.0, build 5235 -- November 23rd, 1998" found inside the SDK archive the latest NT4 driver for V2200?
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby AdamP » 2012-2-20 @ 16:13

Is the CT1330A a Sound Blaster Pro 1 or 2? Because I have a Creative Sound Blaster Pro 2 Windows 3.1 FM driver (not the usual Voyetra one). The other uploaded SB Pro drivers all use the Voetra one.
AdamP
Member
 
Posts: 348
Joined: 2009-8-21 @ 18:12
Location: England

Re: The Unofficial VOGONS Driver Library

Postby DonutKing » 2012-2-20 @ 21:33

CT1330 is SB Pro 1. The SB Pro 2's are usually CT16xx
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1764
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: The Unofficial VOGONS Driver Library

Postby SquallStrife » 2012-2-20 @ 21:40

http://www.ask.asia.creative.com/wwengl ... _audio.htm

Creative's model number system becomes nigh-on useless after the Pro 2 series.

The only pattern I can see is that the first two digits seem to relate loosely to the product family.
VogonsDrivers.com | Link | News Thread
[retro swim] | Link | Release Thread
Follow me on Twitter: https://twitter.com/RetroSwimAU
User avatar
SquallStrife
l33t
 
Posts: 2781
Joined: 2010-2-06 @ 15:18
Location: Drowning in consoles

Re: The Unofficial VOGONS Driver Library

Postby AdamP » 2012-2-20 @ 21:59

Shall I upload only the FM driver or all the other drivers that came with it? They are:

Artisoft Sounding Board
Creative Sound Blaster Pro Wave and MIDI
Creative Sound Blaster Pro MIDI Synthetizer
Creative Sound Blaster Pro Auxiliary Audio
Pro AudioSpectrum Wave/MIDI/Aux
Pro AudioSpectrum Stereo FM
Pro AudioSpectrum Mixer
[MCI] Mixer Control

and they come form the Windows 3.1 Resource kit.

I hope this isn't a violation of copyright :)
AdamP
Member
 
Posts: 348
Joined: 2009-8-21 @ 18:12
Location: England

Re: The Unofficial VOGONS Driver Library

Postby TheMAN » 2012-2-22 @ 23:50

upload away.... that's the whole point of this repository... lots of people either lost their disks or they no longer work... or they bought 2nd hand hardware without the disks and couldn't enjoy its full potential

is it possible to even buy them from the manufacturer (if they still exist)? not at all!
TheMAN
Oldbie
 
Posts: 839
Joined: 2011-2-12 @ 08:39

Re: The Unofficial VOGONS Driver Library

Postby TheMAN » 2012-2-22 @ 23:55

AdamP wrote:Is the CT1330A a Sound Blaster Pro 1 or 2? Because I have a Creative Sound Blaster Pro 2 Windows 3.1 FM driver (not the usual Voyetra one). The other uploaded SB Pro drivers all use the Voetra one.


CT1330 is SB Pro 1.0
CT1350 is SB Pro 1.0, revision 1
CT1600, CT1610, CT1620, CT1680, CT1690, and CT2600 are SB Pro 2.0
only CT1600 was retailed AFAIK, which has the Panasonic CD-ROM interface.... the rest are proprietary or SCSI

keep in mind that Creative has a tendency of reusing PCBs for their variations, so you can never go by the number printed on the board... that is not what they officially designate that particular card as.... always go by the FCC ID white sticker if you can, it will have a more specific "CT" number on there

for example the original SB16 card was CT1730... there was also the ASP chip version, but the card was also commonly called "CT1730" as it is the same board except with the extra chip added... but really, it is called the CT1740 according to Creative's product list
TheMAN
Oldbie
 
Posts: 839
Joined: 2011-2-12 @ 08:39

Re: The Unofficial VOGONS Driver Library

Postby DonutKing » 2012-2-23 @ 00:07

CT1350 is SB Pro 1.0, revision 1


CT1350 is SB 2.0, not SB Pro

I know because I've been fiddling with them every day for the last month :P
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1764
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: The Unofficial VOGONS Driver Library

Postby TheMAN » 2012-2-23 @ 01:38

oops... got a little dyslexic :) I guess it's CT1330A then :s-face:
TheMAN
Oldbie
 
Posts: 839
Joined: 2011-2-12 @ 08:39

PreviousNext

Return to General Old Hardware

Who is online

Users browsing this forum: Bing [Bot], Kubik, kva, quicknick, tgod and 8 guests