VOGONS


First post, by rgart

User metadata
Rank Oldbie
Rank
Oldbie

I'm using laplink and a null modem cable to copy files over to my 486 however Its incredibly slow even when I set the baud rate to its maximum in the laplink options.

I checked MSD and its claiming the baud rate is as follows:

Com1 = 1200
Com2 = 2400

Shouldn't it be much higher?

Am I look for a jumper on the IO card or is there a dos program I need to use. Surely thats not this IO cards maximum baud rate.

a2d4c6.jpg

Reply 1 of 9, by jwt27

User metadata
Rank Oldbie
Rank
Oldbie

Surely there are faster ways to transfer files between PCs. Why not use an ethernet card? That would be quite a bit faster. If you don't have that, the parallel port is much faster as well, IIRC something like 4Mbit/s.

WANTED - Manuals/drivers for:

  • Tecmar Graphics Master
  • Paradise Autoswitch EGA 350 (EGA1A)

Reply 2 of 9, by sliderider

User metadata
Rank l33t++
Rank
l33t++

I've transferred files at 19.2K over null modem but I haven't done it for a while and not on PC. LapLink is supposed to be parallel not serial. Are you sure you're using a LapLink cable and not another null modem?

Reply 3 of 9, by rgart

User metadata
Rank Oldbie
Rank
Oldbie

Hmm I've always used laplink 5 and a null modem cable however the baud rate is usually a lot higher and its reasonably quick.

I didn't want to have to install a network card.

Reply 4 of 9, by elfuego

User metadata
Rank Oldbie
Rank
Oldbie
sliderider wrote:

I've transferred files at 19.2K over null modem but I haven't done it for a while and not on PC. LapLink is supposed to be parallel not serial. Are you sure you're using a LapLink cable and not another null modem?

I also used to transfer files with 19,2k over a serial cable. But the last time I did so was about 15 years ago. I remember setting baud rate within windows though.

Reply 5 of 9, by SquallStrife

User metadata
Rank l33t
Rank
l33t

The baud rate should be set by whatever software you're using.

If not, try this at the DOS prompt:

mode com1:115200,n,8,1

VogonsDrivers.com | Link | News Thread

Reply 6 of 9, by rgart

User metadata
Rank Oldbie
Rank
Oldbie

you know your dos SquallStrife.

Maximum dos is allowing is 19200. Every other settings is saying Invalid Parameter. That's much faster than 1200 or 2400 for laplink. So Im happy with that.

But when I load ctmouse 1.8 it drops the baud rate to 1200 on com1 where the mouse is. Is this normal?

Reply 7 of 9, by Jepael

User metadata
Rank Oldbie
Rank
Oldbie

Serial mice work at 1200 bps so it is correct.

MSD reports what the current setting on the chip is, not the maximum.

I am pretty confident that LapLink has some configuration setting what baud rate it should try to use, or to autodetect. You should be able to get 115200 bps. However if run MSD, it detects the serial port type as you can see. It is 16550A. I recall MSD accidentally leaves the 16550A FIFO enabled with largish timeout, so running MSD after mouse driver has loaded leads into laggy mouse cursor. If LapLink does not understand about 16550A UART and its FIFO, it is possible that LapLink also slows down because of enabled FIFO and timeout, even if LapLink uses 115200 baud rate. After cold booting the PC, do not run MSD before LapLink.

There should be no requirement for setting baud rate manually with dos MODE command.

But otherwise the parallel port allows for faster transfers. Not 4Mbit/sec though. I think I have maxed out at about 40-50 kbytes/sec with FastLynx and 4-bit parallel cable. There are also different cables that can transfer more bits at a time.

The baud rate you can achieve depends on the quality and length of the null modem cable and its configuration. FastLynx can work with 3-pin cable that only connects RXD, TXD and ground, but it can work faster when the four handshake pins are connected as well. I do not know if LapLink implements such thing.

If you transfer between a modern PC that has no real serial ports and you have to use an USB serial port, it can also be the source of sluggish transfer.

You can also use modem terminal software like Telix or Telemate or whatever to transfer files with protocols such as ZMODEM. I use this to transfer files from a Linux PC to DOS PC.

Reply 8 of 9, by Zup

User metadata
Rank Oldbie
Rank
Oldbie

As Jepal said, MSD reports the "default" parameters, not the parameters used by programs.

Also, keep in mind that type of serial cable can slow down the transfer: 3 wire cable needs "software" handshake (XON/XOFF) and that requires sending an XON character before data and an XOFF character after that... so you'll need to transfer more data.

To solve it, you'll need a 3-wire "enhaced" cable (usually works OK, but may be unreliable in some cases) or a 7-wire cable. Those cables will support "hardware" handshake and may perform better. The quick fix (3-wire "enhaced") would be making a short between DTR-DSR-DCD and another short between RTS-CTS on both sides of the cable. That would allow you to use "hardware" handshake and the computer would think that signals are always OK (but it won't know if any side can't receive data for any reason).

In any case, serial connections are slooooooooow. A parallel data would be a better choice, but I'd use serial or parallel only if I couldn't use a network connection.

I have traveled across the universe and through the years to find Her.
Sometimes going all the way is just a start...

I'm selling some stuff!

Reply 9 of 9, by rgart

User metadata
Rank Oldbie
Rank
Oldbie

Yeah I don't use the old null modem cable often just when I need to copy over a small amount of data..

Ah ..so It might be my cable that's slowing me down? I don't recall it being as slow as it is now so maybe my configuration was different prior.

Parallel cable for xfer was common? I looked in my box of cables and couldn't find one. Does Laplink support parallel cable transfers?