First post, by notsofossil

User metadata
Rank Member

This is a driver download for installing Windows 98SE or Windows Me on an IBM Thinkpad T42 laptop.



All the drivers posted here were located through extensive google searching, Lenovo does not support Windows 98SE or Windows Me on this laptop model.


I have only tested Windows Me at this point in time, however, the drivers and instructions posted here should be compatible Windows 98SE. If you encounter missing CD drivers when installing 98SE, you'll have to devise a way to get the motherboard driver into the hard drive so 98SE can install it and get the CD drive working, be it editing the hard drive externally or installing an inappropriate CD driver. The rest of the drivers should work fine. I may later update this thread with 98SE instuctions too.

Most of the drivers make no mention of Windows 95 or Windows 98FE, I have no idea if those will work.

Also, IBM did offer the Thinkpad T42 with a few different customizations. In the future I may revise the driver download here to include any other devices that the Thinkpad T42 is known to ship with. In regards to the Radeon chipset, the WME 8.03 Catalyst driver should include support for the Radeon 9000 and Thinkpad T42 video chipsets.


http://www.mediafire.com/download/60sbt8x4ifb … _Drivers_V1.zip

Drivers included
Motherboard (Intel 855PM infinst_autol.exe infinst_enu.exe)
Video (ATi Radeon 7500 wme-8-03-98-3-050117a-021000e.exe)
Sound (SoundMAX d64z32us.exe sp24465.exe)
Ethernet (Intel PRO/10/100/1000 tpet1u98.exe)
Wireless (Atheros/Intel unidentified 1qwc70ww.exe)
PCMICA (TI Cardbus Controller ossa04ww.exe)

Not included


Included with the .zip file. I left the names of the drivers unedited so they are more recognizable.

Everything included should install without a hitch, except the ATi Radeon 7500 driver. You will have to manually install the display driver. If using Windows Me, you'll have to force it to accept the driver as it doesn't have a digital certificate from Microsoft. The wireless systray program had trouble running after reboot, using Windows Me. Using KernelEx 4.5 Final to run the systray program in 98SE mode seemed to help. The wireless settings are found in the configuration tab.

Out of all the drivers, the ATi Catalyst driver for the Radeon 7500 was by far the hardest to find. I must have gone through a dozen drivers before I found one that finally worked without Windows ME booting to a black screen instead of the desktop.

Contents of instructions.txt

IBM Thinkpad T42
Windows 9x

Intel 855PM:

Run either 'infinst_autol.exe' or 'infinst_enu.exe'.

ATi Radeon 7500:

Unpack WME 8.03 catalyst driver. To install display driver, open display properties in device manager, update driver, specify location, select driver from list, have disk, go to 9x INF folder in the unpacked WME 8.03 installer and finally pick either of the three RADEON 7500 SERIES entries from the giant driver list (scroll way down). If using Windows ME, you have to allow the uncertified driver to install, pick advanced option when offered and turn off the auto rejection. Install ATI Control Panel from the unpacked installer to finish.


Run either 'd64z32us.exe' or 'sp24465.exe'.

Intel PRO/10/100/1000 LAN Adapter:

Run 'tpet1u98.exe'.

Atheros/intel/thinkpad wireless
Thinkpad T42
Windows 9x

Run '1qwc70ww.exe'. When installing the wireless driver (assuming you have the atheros/intel type wireless card), the driver and client should install fine. A possible issue may crop up when you restart Windows and the systray icon is supposed to appear. Sometimes it crashes, not sure why. When using Windows ME OEM, I tried installing KernelEx 4.5 Final and set the systray icon for the wireless client to Windows 98SE compatibility. That seemingly stopped the crashing. Windows 98SE may not require this. Just jotting this down just in case.

The installer 'tpet1u98.exe' is there just in case the installer mentioned above doesn't work for you.

TI Cardbus Controller:

Run 'ossa04ww.exe'.

Drivers not included:






Thinkpad T42 Win9x Drivers | Latitude D600 Win9x Drivers
Next: Dell Inspiron 8000

Reply 1 of 12, by notsofossil

User metadata
Rank Member

Feel free to post whether the drivers here work good on your Thinkpad T42 or not.

It's possible these may work on other similar Thinkpad models too. I don't have any other Pentium M Thinkpads to confirm though.

Thinkpad T42 Win9x Drivers | Latitude D600 Win9x Drivers
Next: Dell Inspiron 8000

Reply 2 of 12, by ultimate386

User metadata
Rank Member

Cool! I have a Thinkpad X32 (dual booting XP and Ubuntu right now) I might have to try this with later. Seems like the hardware is pretty similar from what I remember off the top of my head.

AMD386/IIT387DX40, 32MB, ATi Mach64, AWE64
Compaq Prolinea 4/33, 32MB, Tseng ET4000, SB16
AMD X5, 64MB, S3 Virge/Voodoo1, AWE64
AMD K62+550, 256MB, Voodoo3, AWE64 Gold
P3 1.2Ghz, 512MB, Radeon 7500/Voodoo2 SLI, SB Live!

Reply 3 of 12, by notsofossil

User metadata
Rank Member

I don't have an X32, so I can't confirm whether any of these drivers would be compatible. The typical spec sheet sounds similar, but none seem to give specific model numbers or anything.

Thinkpad T42 Win9x Drivers | Latitude D600 Win9x Drivers
Next: Dell Inspiron 8000

Reply 4 of 12, by dr_st

User metadata
Rank l33t

Between T42 and X32: The chipset and LAN are the same, so the motherboard, sound and Ethernet driver should work.

Wifi is the same (in the sense that the same cards were used across both models), but there were different versions (Intel 2100B, Intel 2200BG and some Thinkpad-branded Atheros card). They are all interchangeably anyways.

The video and CardBus differ. X32 has the basic Mobility Radeon, the T42 can have Radeon 7500 or Radeon 9600. The same driver may support all three, but not necessarily so. CardBus - you will need different drivers as the T42 uses a Texas Instruments part, and X32 a Ricoh part.

https://cloakedthargoid.wordpress.com/ - Random content on hardware, software, games and toys

Reply 5 of 12, by notsofossil

User metadata
Rank Member

If anyone using my driver download ends up obtaining other drivers to suit additional T42 configurations, or if the X32 can be accommodated, let me know and I can update the driver download.

Thinkpad T42 Win9x Drivers | Latitude D600 Win9x Drivers
Next: Dell Inspiron 8000

Reply 6 of 12, by dr_st

User metadata
Rank l33t

If you wish, we can expand this thread to cover other Thinkpads. Following that other thread, I actually decided to try to install Windows ME on my Thinkpad A31p. This machine came with XP, but I have absolutely no use for it, since it is too slow for modern tasks, and I have plenty of other XP machines. However, for a fast Win9x gaming machine it could be good, and I decided that it wouldn't be a bad idea to have first hand experience with Windows ME.

The installation itself went smoothly, and most drivers are actually officially available from IBM/Lenovo (since A31p officially supports WinME, unlike many Thinkpads). However, there are a couple of major deal breakers.

1. Wireless

This machine has the Atheros-based IBM a/b/g adapter for which the mentioned 1qwc70ww.exe driver should work. That driver does not officially support ME for some reason, only 98, but I assume that ME can load the 98 driver. At first it wouldn't install, until I realized that the .INF for the driver specifics a concrete subsystem ID, and the card I have has different IDs (I guess it was not originally an IBM part). Luckily, we are dealing with pre-NT6 drivers, which require no signature, and so tampering with the INF is possible. I just removed the subsystems (effectively turning it into a 2-part driver vs a 4-part driver), and then it installed.

Still, it does not work. Every boot it displays the error "Your network adapter is not working properly. You may need to set it up again. For more information see the network troubleshooter." The device is banged out with Code 10, which is not very specific as it says that the device is "either not present, not working properly, or does not have all the drivers installed". Clicking on "Driver File Details" lists the correct driver (ar52119x.sys), but at the same time says "File not installed". At this point I cannot get the wireless to work. This exact adapter worked in XP just before I wiped it out, so I know it is not defective, and I would prefer not to have to hunt for a different adapter, and then "hope for the best". So I am at a a loss as far as how to resolve this

2. Keyboard Customizer

Pre-Lenovo Thinkpads do not have the Windows key, and there is a Keyboard Customizer utility which allows you to assign the right Alt key (or something else) to it. It also has a few other useful functions. However, it is only supported on NT-based systems, and while it does install, it won't run, complaining about a missing export in SHELL32.DLL (StrStrIA). Maybe by chance one of the many unofficial patches for 9x/ME can bring this missing functionality (a quick search did not find anything).

However, in the meanwhile, I found out that Key Remap from the Win95/98/ME/2000 Software Toolkit works great for mapping one of the modifiers to the Windows key, so at least that part is settled. Now only the Wifi problem remains. There is also one "unknown device" in the Device Manager, and I am not sure what it is, but so far I cannot think of anything important that it might be.

https://cloakedthargoid.wordpress.com/ - Random content on hardware, software, games and toys

Reply 7 of 12, by Sammy

User metadata
Rank Oldbie

I have an T42p and it has Problems with Lan and Wifi.
Lan installed but has a yellow symbol in device manager.
Wifi did not install at all (windows found no driver) when installing.

Sound and Graphics work, but i think its to slow only 4140 points in 3dmark 2000.

Reply 8 of 12, by oeuvre

User metadata
Rank l33t

Another source for drivers https://thinkpads.com/support/Thinkpad-Driver … t/ddfm/T42.html

Change OS to Windows Me and you'll get a bunch of 9x drivers as well. Courtesy ThinkPad forums.

HP Z420 Workstation Intel Xeon E5-1620, 32GB, RADEON HD7850 2GB, SSD + HD, XP/7

Reply 10 of 12, by mard

User metadata
Rank Newbie

I found this thread in the search engine and proved to be quite helpful. I was able to successfully install Windows 98SE (Polish) on my T42 2374 and it's stable, so I thought I'll chime in and share my experiences.

My use case was to play some classic singleplayer games once in a while. Note that I don't have a functioning and compatible MiniPCI WLAN card, so all I needed was a system with working multimedia and basic USB capabilities.

It might get a few tries to get it right. I'm sharing my process, which I streamlined as much as I could, maybe it will prove useful to someone.

  1. I downloaded all Windows 98 compatible drivers from IBM/Lenovo official site (archive). Except the WDM audio driver that is required for emulated CD Audio. More on that later
  2. I downgraded BIOS to 3.21 to solve the problem with USB enumeration known under Windows 98SE (this has been documented in README file for BIOS 3.23) I also disabled Floppy and IRDa in BIOS setup, no reason for those to clutter the OS with unnecessary stuff.
  3. I booted up Win98SE's DOS and formatted the target drive (60GB). Note that WinXP's+ format utlity will FAIL to do so.
  4. Ran Windows setup and installed it. I skipped the creation of boot disk, also skipped the part about PCMCIA devices because I don't have any. No issues so far, after bootup it will complain about a bunch of missing devices, which can be skipped for now.
  5. Extracted the Install Support package tpisos98.exe (README) and applied the INF file that comes with it. It should add an entry to the registry. Reboot.
  6. Extracted Chipset driver oss206ww.exe (readme) and installed infinst_autol.exe, reboot. It complains about the missing driver for 82855PM. I think it can be found in C:\WINDOWS\INF, it requires the 855 driver that should be already there. If not, look in extracted package. If not, cancel, extract infinst_autol.exe with 7-zip, reboot and try again. Reboot.
  7. Extracted ICH APM fix ideapmos.exe (readme) and applied extracted registry file to resolve the conflict with Ultra ATA Storage Controller in Device Manager. Rebooted, checked, verified as fixed.
  8. Ran nusb36e.exe and followed attached instructions. Rebooted, verified. HID devices work OK, just allow to find the device wizard to install HID driver from the Windows disc. Mass storage works OK.
  9. Ran Radeon 7500 driver installer Vftp1gme.exe (readme). Rebooted, verified, no problems here.
  10. Ran WDM SoundMAX Audio driver D64z32us.exe (readme). Rebooted. Windows will ask you for a file smx.cat, it's available in C:\IBMTOOLS\DRIVERS\D64Z32US\SMAXWDM\SE. Verified, sound OK. MIDI requires one more reboot, works OK.
  11. Installed UltraNav driver Unav1i9m.exe (readme) to get that sweet ThinkPad'y middle button scrolling. No issues, just the keyboard is not working until rebooted.
  12. Installed SpeedStep 1ysue1us.exe (readme), rebooted. It's a frequency scaling utility, probably optional.
  13. Installed DirectX 9 DEC 2006 and 3DMark 2001 SE to verify its gaming potential. Got 4135 3D marks (on XP it was 3900-ish).


  • Installing "82855PM Processor to I/O Controller - 3340" driver is crucial for loading/running 3D games smoothly. This is based on my observations with 3DMark 2001 SE. Without this driver, games were performing very poor in True Color colorspace, and in High Color they were still occassionally stuttering. Windows wasn't able to find it automatically in my case, but if it asks for it, try pointing to C:\WINDOWS\INF directory. It looks for the 855 driver.
  • I noticed that installing the ethernet driver adds additional ~20 seconds to boot time. For me, it's not worth it. Also I don't have a functioning WLAN card to compare it with. I might be wrong but I think enabling networking in general yields similar results. I suggest creating a HDD/system partition image with something like Clonezilla before installing network drivers.
  • I also don't recommend installing the Bluetooth driver. It crashed the system during install, made the system hilariously unstable, even after uninstalling it I exprienced crazy glitches and hangups.
  • Also, important note regarding the Wireless driver, per README. It requires an additional install of Windows Management Instrumentation (WMI) core components in order to run. If you failed installing it, try again with WMI installed.
  • If you want to install Cardbus PCMCIA drivers... I haven't had much luck in removing generic one after Windows has been installed, but you will definitely get it working if you put the files in WIN98 directory you install Windows from, and they'll be correctly and automatically installed. You can find more information in README under section "Unattended Install (before Windows 98/SE setup)." (archive.org).
  • I noticed no problems with missing CD-ROM drivers. I was also surprised to see my USB drives in DOS listed as regular drives. I think that's BIOS that does the job during bootup.
  • And one more general advice... If you plan on playing any DOS CD-ROM games, either from physical or emulated drive... make sure you use the first available CD-ROM drive, in alphabetical order. Many DOS games use only first CD-ROM drive they can find, very often for CD audio, sometimes for copy-protection. Reassign the drive letters from device manager if you must.
  • Tools like Hiren's BootCD 15.2 (archive) and even most recent Medicat USB 21.01 (for 32-bit tools like Acronis True Image) work well on this machine. Use them!
  • IBM's Battery MaxiMiser tray applet causes problems after quitting some DOS games and sometimes it freezes some shell components. You can disable it from Battery MaxiMiser Wizard.

All links in my post are available in archive.org. Good luck!


  • hwinfo.png
    File size
    31.77 KiB
    File comment
    HWiNFO 32 Screenshot
    File license
    Public domain

Reply 11 of 12, by sero13

User metadata
Rank Newbie

Hello All, just wanted to say how useful I found these guides for setting up my T41, so big thanks to Notsofossil and Mard for sharing their experiences. My setup is 1.4ghz, 128gb msata (in the IDE caddy) and 1.5gb ram. My install was reletively easy (not sure whether I have been lucky so far or this is down to using the T41) just using the drivers on the Thinkpads archive, however I did use the WDM Soundmax driver Mard linked. I did have to remove one of my ram sticks in order to get Win98 to install, then run Rloew's Patchmem to put it back again (I'm dualbooting with XP so seemed a shame to waste it). I'm not sure if I accidentally nudged a cable while doing this as now the left trackpad button doesn't work. Track pad itself and track point buttons work fine but I would like to get it working.

One odd occurrance was when installing the Chipset drivers (I think) it changed the splash screen to the newer Intel logo vs the original Centrino. I'm tempted to upgrade then downgrade the BIOS back to 3.21 but I'm probably tempting fate there. It is annoying that it doesn't match the Centrino sticker...

Now its time to finish setting up Windows just the way I remember and fill it up with games before putting it on the shelf never to be looked at ever again!

Reply 12 of 12, by arizonapalms

User metadata
Rank Newbie

Thought I'd share the steps I took to get it on my ThinkPad T42 2373-M66
Fun fact, I bought this from an ex-IBM employee in Sydney a few years back. He also sold me a few other machines which are long gone but this one remains!

Formatted C: Drive, copied win98 folder over and ran setup from there.
Installed PATCHMEM (as using 2GB of ram, I'm usually against this but I want to keep the ram in here. Anything over 512mb is overkill for Win98)
Installed USB mass storage drivers from CD
Ran infinst_autol.exe for the Intel Chipset
ATi Radeon 7500 drivers installed using the 'have disk' method, selected first in the list. It prompted me that the signature's were off but continued.
Intel drivers all picked up ok including 82855PM Processor to I/O Controller - 3340 driver from the INF folder.
Changed display res to the native 1024x786 32bit, no issues.
Used d64z32us.exe for sound
Used tpet1u98.exe for ethernet - had to manually 'have disk' this one to the PRO1000 folder
Noticed the DVD drive is now no longer appearing in My Computer - rebooted.
Got a BSOD saying Unable to write to disk in Drive C:, pressed any key to continue, then more blue screens! This kind of pissed me off, but after rebooting again it worked. Perhaps it was the USB drive i had left in!
DVD drive now showing up
Ran ossa04ww.exe and updated drivers in device manager for the PCI-4520 cardbus controller - this locked up so I had to force a reboot. I'm going to leave these as the generic drivers for the time being.
Installed the UltraNav driver Unav1i9m.exe -> extracted and ran Setup.exe. Once this was done it caused the system to lockup. I rebooted again but the system locked up on the splash screen 😠
Safe mode, then changed from IBM to Synaptics, still crashes on splash screen. Safe mode again, removed Intel ethernet driver, now it boots. Looks like the ultranav driver was a red herring.
"New hardware found" window came up for the Intel Ethernet, but stopped responding...
Used 8255xdel.exe to remove the drivers
Downgraded BIOS to 3.21
Trying alternative ethernet drivers from https://download.cnet.com/WIN98SE-8-6-11-0-EX … 2_4-103814.html, these worked! Had to manually renew IP with winipcfg
Enabled DMA on hard drive
Reboot again
WiFi installed via 1qwc70ww.exe however the device wasn't detected even If i tried to force the drivers. I'm not bothered about using WiFi anyway so I'll ignore that for now.

There are still four 'Other Devices' in Device Manager, but the system is at a point where I can use it comfortably. Going to run some benchmarks and if it's stable I have myself another machine for LAN parties!