Socket 7 Motherboard not assigning drive letter to CDROM

Discussion about old PC hardware.

Socket 7 Motherboard not assigning drive letter to CDROM

Postby johnnystarr » 2017-11-11 @ 01:49

Greetings,

New here so be nice :D ...
I've built a retro computer recently with the following specs:

    Socket 7 Motherboard
    Pentium I @133Mhz
    16M RAM
    IDE 52x Creative CDROM
    2G compact flash -> IDE
    Standard 1.44 3 1/4 Floppy Drive

So far, everything has worked great. For some reason I'm having issues getting the CDROM to show up. The BIOS picks it up for sure.
I have the compact flash card connected to MASTER of IDE-0, and the CDROM connected to MASTER of IDE-1. I have set the jumper on
the CDROM drive to the MASTER setting. On POST, the Sec Master shows as CREATIVE CD6220-F. After the box boots up, it shows that
the CDROM is the secondary master as well. However, I can't CD to D: I don't see anything in the BIOS that allocates a drive letter to it
though. It's been a very long time since I've had to mess with this :D

I tried setting the primary boot device to the CDROM and it said it was attempting to read the master boot record from the CDROM, however
the LED didn't come on or anything. I got this drive brand new as NOS on eBay. I suppose the drive could be bad, but IIRC these things just
worked back in the day.
Attachments
IMG_2145.JPG
IMG_9222.JPG
IMG_3002.jpg
johnnystarr
Newbie
 
Posts: 3
Joined: 2017-11-11 @ 01:36

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby lazibayer » 2017-11-11 @ 02:46

You need to load CDROM driver before using it.
User avatar
lazibayer
Oldbie
 
Posts: 891
Joined: 2014-10-21 @ 21:16

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby RJDog » 2017-11-11 @ 04:13

Yup I'don't say everything is fine, you just need to (in DOS) load an ATAPI driver (e.g. OAKCDROM.SYS) and drive redirector (e.g. MSCDEX.EXE). If you have access to a Windows 98 boot disk, you can see a good example (including the files themselves).
RJDog
Member
 
Posts: 316
Joined: 2016-9-28 @ 01:14
Location: East Coast Canada

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby johnnystarr » 2017-11-11 @ 04:54

So I used the oakcdrom.sys in Autoexec.bat and config.sys and it mounts. However when I cd to D: I'm getting the good old "Drive not ready, Abort? Retry? Fail?"

The CD light doesn't come on even. I see there's PIO modes in the BIOS. I've tried all to no avail. Thanks for the feedback as well!
johnnystarr
Newbie
 
Posts: 3
Joined: 2017-11-11 @ 01:36

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby Rodoko » 2017-11-11 @ 05:17

Well, what you can do is put a CD in the drive before accessing to D:

Is like a floppy, when you don't have a floppy inserted on the drive nothing happens xD

Now to the serious part:

Double check that the settings in config.sys and autoexec.bat are correct, here is an example of my own way

autoexec.bat

MSCDEX /D:MSCD001

config.sys

DEVICE:C:\DOS\OAKCDROM.SYS /D:MSCD001

Give my tips a try, it should work, if it doesn't work you need to take the CD drive apart and clean the lens, sometimes humidity and dust from being stored in the box can make the lens foggy or dirty, rendering them unable to read

P.D: Almost forgot, when you turn on the machine open the drive and close it to check if it works correctly on the logic and motor side BTW ;3
User avatar
Rodoko
Newbie
 
Posts: 46
Joined: 2015-5-04 @ 22:00

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby johnnystarr » 2017-11-11 @ 05:27

Thanks @Rodoko for the tips. I'll need to check the lense for sure. Everything else checks out.
johnnystarr
Newbie
 
Posts: 3
Joined: 2017-11-11 @ 01:36

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby Mister Xiado » 2017-11-11 @ 05:28

In addition to that which has already been stated, remember the first rule of technical troubleshooting: replace suspected bad with known good. Test the drive in another system without such issues, test a known-working drive in the system with the issues.
The Homepage of the Oldternet - Where it's always 1992 (or so).
Many a C64 - Radio Shack TRS-80 CoCo 2 - HP Vectra 486 66/XM - K6-2 300 -
Mac Plus - rebuilding a vast collection wrongfully taken from me.
User avatar
Mister Xiado
Newbie
 
Posts: 65
Joined: 2017-9-12 @ 23:04

Re: Socket 7 Motherboard not assigning drive letter to CDROM

Postby .legaCy » 2017-11-12 @ 15:20

I like PhilsComputerLab ms-dos startup menu, it have everything done, you just need to personalize it for your hardware.
If you like retro hardware and retro gaming videos please visit my YouTube channel
https://www.youtube.com/channel/UCSZiFV ... zNa30_DYTg
User avatar
.legaCy
Member
 
Posts: 194
Joined: 2016-4-08 @ 23:11
Location: Brazil


Return to General Old Hardware

Who is online

Users browsing this forum: debs3759, DerZocker, ElDavo, quicknick, ShenTao, Zup and 10 guests