PnP Sound Blasters not detected on i430TX

Discussion about old PC hardware.

PnP Sound Blasters not detected on i430TX

Postby Dracolich » 2017-12-20 @ 01:47

Hello all, I'm new here and this is my first post. I hope someone can help. I've searched these forums and Google numerous times, trying every idea I've found, with no luck.

Back during early summer I rebuilt my MS-DOS rig using the following:
QDI Titanium IB i430TX with BIOS 1.3s
AMD K6-233 with socketA heatsink+fan
128MB SDRAM
2x USB connected to mobo header
2.6GB primary master, CD/DVD primary slave
18GB secondary master, Zip250 secondary slave
4MB S3 Virge/GX
4MB Voodoo1
D-Link DFE 530TX+ RevD2
CT2260 (non PnP) with YMF262
Dual boot MS-DOS 7.1+Win3.11 and FreeDOS 1.0

My problem is this:
I also have a CT4500 AWE64 value. CTCU and CTCM cannot find it on this mobo in any of the three ISA slots. The card is clean and works on an FIC PA-2007, so I know the card is good. My CT2260 works on this mobo in all three slots, so I know the board and slots are good. Before discarding a box of extra parts, I also had a CT2950 and CT4170 PnP cards. I had tried them as well in all three ISA slots and they did not work either.

CTCU never shows a card, and CTCM shows version information (1.08) but no card information. This morning I tried manually editing the ctpnp.cfg and setting it read-only, but CTCM still doesn't show the card. DIAGNOSE displays a failure setting the base I/O address. I tried all I/O address options available; 220, 240, 260, and 280, but none works. I also tried booting a DOS 6.22 floppy then running CTCU but still doesn't show the card. When I boot the original installation CD, and attempt the Win31 installation it gives the same base I/O address errors as DIAGNOSE. I remember when I last tried the CT4170, I ran the installation CD and got the same base I/O address errors.

In BIOS I've disabled LPT, IR and COM ports, I've tried with PnP OS both on and off, and I've tried with resources both auto and manual. When on manual, I made sure the desired IRQ and DMA were PCI/ISA PnP. I cannot disable the USB because it is needed for a connection to a KVM. I believe I am using the correct ctcmbbs and sbbasic, "MS-DOS mode of Windows 9x" downloaded from philscomputerlab. I also used setver for CTCM and CTCU, set to 6.00. I had also tried with the Voodoo and nic removed, but no luck.

Any ideas, or does anyone see a hardware combination that could be interfering with ISA PnP? Before the S3 Virge, I used an 8MB Permedia2. It made no difference with the sound cards. I remember years ago, then running Win98, having the same problem with this card on this mobo and switched to the FIC mobo. I cannot do that now as I used that mobo in another rig for my mom :happy:

The 2.6GB is partition as 1.6GB MS-DOS FAT16 and 1.0GB OS/2 Warp. The 18GB is FAT32 and is where all of the games and other application software is installed, so I need DOS 7 or FreeDOS to use this drive. I do have a spare Intel 200MMX cpu I could swap with and a 64MB SDRAM to downgrade if cpu and/or ram might be factors. I might have already tried the Intel cpu, don't remember now, and I might have also already tried 64MB or less RAM. It was so long ago... Am I better off staying with the CT2260? Would the AWE64 be enough difference in games such as Doom and Duke3D to make it worth more effort?

I just can't believe that out of a printer paper box full of loose parts, all three PnP Sound Blaster cards would have died but not the 2260, a 4810, Philips Rhythmic Edge, and various video cards. :wink:
Dracolich
Newbie
 
Posts: 31
Joined: 2017-8-07 @ 13:45

Re: PnP Sound Blasters not detected on i430TX

Postby Dracolich » 2018-6-07 @ 16:06

It's been a while but I want to drop an update. I've tried a few more times to get the AWE64 working on my QDI board to no avail. I've tried every DOS/Win 3.x driver I can find, including the CTCM and CTCU modified to remove a windows check. None work and most times CTCM freezes the pc, and CTCM /T shows the message about test mode but still does not find a card. Also tried removing the NIC and Voodoo cards, tried swapping the AMD cpu with an Intel, tried changing C: from FAT32 to FAT16, tried booting a DOS 6.22 boot disk, tried PnP OS on and off in BIOS and also resources between auto and manual.

I finally had a chance to visit my mom, where the pc with the PA-2007 board is, and spent a few minutes to swap the PCI CT4740 with the AWE64. Right away it appears on the POST screen:
Code: Select all
Initializing Plug and Play cards...
Card-01 Creative SB AWE64 PnP


The QDI board does not show any similar message - nothing that indicates PnP detection. I noticed the PA-2007 is Award BIOS 4.51PG Version 1.09CD12. The QDI board is also 4.51PG but Version 1.3s. For now I am leaving the AWE64 on the FIC board and continuing to use the non-PnP CT2260 on the QDI, and maybe get a Dreamblaster DB50XG-based daughterboard.
Dracolich
Newbie
 
Posts: 31
Joined: 2017-8-07 @ 13:45

Re: PnP Sound Blasters not detected on i430TX

Postby Pabloz » 2018-6-07 @ 23:24

i have mix experiences with PNP cards
they are supposed to work without any installer or anything in autoexec.bat

but sometimes when running a game i get no sound
and when i exit and run it again , sound is detected.
Like a lottery for it to get detected by the game.
Pabloz
Member
 
Posts: 227
Joined: 2017-4-22 @ 22:36


Return to General Old Hardware

Who is online

Users browsing this forum: Batyra, Errius, luckybob, modbus, Robert B and 22 guests