New CMOS batteries won't keep date/time, HDD settings ...

Discussion about old PC hardware.

New CMOS batteries won't keep date/time, HDD settings ...

Postby obcbeatle » 2019-1-08 @ 04:39

I have an old PC (MTI R534F MUSTANG motherboard with a Cyrix 6x86L CPU) that won't keep time within BIOS/Win98SE after installing new CMOS batteries (I've tried two new batteries so far ... button CR2032's). The PC loses date and time after being powered off for a couple hours. And it recently also lost the BIOS HDD settings too after being off for about a week. I don't see any problems with the battery holder. Am I using the correct battery? I'm pretty sure it was an original/ dead CR2032 that I replaced with new CR2032's. Or maybe this is a problem with an old BIOS/mobo? Any advice appreciated. Thank you.
obcbeatle
Newbie
 
Posts: 50
Joined: 2018-11-17 @ 14:56

Re: New CMOS batteries won't keep date/time, HDD settings ...

Postby dionb » 2019-1-08 @ 09:35

First suspect is JP25, pins 1-2 need to be covered for normal operation. Check that jumper, if it's missing it could lead to strange behaviour, and if it's on 2-3 (CMOS CLR), it's pretty clear that it won't keep settings.

Second would be BIOS. It's pretty obscure, but I know of at least one instance (GVC FR520, also with a SiS chipset) where an old BIOS revision led to the CMOS battery being discharged in very short time indeed. A later BIOS update fixed that. No idea about MTI boards (never seen one in the flesh myself), but something to look into if JP25 seems OK.
User avatar
dionb
Oldbie
 
Posts: 1391
Joined: 2017-12-23 @ 15:35
Location: Amsterdam

Re: New CMOS batteries won't keep date/time, HDD settings ...

Postby obcbeatle » 2019-1-11 @ 13:41

Thanks dionb ... J25 pins 1-2 are covered. I'll see what I can find out about this old BIOS this weekend.
obcbeatle
Newbie
 
Posts: 50
Joined: 2018-11-17 @ 14:56

Re: New CMOS batteries won't keep date/time, HDD settings ...

Postby obcbeatle » 2019-1-16 @ 22:19

So I Googled the BIOS of this old Mustang motherboard (ROM PCI/ISA BIOS (2A5IHR0C) Standard CMOS Setup Award Software, Inc.) ... specifically BIOS 2A5IHR0C ... and came up with one website that has a BIOS update (I think) for this board. But it's not an Award website. And it's not clear whether the download is a BIOS upgrade. So I'm too shy to try upgrading the BIOS.

Sooo ... after powering off/on this board for about a week ... I still get the same behavior ... even when trying a third new battery:

*When powered off for 24 hours ... the BIOS/Win98SE loses a day ... and loses the time.

I guess not a big deal because I can set the correct time in the BIOS when I first turn it on ... but I do use this old PC somewhat regularly for a couple old DOS games. I can play those games in DOSBox on an XP PC too ... but it's more fun on this older PC :-)

Anyway ... one question I have is ... is there anything else I can try besides upgrading the BIOS to see if I can keep this board in correct date/time?

PS: Just remembered ... I believe this board will also lose the HDD settings if off for like over a week. I haven't tested for that again ... but I know it lost the HDD setting recently when it was powered off for about a week. Again ... not a big deal because I can reset the HDD info. ... but kind of a pain. Just wondering.
obcbeatle
Newbie
 
Posts: 50
Joined: 2018-11-17 @ 14:56


Return to General Old Hardware

Who is online

Users browsing this forum: Google [Bot] and 14 guests