[SUCCESS!] Old KEnitec 286 Plus (suntac) Rescue, will need help.

Discussion about old PC hardware.

[SUCCESS!] Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-08 @ 20:21

Hello, im new to the forum, im from Catalonia so english its not my native languaje, but ill try.

I've recenly picked an old Kenitec 286 plus from a dusty warehouse, but its not working at all, may be i can get some help in here...

Image

First things first, the specs:

- 286 processor at ??mhz (since cant boot)
- Motherboard is "suntac 286-12" well not exactly, but it is the same in this post: https://www.vogons.org/viewtopic.php?t=35883
- Memory Unknown....may be 2 Mb or 640Kb
- HDD 20MB 5.25" ST225
- FDD 1.2MB 5.25"
- Controller card for 2 HDD and 2 FDD
- Graphics card: Peaktron electronics (CGA ¿?)
- Coaxial network card
- Monitor 14hp33t 14" monochrome, 9 pins. Dont know if its working, because computer wont start.

Now the problem. On switch on, PSU starts functioning, and leds on computer, HDD and screen turn on, but:

- No beeps at all
- No image at all

Today got some time and discovered some corrosion arround the keyboard DIN connector and battery, so i've removed both and did some cleaning. Also tested the most damaged paths, all OK.

Now i've tested the PSU giving me some high volt values:

5V -> 8V
12V -> 19V

Thats pretty high, but hey... thats ancient tecnology, may be its normal?? any ideas?

My next steps are:
- Get advide here :D
- Buy a isa VGA card, so i can test it on a 15 pin VGA monitor.
- Test more components?¿ witch?

Here are some pictures:

Image
Image
Image
Image

And some other pics: https://imgur.com/a/ecfzVuc
Last edited by Montserrat on 2019-3-27 @ 20:25, edited 1 time in total.
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-09 @ 12:49

Hi, nice board and well done repair.

No, your Voltages are _not_ OK. But as the Other components are running...maybe its a wrong measurement?

For further diagnostic a VGA will not help you. You should order a POST-card first (~ 4 €) and/or a TL866 (~30 €) to test your Bios and program some diagnostic ROMs if neccessary.
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Vynix » 2019-2-09 @ 13:57

Can you take a picture of the CPU? It's really hard to tell which 286 version you have (on the picture however, I see that it's an Intel, that's a given) as the picture is kinda blurry.

It should have a number like this written on it: 80286-NN where "NN" is the frequency of the CPU (e.g: 80286-12 would be a 12 MHz chip while 80286-8 would be a 8 MHz version), that should help you determine the frequency of the CPU without having to boot it.

By the way, Kenitec was a French company, it's quite surprising to see that one has ended up in Catalonia :-D

Oh and your voltages are obviously too high, either your power supply is not giving the correct voltages or either it's a wrong measurement.
Last edited by Vynix on 2019-2-09 @ 20:48, edited 1 time in total.
Vynix
Newbie
 
Posts: 67
Joined: 2018-12-11 @ 11:06
Location: France

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-09 @ 19:11

Hi, thanks for the replys,

- About PSU, tomorrow will open it and check for acid leaks, will take some pictures.

- About the diagnosis card found some on amazon for 4€, or 10€ fast shipping, you meant those? Where can i find reference for the error codes?

https://www.amazon.es/gp/product/B07MDX2S1L?pf_rd_p=fe1ee12e-2ecc-412d-a7b9-b47624d1ea7b&pf_rd_r=YPMSAQH3ZXTCMYVXXW4T

- About the TL866, well i was waiting for an excuse to buy one cause i wanted to flash a Sega Mega CD BIOS, but didnt wanted to spend so much...i got my excuse...hehe. But anyways ill wait until the programmer is mandatory.

- About CPU pictures, i will take them tomorrow morning using a reflex, i need more light, since its engraved barelly legible.

Also checked the keyboard dim conector and seems ok, so im gonna reuse it, now its cleaning the corrosion:

Image

PD: Well from Barcelona to France there is about a couple of hours or less in car, is not that far :D.
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-09 @ 19:31

Montserrat wrote:

- About the diagnosis card found some on amazon for 4€, or 10€ fast shipping, you meant those? Where can i find reference for the error codes?

https://www.amazon.es/gp/product/B07MDX2S1L?pf_rd_p=fe1ee12e-2ecc-412d-a7b9-b47624d1ea7b&pf_rd_r=YPMSAQH3ZXTCMYVXXW4T


Yes, order it, worth every pence ;-) You will fnd codes via google.

If you have your Tl866, can you please provide your BIOS+Board here? ;-)
viewtopic.php?f=46&t=53419&p=729853
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-10 @ 10:57

Ok, did the pictures and checked the PSU. I will use picture links because the are on hi res, Lets see:

- About the CPU -> https://imgur.com/jg4EBuA So its N80286-12

- About the PSU :
https://i.imgur.com/rgq61cz.jpg
https://i.imgur.com/BrYSBQ3.jpg
https://i.imgur.com/WqKF56o.jpg -> Whats that yellowish mess, it leakead from big capacitors?

- About the BIOS, the motherboard its AMA-1240V1-D, and the bios is labeled as a Phoenix, seems that this board its already posted on that thread.

Back to the main problem, PSU is giving ludicrous voltage outputs, even today gave me 200v on the 12v rail!, so well....unless this board has some kind of electric protection circuit...we can asume its totally fried.

Im searching for some schematics, or visual inspection to check on that, but have no idea how to find them.

Also added some more pictures of the chipset, oscilators, memory, etc to a gallery -> https://imgur.com/gallery/ecfzVuc
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby quicknick » 2019-2-10 @ 11:31

There's nothing wrong (visually, at least) with your PSU. The yellow stuff is some kind of glue that they use on the larger capacitors to keep them in place. Other than this, I suspect your multimeter plays tricks on you. I can see a 16V capacitor that filters the 12V rail, if that were to go up to 200V the capacitor would be blown to small pieces (and even at 19V I think it would leak or swell).
User avatar
quicknick
Member
 
Posts: 238
Joined: 2017-10-30 @ 23:53

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-10 @ 12:00

Agree ;-)

How do you measure voltage? AC or DC? ;-)
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-10 @ 14:34

Just checked my multimeter in DC....aaaand its gone haha. a 1,2v AA batery gives 2+v, and my everyday computer PSU is giving exact same values of that 286 PSU, 5v -> 8v and 12v -> 19v. So yes i need a new multimeter...didnt realized when it broke.

Well thats good news for the 286... so im buying the Diagnostics post card...and a new multimeter. (and the money starts fading away....)

Also checked the 286 pc speaker in my computer and its working.
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby computerguy08 » 2019-2-10 @ 22:05

Had an identical Suntac board a while ago. Mine was unfortunately not salvageable, because someone destroyed the CPU socket before I got it and my attempt to replace the socket failed, so I had to scrap it.
Not to mention it had battery leak corrosion as well.

Wish you luck with your board rescue.
User avatar
computerguy08
Newbie
 
Posts: 12
Joined: 2019-2-02 @ 16:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-11 @ 14:59

Ok, i have now the POST card, and a new multimeter.

- About the PSU, i can now read correct vaules with new multimeter, 5v and 12v respectively, soy PSU its working normally.

- Used the POST CARD, and got 2 different error codes:

- If i use slots 1 to 6 i got error code 01, wich in the reference manual for the phoenix bios means bad CPU. So first thing i did is extract CPU and put it again, but no luck.

- If use slots 7 or 8, i get error code A1, wich in the reference means "check keylock". I think it means the actual key lock on the front of the PC? in any case, i double checked it was conected nad in "OPEN" position (i have the keys).

Well...whats the next step? need a new cpu? or may be its a problem of the bios rom?? they got exposed to daylight, the stickers felt off easily.

Here a little video and a pic of the stickers: https://youtu.be/X6YFNI2ut6w

Image
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-11 @ 16:43

Not allowed to see that video.

But: Are you sure that codes are not displayed randomly? Should be the same in all slots.

Its for sure not the CPU, otherwise it would only display "--" on the card.

To make sure these are not random values: Look at the POST-history on the card: Press the buttom several times and note each value.

If the values are not random but there is a order: Then we know CPU+BIOS are OK.
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-11 @ 18:52

Video is now public: https://youtu.be/X6YFNI2ut6w

Also, the keyboard din conector is again soldered to the board, and working. Keyboard leds flash once on power on. Still i get same error codes depending on the slot the POST CARD is in.

I've navigated into the POST CARD "historic" but no other error codes are found, unless im doing wrong.
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-11 @ 19:14

Interesting...and you can reproduce your results? Never seen to get different codes in different slots...

I am quite sure your CPU+ROM are working. The 00 indicates the start of the POST sequence. You can try to remove one ROM and I think your will see only "--" on the card. When you remove the ROM, is the IRDY still blinking that way? Thats not normal.

But honestly, I dont have an idea where the mistake is. I think its related to your battery damage. Look for example on your DM7406 - you can see the green residue almost going ito the ceramic case. Would not be surpsrised if this one is damaged. But I dont know what its function is...
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-11 @ 21:28

Predator99 wrote:Interesting...and you can reproduce your results? Never seen to get different codes in different slots...

I am quite sure your CPU+ROM are working. The 00 indicates the start of the POST sequence. You can try to remove one ROM and I think your will see only "--" on the card. When you remove the ROM, is the IRDY still blinking that way? Thats not normal.

But honestly, I dont have an idea where the mistake is. I think its related to your battery damage. Look for example on your DM7406 - you can see the green residue almost going ito the ceramic case. Would not be surpsrised if this one is damaged. But I dont know what its function is...


Yes i can reproduce the results every time.

But i cant see any 00?¿ . Meanwhile i've extracted the roms as you said and yes i got the "-- --" on the post card.

Also, inspected the DM7406, it seems in good shape to me, no corrosion, what is this part doing? how can i test it?
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby suntac » 2019-2-11 @ 21:50

It is not exactly the same model, but there are some schematics:
http://minuszerodegrees.net/manuals/Suntac/Suntac%20HT-286.pdf
suntac
Newbie
 
Posts: 82
Joined: 2018-4-30 @ 11:16

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-13 @ 14:18

Just now, Was about to check components, powered on and suddenly got a beep-code...but im unable to reproduce,dont know why beeped, and it was so unexpected i cant remember the code ...

Also now i've checked all the resistances in the board (at least what i can identify as resistance), and got 6 with value error below his own tolerance (all golden 5%), but since i dont know much about electronics, dont know if its relevant or not. The rest are ok. Should i replace those?

Image
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Predator99 » 2019-2-13 @ 17:13

No, do not replace them! You are not measuring the resistors but also the circuit around them. Resistors will not fail.

Was it a beep code with a pattern in it? Wait one day and power on again tomorrow with your VGA and POST card installed.
Predator99
Oldbie
 
Posts: 883
Joined: 2016-12-28 @ 19:09

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby Montserrat » 2019-2-13 @ 19:33

Predator99 wrote:No, do not replace them! You are not measuring the resistors but also the circuit around them. Resistors will not fail.

Was it a beep code with a pattern in it? Wait one day and power on again tomorrow with your VGA and POST card installed.


Ah, true, did not realized that! thanks!

The beep was like 3 normal beeps (not long) an then 2 shorts, but i cant really be sure because got me by surprise, Tomorrow will try that, on video :D
Last edited by Montserrat on 2019-2-13 @ 19:47, edited 1 time in total.
Montserrat
Newbie
 
Posts: 69
Joined: 2019-2-08 @ 19:40

Re: Old KEnitec 286 Plus (suntac) Rescue, will need help.

Postby root42 » 2019-2-13 @ 19:41

Predator99 wrote:No, do not replace them! You are not measuring the resistors but also the circuit around them. Resistors will not fail.


If they DO fail it would be quite spectacular, I guess. :D
Soldering, retro game reviews and more on YouTube and Bonus videos
Me playing games on my 286 and on my Sega MD2 on Twitch
80386DX@25 MHz, 8 MiB RAM, Tseng ET4000 1 MiB, schlae AdLib, PC MIDI Card + SC55MkII, XT CF Lite, OSSC 1.6
User avatar
root42
Oldbie
 
Posts: 983
Joined: 2018-1-27 @ 13:23

Next

Return to General Old Hardware

Who is online

Users browsing this forum: kaputnik, Scandy and 7 guests