Just got my first retro laptop!

Discussion about old PC hardware.

Just got my first retro laptop!

Postby Elia1995 » 2019-7-09 @ 20:59

Hi guys! It's been a long time since I've visited VOGONS, but I've been super busy with University, these months and a few weeks ago I finally graduated, so I finally got that sweet free time I've been looking for a while!

Today, a friend gifted me a Mitac 5033, a retro laptop from the late '90s. It's in almost pristine conditions, besides a missing switch on the top of the LCD screen to lock/unlock the screen and the battery being totally DEAD, it must be plugged in the whole time to use it.

So far, the only specs I managed to pull out of this computer, are the following:
    CPU: AMD K6-2 366MHz
    RAM: 32MB, unknown type (probably SDRAM)
    4 GB HDD with Windows 98

I tried to look what audio card there is, since there's sound, but all I get from the sound control panel, is "ESS Audio" or something like that...

There's also a working CD drive and a floppy drive which I've yet to try...

However, there are a couple of problems that I've encountered so far, but hopefully are resolvable: first of all, the computer randomly shuts down on its own, just blanks out and turns off, all while powered directly by the AC adapter, due to the dead battery... probably it's just overheating, so I'll try using some fans underneath and check if it'll stop doing that.
The second thing, is that the CMOS battery is also obviously dead, but I couldn't find any info online on where it is located and how to disassemble this laptop...
I can't wait to test my DOS collection on this laptop, tho, I'm sure it's gonna handle any DOS game from the '90s just fine, and maybe some Windows 3.x / 9.x ones too!
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 648
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Just got my first retro laptop!

Postby keenmaster486 » 2019-7-09 @ 21:21

Hmm, interesting! I wonder what kind of audio and graphics chips it has?
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
Vintage desktops: Pentium/MMX 233 (Win95), 286-12 (MS-DOS 5.0)
Vintage laptops: IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1681
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: Just got my first retro laptop!

Postby mothergoose729 » 2019-7-09 @ 21:31

Congrats! What a neat little machine.

ESS Audio could be a good sign. ESS made the best sound blaster clones, although some models are better than others. You can also add a opl3lpt for sound later on, assuming it has a parallel port.
mothergoose729
Member
 
Posts: 264
Joined: 2018-4-10 @ 03:04

Re: Just got my first retro laptop!

Postby Elia1995 » 2019-7-09 @ 22:35

keenmaster486 wrote:Hmm, interesting! I wonder what kind of audio and graphics chips it has?


No idea about the actual models yet, as I now have to deal and fix this "spontaneous shutting down" problem first

mothergoose729 wrote:Congrats! What a neat little machine.

ESS Audio could be a good sign. ESS made the best sound blaster clones, although some models are better than others. You can also add a opl3lpt for sound later on, assuming it has a parallel port.



Yeah, it does have a parallel port! And even an USB port too!
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 648
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Just got my first retro laptop!

Postby keenmaster486 » 2019-7-09 @ 23:09

The spontaneous shutting down could simply be due to an intermittent short in your AC adapter or power jack.
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
Vintage desktops: Pentium/MMX 233 (Win95), 286-12 (MS-DOS 5.0)
Vintage laptops: IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1681
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: Just got my first retro laptop!

Postby henryVK » 2019-7-10 @ 07:39

Supposedly this was also branded IPC TopNote and Fujitsu Liteline!

Should have an ESS1869 soundchip and Trident 9660 graphics!

Let's see some pics when you get it up and running :happy:
User avatar
henryVK
Member
 
Posts: 254
Joined: 2017-12-29 @ 20:26
Location: Europe

Re: Just got my first retro laptop!

Postby Elia1995 » 2019-7-12 @ 07:13

The shutting down is random, sometimes it's very stable and lasts for over an hour, other times it shuts down after 10 minutes of usage...

I noticed that the first times a day that I use it, is when it lasts longer, then the AC adapter builds heat and starts shutting down the PC randomly like that...

I'm now gonna try and put some DOS games in it, if the AC adapter allows me, starting with demanding ones, such as Duke Nukem 3D, Blood and Quake... I think that a 366 MHz CPU like that should handle them just fine!
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 648
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Just got my first retro laptop!

Postby henryVK » 2019-7-12 @ 09:06

You should test with a different (universal) AC adapter to see if that is what's causing the shutdowns.

And don't wait too long with that dead CMOS battery. It might already be leaking all over the insides!

According to these guys here, the battery should be under the palm rest

https://forums.techguy.org/threads/solv ... em.212988/

The CMOS backup battery is located under the palm rest and to change it out you need to remove the four screws along the lower front side of the case. This battery needs to be changed ever few years and the laptop may NOT boot if this battery is dead. The battery cost is under $5.00 and so I suggest that you change it once a year to be safe. Be careful opening the LCD lid after removing the four retaining screws - the lid latch tends to pick-up the palm rest when you open the lid to remove the palm rest and if you don't hold the palm rest down to prevent this then the lid latch can break off as the lid is pulled up.
User avatar
henryVK
Member
 
Posts: 254
Joined: 2017-12-29 @ 20:26
Location: Europe

Re: Just got my first retro laptop!

Postby Elia1995 » 2019-7-12 @ 09:08

"The computer may NOT boot if this battery is dead" ... well, since mine boots, then I guess it ain't dead? :|

There's actually one way I can still test it before changing it, I'll set the date and time, if date and time will remain consistent, then it's definitely not dead.


EDIT: Here's some news. The audio card is an ES1869, it plays MIDI music on DOS games when I set them with "General MIDI" off the speakers I plugged in its audio out jack.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 648
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: Just got my first retro laptop!

Postby aaronkatrini » 2019-7-12 @ 11:35

Put a fan to that psu xD
aaronkatrini
Newbie
 
Posts: 48
Joined: 2018-5-28 @ 14:32

Re: Just got my first retro laptop!

Postby mothergoose729 » 2019-7-12 @ 19:15

Elia1995 wrote:"The computer may NOT boot if this battery is dead" ... well, since mine boots, then I guess it ain't dead? :|

There's actually one way I can still test it before changing it, I'll set the date and time, if date and time will remain consistent, then it's definitely not dead.


EDIT: Here's some news. The audio card is an ES1869, it plays MIDI music on DOS games when I set them with "General MIDI" off the speakers I plugged in its audio out jack.


Nice! According to their datasheet, that chip supports OPL3 emulation and ESFM. If you had to pick one sound card for all of DOS, this would probably be it. The FM synth in DOS games sounds 99% like a real OPL3, with the only major differences being with midi playback inside windows AFAIK.

https://www.diamondsystems.com/files/bi ... manual.pdf

It looks like the card is plug and play in DOS, but you if want more control over how it is configured you can try this driver

http://vogonsdrivers.com/getfile.php?fi ... enustate=0

This laptop looks excellent for DOS. The sound card is usually the biggest hurdle.

You can also experiment with a utility called setmul. If you disable L1 cache, you should be able to get somewhere around a 486DX66 for speed sensitive dos games. If the laptop bios lets you disable L2 cache, then you can get down to something around a 386DX33 or similar, which will cover most of your basis.

Certain mobile variants of the K II also can have their multiplier set in software. If that is the case then you have a really special machine on your hands. Worth trying at least.
mothergoose729
Member
 
Posts: 264
Joined: 2018-4-10 @ 03:04

Re: Just got my first retro laptop!

Postby LHN91 » 2019-7-12 @ 19:22

I actually find I prefer the sound of ESFM in some ways, so yeah. Looks like a really good DOS laptop if you can sort the minor issues.
LHN91
Member
 
Posts: 175
Joined: 2015-11-24 @ 15:54


Return to General Old Hardware

Who is online

Users browsing this forum: Google [Bot], istellabot [Bot], MMaximus and 14 guests