VOGONS


First post, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Hi,

i`m going to build a Turbo XT System with parts is got from various Sources 😀

Part 1: The Case

i got this one for free from the User 6502 from DosReloaded:.

photo_2020-02-02_19-19-25.jpg
Filename
photo_2020-02-02_19-19-25.jpg
File size
109.66 KiB
Views
340 views
File license
CC-BY-4.0
photo_2020-02-02_19-21-49.jpg
Filename
photo_2020-02-02_19-21-49.jpg
File size
209.12 KiB
Views
340 views
File license
CC-BY-4.0
photo_2020-02-02_19-49-45.jpg
Filename
photo_2020-02-02_19-49-45.jpg
File size
142.65 KiB
Views
340 views
File license
CC-BY-4.0
photo_2020-02-02_20-23-52.jpg
Filename
photo_2020-02-02_20-23-52.jpg
File size
113.52 KiB
Views
340 views
File license
CC-BY-4.0
Last edited by matze79 on 2020-02-03, 18:18. Edited 1 time in total.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 1 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Part 2: The Power Supply

A Quick Test was running and i measured 5V and 12V, then the FI switch kicked in.

So i opened the PS and got a Surprise:

photo_2020-02-03_18-31-23.jpg
Filename
photo_2020-02-03_18-31-23.jpg
File size
173.17 KiB
Views
338 views
File license
CC-BY-4.0
photo_2020-02-03_18-33-26.jpg
Filename
photo_2020-02-03_18-33-26.jpg
File size
84.67 KiB
Views
338 views
File license
CC-BY-4.0
photo_2020-02-03_18-35-19.jpg
Filename
photo_2020-02-03_18-35-19.jpg
File size
78.46 KiB
Views
338 views
File license
CC-BY-4.0
photo_2020-02-03_18-35-12.jpg
Filename
photo_2020-02-03_18-35-12.jpg
File size
69.72 KiB
Views
338 views
File license
CC-BY-4.0

Glueing some FR4 under the Broken PCB with Epoxy:

epoxy.jpg
Filename
epoxy.jpg
File size
63.78 KiB
Views
338 views
File license
CC-BY-4.0

Now it`s time to let everything dry 😁

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 2 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Part 3: The Drives

5,25" Drives (still untested)

Attachments

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 3 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

PCB repaired:

Epoxy and a quadratic FR4 piece make it as stable as new, drilled a new hole and now we ready to reattach it:

photo_2020-02-04_10-52-51.jpg
Filename
photo_2020-02-04_10-52-51.jpg
File size
64.92 KiB
Views
299 views
File license
CC-BY-4.0
photo_2020-02-04_10-58-54.jpg
Filename
photo_2020-02-04_10-58-54.jpg
File size
122.61 KiB
Views
299 views
File license
CC-BY-4.0
photo_2020-02-04_11-09-30.jpg
Filename
photo_2020-02-04_11-09-30.jpg
File size
76.39 KiB
Views
299 views
File license
CC-BY-4.0
photo_2020-02-04_11-11-50.jpg
Filename
photo_2020-02-04_11-11-50.jpg
File size
144.17 KiB
Views
299 views
File license
CC-BY-4.0

Caps for A-Matic Switching Power Supply:

photo_2020-02-04_20-31-03.jpg
Filename
photo_2020-02-04_20-31-03.jpg
File size
177.65 KiB
Views
242 views
File license
CC-BY-4.0
Last edited by matze79 on 2020-02-04, 19:31. Edited 1 time in total.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 4 of 15, by keropi

User metadata
Rank l33t++
Rank
l33t++

looking forward to see the components for the build!
so far great job 😀

🎵Link to buy a PCMIDI mpu
🎧Orpheus soundcard project
💻WTB Amstrad PC7486SLC-33 system

Reply 5 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Part 4: Mainboard

board.jpg
Filename
board.jpg
File size
197.24 KiB
Views
252 views
File license
CC-BY-4.0

Board installed 😀

A Unknown XT Board with Faraday Clone Chipset running the XT up to 9.54Mhz Speed.
I had real Fun finding a BIOS that works.

The Capacitors near PowerSupply are exchanged, there now 10uf Capacitors with 100nf X7R on the underside.

Turbo XT BIOS does only support 512Kb RAM on this Mainboard.
It does not enable the 128Kb Bank, sad..

So i sourced a BIOS from 1986! which works fine.
But is incombatible with VGA, it always shows Video Memory Bad if a VGA Card is inserted.

It also allows to Switch Speed with CTRL + Alt + "+", Default 4,77Mhz, 7,68Mhz and Turbo 9,54Mhz.
i would prefer booting at 9.54Mhz. But with this BIOS its not happen 😀

A Intel Above Board supplies another whopping 1,5Mbytes of EMS.

expansion.jpg
Filename
expansion.jpg
File size
180.36 KiB
Views
248 views
File license
CC-BY-4.0

from time to time i find some 41256 so i filled 3 Banks of Memory in few months.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 6 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Part 5: Expansionscards

I have a CGA Clone Card, but no Screen.. that sucks a a bit, as my Monitor is HGC only.

cga.jpg
Filename
cga.jpg
File size
236.75 KiB
Views
235 views
File license
CC-BY-4.0

The other Card is a Fullsize Zyxel Modem and fully Operating, i already tested it 😀

connect.jpg
Filename
connect.jpg
File size
109.76 KiB
Views
235 views
File license
CC-BY-4.0

For now i have to use a 16BIT Multi I/O Controller as Floppy Controller and a XTIDE CF Card, as i have no Period Correct Controllers yet.

The Videocard i will use until i get a nice Colour CGA Screen 😉

hgc.jpg
Filename
hgc.jpg
File size
195.03 KiB
Views
228 views
File license
CC-BY-4.0
Last edited by matze79 on 2020-02-04, 19:51. Edited 3 times in total.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 7 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

reserved

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 8 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Current State:

current.jpg
Filename
current.jpg
File size
88.45 KiB
Views
226 views
File license
CC-BY-4.0

Attachments

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 9 of 15, by Jo22

User metadata
Rank l33t
Rank
l33t
matze79 wrote on 2020-02-04, 19:41:

The Videocard i will use until i get a nice Colour CGA Screen 😉

Hey, what about using the CVBS (FBAS) output on a nice old TV set instead ?
The cheaper the TV set, the smoother/less-blocky the CGA graphics. 😉

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 10 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Yeah only have a 42" TV and it looks very bad, the Picture Jumps up and Down 😀

I also got a ATI Graphics Solution but the MM12 Monitor is incombatible with it. Can get the Picture on Hold.
I set it to Mono Screen but it does not work properly.

with the cheapo HGC Card everything is fine.

This is my XT:

9.54mhz_xt.jpg
Filename
9.54mhz_xt.jpg
File size
114.58 KiB
Views
176 views
File license
GPL-2.0-or-later

And IBM AT 286 6Mhz / 287 4Mhz:

6mhz_at.jpg
Filename
6mhz_at.jpg
File size
175.08 KiB
Views
176 views
File license
GPL-2.0-or-later

Tested Drives today and found 2 working 5,25" 😀 i`m glad they work!.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 11 of 15, by Jo22

User metadata
Rank l33t
Rank
l33t
matze79 wrote on 2020-02-06, 20:33:

Yeah only have a 42" TV and it looks very bad, the Picture Jumps up and Down 😀

Haha, I see. ^^ I've got the same issue anytime I use a CGA card.
Unlike MDA/Hercules, it doesn't use a proper 50Hz refresh rate, but is always de-tuned for some reason that's beyond me.. 😉
Anyway, using that V-Sync knob that you'll find on every video monitor really helps.

matze79 wrote on 2020-02-06, 20:33:

I also got a ATI Graphics Solution but the MM12 Monitor is incombatible with it. Can get the Picture on Hold.
I set it to Mono Screen but it does not work properly.

Hm. Sorry, I don't know what to recommend. Maybe the card is slightly off-frequency due to age, not sure.
Some Hercules had different crystals, so their frequency perhaps varried in the past also.
Or maybe it's the monitor that's a bit finicky here, not sure.

matze79 wrote on 2020-02-06, 20:33:

with the cheapo HGC Card everything is fine.

Hercules (aka Herkules or MGA - Monochrome Graphics Adapter) is awesome. It was very hi-res for its day and is on par with VGA in text-mode.
Speaking of VGA, some VGA cards even had an emulation mode of it. Because of this, I once thinkered with these little HGC compatible cards:
I thought myself "Why not the other way round, too ?" and experimented with a simple homebrew HGC-VGA adapter.
Unfortunately, it worked for me in text-mode only. Although it was supposed to not to (shoud work vice versa)..
See Hercules graphics on VGA monitors (mod)
By the way, if you're using a 286 CPU (maybe V20/30 or 80186, too ?) you can try out that C64 emulator.. It requires Hercules, too.
Re: "Childhood Embers" - 286 AT with Hercules graphics build

Edit: Not sure if you do know this, but CGA and Hercules can co-exist. Well, at least if only one screen page of Hercules is used (often the case).
That way, you can have a cool dual monitor setup! ^^ Simply enter MODE MONO for HGC and MODE CO80 or MODE CO40 for CGA (on DOS 5/6).

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 12 of 15, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie
matze79 wrote on 2020-02-04, 18:56:

So i sourced a BIOS from 1986! which works fine.
But is incombatible with VGA, it always shows Video Memory Bad if a VGA Card is inserted.

Nice PC!

Does it boot with Hercules+VGA installed?

Reply 13 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Yes, Hercules and VGA can coexist, i had this for long time in my PC until i moved to PCI only System.
Was useful for debugging and second Linux Console.

I got MFM Drives now.

But i need some tool to find all bad tracks to add them to the controllers defect managment list 😳
Spinrite woes, but disk boots fine.

Some testing:
Cloning C: to D:

https://www.youtube.com/watch?v=KsVa1xwzysA

80 Megs of rotating Steel ;D

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 14 of 15, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie
matze79 wrote on 2020-03-30, 13:07:

Yes, Hercules and VGA can coexist, i had this for long time in my PC until i moved to PCI only System.

Do they coexist in this PC? You could try to boot with Hercules as primary adapter and init VGA from DOS after booting. Would be interested if this is possible. If the XT-BIOS prevents the VGA from being initialized this should work.

Reply 15 of 15, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

no the XT will execute Option ROM on VGA this will automaticly make HGC second.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer