VOGONS


First post, by blacknite

User metadata
Rank Newbie
Rank
Newbie

Background:
Machine is a HP Pavilion 3100 with Pentium MMX 166 with 48MB of SDRAM.
I acquired the machine with no hard drive.
I put in a harddrive that already has Windows 98 SE on it from a previous build (40GB Quantum drive), It is recognized in the bios as ~8.5GB but the full 37Gb is seen in Windows. The BIOS also recognizes the CD Drive
Windows was able to boot without safe-mode from the old installation, however as to be expected it was missing many drivers, including the Plug and Play BIOS driver.
In an attempt to salvage this install I put my copy of Win 98 SE in the disc drive and found that the Activity light on the drive stays on when there is a disc inserted (I personally have never seen a PC do that before)
I also found that windows did not mount the disk drive. Unsure on the status of the CD drive I swapped is for a known good one (52X reader from 2000). It had the same "Activity LED stays on when the disc is inserted" so I assume that is a function of the BIOS. Still no D drive. At this point I decide that due to the lack of installed drivers I am not going to be able to get anywhere easily with this installation of Windows so I decide to start fresh. In a last ditch effort I instert the Win 98 SE boot disk and select "Start computer with CD-ROM support". This is where my real issue begins.

No matter if I attempt to "Start computer with CD-ROM support" or the Start Windows 98 Setup option I get the following result:
DOS gets to the Point of Mounting the CD drive and Hangs. The HDD LED is left blinking continously and the CD LED blinks continously. flashing cursor on screen. PC is frozen (NUM Lock not responsive when pressed).
If I eject the CD the HDD light stops flashing but the CD light does not.

I have attempted this with Plug and Play BIOS both on and off. Not Sure what to try next, was really hoping to use this as my Quarantine Machine.

Item to note:
The WIN 98 SE disc and Boot Floppy were both created last night. I used PowerISO to burn both the disc and the Floppy Image.

Reply 1 of 5, by wiretap

User metadata
Rank Oldbie
Rank
Oldbie

Cable problem -damaged, wrong position for the drive jumper, pins aligned properly?

Jumper problem - master/slave/CS?

IDE channel enabled in the BIOS?

Circuit Board Repair Manuals
Turbo Display Project
Dual Socket 8 Project

Reply 2 of 5, by blacknite

User metadata
Rank Newbie
Rank
Newbie

Cable damage is possible, I hadnt checked that, Will do when I get home.

Jumper is set to master. I can try CS when I get home, I believe that cable only has one connector on it. Its the 40-wire style cable, Likely original to the machine.

IDE channel is enabled in the BIOS and the drive is recogonized in the BIOS (Tatung CD-1216E) as the Secondary Master.

Reply 3 of 5, by pentiumspeed

User metadata
Rank Oldbie
Rank
Oldbie

Don't do that if the windows 98se can see more than 8GB on this 40gb hard drive and computer's hard ware sees hard drive as 8GB, as this causes issues. Partition the hard drive to one 8GB max and try again?

Cheers,

Great Northern aka Canada.

Reply 4 of 5, by chinny22

User metadata
Rank l33t
Rank
l33t

So just to confirm, you have 2 IDE cables in the PC.
Only device on the Primary is the HDD jumpered to Master
Only device on the Secondery is the CD-ROM also jumpered to master

If this is true and the device is attached to the last connector than that setup is correct and should work fine, jumpered as CS is also fine.

It's not uncommon for motherboards of this era to be limited to 8GB, BIOS update may resolve it but would agree with pentiumspeed your only as strong as your foundation and BIOS is right at the bottom of the system configuration.
If BIOS cant be setup correctly to recognize the 40GB drive (either by Auto or entering the config manually) I'd use drive overlay software.

Definitely change the IDE cable though, I also had issue once where I try to use 80pin cables everywhere but had 1 PC that refused to work unless it was 40pin, just something to keep in mind while troubleshooting.

Reply 5 of 5, by blacknite

User metadata
Rank Newbie
Rank
Newbie

Thanks all for the suggestions.

I didn't think its the 40GB drive but just to be sure I removed it from the system. The Windows 98 Setup should just bring up an error that it cant install because no hard drive is installed (which it eventually did.

Things I tried:
Full visual inspection of the IDE cable.
Swapping to the other installed IDE cable.
Swapping IDE Channels (chinny22 yes you are correct in the description of the setup with the exception of the IDE cables have only one connector each, both are already 40 wire)
Swapping Cd drives again
Reset the Bios
Finally I reversed the IDE cable.

Reversing the IDE cable finally got me a result, when I mean reverse, I mean plug the motherboard end into the CD drive and vice versa.
I'm still not sure of the installed CD-drive as I would get graphical errors when trying to boot from it (not sure how to post photos on this forum, not going to unless asked)
I was able get it working enough with the other CD-drive and booted dos with CD-ROM support, copied the /win98 folder to the C drive, and then booted back off the hard drive. Installed all the drivers using the win98 directory now on my hard drive and rebooted about 6 times.

The CD drive is now detected in windows now, so it was definitely a lack of drivers that was preventing it from showing up. Haven't tested it in Windows and I dont intend to.

On to the next challenge...