VOGONS


First post, by bloodem

User metadata
Rank Member
Rank
Member

Hi everyone,

I have a strange issue, which I noticed some time ago but it didn't bother me too much, however I'd really like to find a solution now.
I don't know if this is a common issue or it's something specific to my 1440p monitor (which, btw, is very retro friendly, supporting very high quality upscaling and aspect ratio correction even in MS-DOS).

So, the problem is that, for some reason, on my 1440p display , resolutions such as 1920 x 1440 / 1600 x 1200 are only available with driver versions 30.82 or older.
When using a driver such as 45.23 or newer, the max selectable resolution is 1920 x 1080 (and 1600 x 1200 / 1920 x 1440 are not possible anymore).
This is on VGA, by the way - I don't use DVI, because older nVidia cards have a blurry DVI output in DOS, while VGA is nice and crisp.

What I tried:
- Adding custom resolutions with PowerStrip: this did not work, after the resolution is added, PowerStrip asks for a restart to apply it, but the custom resolution is still not visible/selectable.
- Forcing different monitor types (such as old 1600 x 1200 CRTs) before installing the nVidia driver, but it doesn't make a difference, the newer drivers still see 1920 x 1080 as the max.

This issue is annoying, because I can only use my display's (almost) native resolution with older cards, such as GeForce 4 Ti 4600. And even if the Ti 4600 is a very powerful card for Windows 98, resolutions such as 1600 x 1200 or 1920 x 1440 are a bit too much for it to handle in some games. So a GeForce FX 5900 would be ideal, however that card requires newer drivers which, as I said, kill those resolutions (at least in my case).

Did anybody face similar issues and if yes, did you manage to solve them somehow?

2 x Socket 3 / 3 x Socket 7 / 4 x SuperSocket 7 / 4 x Slot 1 / 2 x Slot A / 5 x Socket 370
3 x Socket A / 1 x Socket 478 / 2 x Socket 754 / 3 x Socket 939 / 2 x LGA775 / 1 x LGA1155
Current rig: AM4 - Ryzen 5 3600X
Backup rig: LGA1151 - Core i7 7700k