VOGONS


First post, by Unite

User metadata
Rank Newbie
Rank
Newbie

This is been a bit of a battle for me so let me lay the story thus far.

I was gifted a Gravis Ultrasound Max 2.1. Awesome early Christmas present to say the least. Dropped it in the system and away it went sounding great in everything including Duke3D.

Tonight though I thought I'd get it set up properly. By that I mean I want it in my 486 rig along side my sound blaster clone (so I can retain adlib and opl synth) and I wanted to max out the memory to 1024kb.

So... First things first I added the memory, run the test program in setup and all is good. Then I put the sound blaster clone back in and this is where things go astray.

Firstly I've had a hell of a time getting the conflicts sorted. The GUS just plain didn't want to know on any base address other than 220 but that's fine since I can set the SB to 240. Next the IRQs. What a nightmare. Ended up having to disable ltp and com2 but that's fine since I never use them. I initially set the GUS as

Ultrasound IRQ 7
MIDI IRQ 3
DMA 1
Base 220

And the Sound Blaster clone as
IRQ 5
DMA 3
Base 240

This sort of worked. Games such as Pinball Illusions worked fine swapping the setting between the GUS and the SB. Transport Tycoon Deluxe though no sound from GUS.

To fix this I changed the GUS Midi IRQ to 11. I now get sound in Transport Tycoon but it's distorted. Might be a levels issue, need to look into this further. IRQ 11 is not ideal since I would normally use that for the network card but I suppose I could change that. Its no big deal really since the network card is only initialised as I need it.

Problem arrives with Duke3D. No music from the GUS no matter what I do. Not even if I remove the SB. The GUS with 1Mb ram has no sound in Duke.

So before I completely loose it with this system has anyone any suggestions firstly as to why some games work on some IRQs and not others with the GUS and why there is no sound in Duke? Or if anyone has any suggestion as to what settings to apply to these cards please let me know.

On another note I've got the line out of the GUS into the line in of the sound blaster clone which then runs to the speakers. While this works I'd prefer it the other way round but I can't figure out how to enable the line in on the gus. Don't see mixer anywhere.

The system specs are:

486DX2 66
32mb ram
S3 VLB graphics
PT607G IO card
Generic network card
Crystal sound blaster clone
Gravis Ultrasound Max 2.1

Just running DOS 6.22, no windows. GUS drivers are version 4.11

Reply 1 of 4, by alvaro84

User metadata
Rank Member
Rank
Member

I can only answer your last question for now: look for Ultramix, that's the Max's mixer under DOS.

Shame on us, doomed from the start
May God have mercy on our dirty little hearts

Reply 2 of 4, by dionb

User metadata
Rank l33t
Rank
l33t

Those resource allocations are a bit unconventional. Not sure if that's the issue you're hitting now, but those SB allocations in particular won't work on some games, and MIDI on something other than 2/9 is hit and miss too.

I'd go for:
SB:
A220
I5
D1

GUS:
A240
I 7
D 7 (all four of them!)

As for MIDI, are you using MegaEM or Ultramid? See here for tips on both (and when to use which): https://retronn.de/imports/gus_config_guide.html
EIther way, you probably want to set IRQ to 2/9

The thing that rings a bell here is:
"There exist a few games that do not implement dynamic loading of instrument samples with ULTRAMID. In this case ULTRAMID can be run with -c to preload instruments to the GUS RAM."

Reply 4 of 4, by Unite

User metadata
Rank Newbie
Rank
Newbie

I've been spent another good few hours on this today. I've changed the settings to 240,7,7,7,7 for GUS and 220,5,1 for the SB clone . Ultramix sorted the line in for me, thanks

With these settings Doom now doesn't work with the GUS. Most other things work fine. Still nothing in Duke. If I start megaem midi emulation works fine in the likes of monkey island but trying to lunch the Duke3D with this enabled resets the machine.

I'll take a look at that video northdale, thanks.