VOGONS


First post, by Tronix

User metadata
Rank Member
Rank
Member

Hello, i have old terminal board (just a board and nothing else):

BULL S.A CARTE LA2.1 290 108-00A NEP-14T

d604609cf93b4777b9d3c858c7673a19.jpg

I replace broken LED1 and LED2, traced the main power circuits and made a pinout of the blue connector J4:

cjcdm9l0xyziqqya9s4zu_j9q7o.png

So, I connect +5 and +12 to ATX power supply. Then i attach HSYNC, VSYNC and color components to MCE2VGA video coverter and started the board, it shows signs of life, but both LEDs are blinking and nothing is shown on the screen (gray rectangle). Once I touched something on the board and I managed to see an error message on the screen (Err. 4). I could not repeat this again for photo.

Some scopes,
/HSYNC:

Filename
20201021_570425.png
File size
7.88 KiB
Downloads
No downloads
File license
Public domain

VSYNC:

Filename
20201021_570607.png
File size
7.85 KiB
Downloads
No downloads
File license
Public domain

SCN2674BC4N40 CRT controller pin 16 /CCLK:

Filename
20201021_572813.png
File size
8.3 KiB
Downloads
No downloads
File license
Public domain

8088 pin 19 CLK:

Filename
20201021_572901.png
File size
8.46 KiB
Downloads
No downloads
File license
Public domain

I do not quite understand the purpose of the J7 (W1, W2, W3, W4) jumper block - he distributes the main clocks from crystal generators to both ASIC NEC logics ... Depending on some of its positions, the frequency of the HSYNC changes, maybe something else...
And W5 jumper around BOOT EPROM - without this jumper board does not init CRT controller, does't start blinking LED.

I dumped all *PROM from this board, they are all in the attached file.

So, any info wanted...

Attachments

  • Filename
    bull_terminal.zip
    File size
    8.01 KiB
    Downloads
    10 downloads
    File license
    Public domain