The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Announcements, advice, random banter, unrelated discussion, et cetera.

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Holering » 2014-8-28 @ 22:43

Where do I upload files? Should I just make an attachment and then tell you Malik? I have these http://www.vogons.org/download/file.php?id=15516, and I also have some ISOs with one I don't see on this thread (it's from 1998 and the original links appear to not work so great anymore).
Last edited by Holering on 2014-9-06 @ 01:05, edited 2 times in total.
Holering
 

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Robin4 » 2014-8-28 @ 23:01

~ At least it can do black and white~
User avatar
Robin4
Oldbie
 
Posts: 1925
Joined: 2011-4-04 @ 09:52
Location: THE NETHERLANDS

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Holering » 2014-8-28 @ 23:39

It's asking me to login. I don't even see anywhere to make credentials. I'll post the ISO here for now http://speedy.sh/jaqGd/Sound-Blaster-Live-Value-Installation-CD-1713330760.zip. I hope Malik or someone can put this in the repository sooner than later (speedy share links don't last forever).
Holering
 

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Stiletto » 2014-8-29 @ 02:15

Holering wrote:It's asking me to login. I don't even see anywhere to make credentials.


You PM SquallStrife, that's how you get an account there.
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 3758
Joined: 2002-7-01 @ 21:57

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Malik » 2014-9-04 @ 15:57

Hi!

Sorry, I've been busy with my post-graduate diploma, until April next year. But I'll be checking once in a while.

Yes, you can contact SquallStrife for getting the FTP account.

I'll try downloading it in the meantime.
User avatar
Malik
l33t
 
Posts: 2450
Joined: 2004-4-10 @ 14:37
Location: Malaysia

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Holering » 2014-9-06 @ 22:56

Contacted SquallStrife. Also told him about these drivers.

Live! WDM Win98 drivers for live! cards; even has newer version from march 2002 with troublesome sbpro emulation. All seem intact and authentic.
http://speedy.sh/R2exH/live-wdm-s.exe
Holering
 

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby maxtrix » 2015-4-20 @ 02:51

Hi, im looking for this CD ISO:

Image

I have this sb live! 5.1 sb0100.

The platinum version of this CD that is posted, can work with this model?
User avatar
maxtrix
Newbie
 
Posts: 12
Joined: 2015-4-03 @ 20:10

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby swaaye » 2015-7-09 @ 03:14

Does someone have the install CD for a X-Fi Titanium (SB0880)? I apparently don't have one.... I am looking to run the oldest drivers that support these cards.
swaaye
Moderator
 
Posts: 6911
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby vetz » 2015-7-09 @ 11:10

swaaye wrote:Does someone have the install CD for a X-Fi Titanium (SB0880)? I apparently don't have one.... I am looking to run the oldest drivers that support these cards.

I believe I do :)

I'll check and get back to you.
User avatar
vetz
l33t
 
Posts: 3122
Joined: 2012-4-23 @ 17:13

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby swaaye » 2015-7-15 @ 05:31

vetz wrote:I believe I do :)

I'll check and get back to you.

Any luck finding that CD?
swaaye
Moderator
 
Posts: 6911
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby swaaye » 2015-7-17 @ 00:49

I asked over on Beyond3D and someone posted a link to Alienware . They have downloads of what appear to be files off of the install CDs for various cards. The X-Fi Ti download has 2008 drivers. That sounds right to me.

http://support.alienware.com/Support_Pa ... 3&manu=15&
swaaye
Moderator
 
Posts: 6911
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby PhilsComputerLab » 2015-7-17 @ 00:59

I have read reports about OEM Alienware PCI X-Fi cards, that only work with Alienware drivers. Thanks for the link.

I've got 3x PCI X-Fi from eBay. A 460, 670 and 770. The 770 has this weird chip on the back of the card, and it's listen on that Alienware site. Awesome, because I could never get it going.

Also, I've got some newer driver CDs for PCIe cards like Titanium HD, Recon 3D, Z. Anyone interested?
User avatar
PhilsComputerLab
Hardware Mod
 
Posts: 6180
Joined: 2014-9-28 @ 03:33
Location: Western Australia

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby PeterLI » 2015-7-19 @ 00:29

-
Last edited by PeterLI on 2016-12-15 @ 18:09, edited 1 time in total.
PeterLI
l33t
 
Posts: 2392
Joined: 2013-10-18 @ 02:30

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby boxpressed » 2015-9-04 @ 21:37

I finally managed to score an AWE32 with a real OPL. Two of them, in fact: a CT2760 and a CT3900.

Right now, one of these will replace an AWE64 Gold. I had used the AWE64 Gold CD-ROM from Vogonsdrivers to install it, and it created the CTCM and SB16 directories.

If it makes sense to, I'd like to start fresh and either delete or rename those directories and install from AWE32-specific media.

I couldn't find a file on Vogonsdrivers that was specific to the CT2760 or CT3900. Can someone point me to the appropriate file? The one entitled "Sound Blaster AWE32 Driver Disk" probably has what I need, but there seems to be multiple versions of install disks within the file.

Thanks in advance!
User avatar
boxpressed
Oldbie
 
Posts: 1061
Joined: 2014-5-20 @ 18:29
Location: Wisconsin, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby pleonard » 2015-9-05 @ 02:09

PeterLI wrote:I found disk 1 of the CT5330.


Hey, thanks very much! Have a SoundBlaster Pro in a Ultimedia M57... am planning to figure out a way to tap into the front panel speaker connection some time soon.
pleonard
Newbie
 
Posts: 36
Joined: 2014-4-26 @ 17:59

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby Stiletto » 2015-9-05 @ 02:31

PeterLI wrote:I found disk 1 of the CT5330. The contents can be added to Vogons Drivers. They are available here:
https://drive.google.com/file/d/0B1s--Z ... sp=sharing

This is the Sound Blaster Pro MCV.


Uploaded, thanks.
http://www.vogonsdrivers.com/getfile.php?fileid=825
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 3758
Joined: 2002-7-01 @ 21:57

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby boxpressed » 2015-9-05 @ 17:08

boxpressed wrote:I finally managed to score an AWE32 with a real OPL. Two of them, in fact: a CT2760 and a CT3900.

Right now, one of these will replace an AWE64 Gold. I had used the AWE64 Gold CD-ROM from Vogonsdrivers to install it, and it created the CTCM and SB16 directories.

If it makes sense to, I'd like to start fresh and either delete or rename those directories and install from AWE32-specific media.

I couldn't find a file on Vogonsdrivers that was specific to the CT2760 or CT3900. Can someone point me to the appropriate file? The one entitled "Sound Blaster AWE32 Driver Disk" probably has what I need, but there seems to be multiple versions of install disks within the file.

Thanks in advance!


I assumed that since the CT2760 was the first model of the AWE32 that the file on vogonsdrivers with the separate floppy disk folders would be the right one to use. I was correct, and my CT2760 seems to be working just fine now.

I read somewhere else that the CD-ROM drivers for the PNP version work for the CT3900, so I'll try those later.
User avatar
boxpressed
Oldbie
 
Posts: 1061
Joined: 2014-5-20 @ 18:29
Location: Wisconsin, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby DolchFlexPAC » 2015-11-25 @ 18:30

Hi all - If anyone is interested, I still have my Creative Sound Blaster Live! PCI512 CT4830 sound card (see pics below), along with the 2 original CDs (Drivers & Live!Ware 2.0) the manual and the remote control accessories. I can upload ISOs of these if anyone would like - PM me.

As well, is there an 'official' CD for the Creative Soud Blaster 32 PnP ISA (CT3600), or is it the same disc that came with the AWE32? I have the AWE32 drivers working fine, but that's a different card and would prefer to have the exact software if there ever was a different CD.

http://imgur.com/CbpgZoK
http://imgur.com/hmCyqcb
http://imgur.com/MLNwOQa
http://imgur.com/rM6UPJp
http://imgur.com/uiiUNcE
http://imgur.com/bFUbs74
DolchFlexPAC
Newbie
 
Posts: 3
Joined: 2015-11-10 @ 16:27

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby boxpressed » 2015-11-29 @ 17:14

That's interesting that a Live! CT4830 came with a PCI512 install CD. I won't install another Live! unless I do so with the CD that was bundled with it. Way too many variants lead to installation problems.

I know that I would appreciate a link to those CDs. Not sure if they're on vogonsdrivers already.
User avatar
boxpressed
Oldbie
 
Posts: 1061
Joined: 2014-5-20 @ 18:29
Location: Wisconsin, USA

Re: The New Creative Labs Sound Blaster Drivers Collection. (Updated 6th Jan. 2014)

Postby DolchFlexPAC » 2015-12-01 @ 15:22

I see what you mean........ only the CT4820 and SB0150 were official PCI512s.....the CT4830 seems to have been an OEM card but certainly my card is what it is. Do you have a link for what should be the correct drivers CD for the 4830? I can install both discs and see what's up.

PS I would love to have access to Vogonsdrivers but still no reply from SquallStrife about enabling my Vogons account for the drivers side. I have a lot of old drivers I had archived on old 1X CD-Rs...... those TDKs and Kodaks cost me a fortune, back in the day of my 1X external SCSI Pinnacle RCD 5040 CD-recorder :)
DolchFlexPAC
Newbie
 
Posts: 3
Joined: 2015-11-10 @ 16:27

PreviousNext

Return to Milliways

Who is online

Users browsing this forum: Baidu [Spider] and 3 guests