SoftMPU project needs your help! (game & sound card testing)

Forum for discussion of bugs, code, and other aspects of SoftMPU.

Re: SoftMPU project needs your help! (game & sound card testing)

Postby bjwil1991 » 2017-10-05 @ 12:07

escarioth wrote:tryed the softmpu for some time now :)
lots of games are working great, cant say if something wrong goes after a while but
i can definetly hear music :) and pretty nice ones
Testing with a Roland MT-32 (old)
from a SB16 CT2950
Port:220 Irq:5 DMA:1 Midi:330
7th Guest - Works !
11th Hour - Not working at all, even with /delaysysex, would need help. (buffer overf.)
A-10 Tank killer - Wont work.. only sound no music. weird problem.
Beneath a steel sky - Works ! plays but movies seems to get problem with my current SB16.
Castle of Dr. Brain - Works !
Codename : iceman - Works !
Colonel's Bequest - Works !
Conquest of camelot - Works !
Companions of Xanth - Works ! (disable L1 cache)
Daggerfall - not working
Dark Force - Works !
Discworld - No Need for SoftMpu
Dungeon Hack - Works !
Dune - No Need for SoftMpu
Dune 2 - No need for Softmpu (but need patch for MT32)
Eye of Beholder III - No Need for SoftMpu
Elvira : Mistress of the Dark - Works !
Elvira : Jaws of Cerberus - Works !
Elvira : Waxworks - Works !
Gabriel Knight : Sins of the Father CD - Works ! (But need to patch text problem)
Hook - Works !
Hoyles Book 1 - Works !
Hoyles Book 2 - Works !
I have no mouth and i must scream - Works !
Indiana Jones : fate of atlantis - No Need for SoftMpu
King's Quest I AGI - Works !
King's Quest I SCI - Works !
King's Quest II AGI - Works !
King's Quest IV AGI - Works !
King's Quest IV SCI - Works !
King's quest V - Works !
Lands of Lore : Throne of Chaos - No need for Softmpu
Laura Bow : Dagger of Amon-ra - No Need for Softmpu
Leisure Suit Larry I SCI - Works !
Leisure Suit Larry III - Works !
Leisure Suit Larry V - Works !
Les Manley : Search for the King - Works !
Lode Runner Returns - No Need for softmpu
Loom - Works ! (need L1 Cache disabled)
Magic Carpet - No Need for Softmpu
Monkey Island I - Works ! (Need L1 cache disabled)
Monkey Island II - No Need for SoftMpu
Menzoberranzan - Works !
Phantasmagoria - No Need for Softmpu
Police Quest II - Works !
Princess Maker II - Not Working :( seems this is the irq 2/9 problem
Relentless - No Need for SoftMpu
Rise of the Dragon - No Need for SoftMpu
Silpheed - Works !
Simon the Sorcerer - Works !
Space Quest II AGI - Works !
Space Quest III AGI - Works !
Sid Meier's Civilization - no need for SoftMpu
Under a Killing Moon - No Need for SoftMpu
Veil of Darkness - Works !
Wayne's World - No Need for SoftMpu
X-com : UFO defense - No Need for SoftMpu
X-com Terror from the deep - Grr...i can only get Music to work if No sound is chosen, this problem is driving me crazy
Tie Fighters - No Need for SoftMpu
Zeliard - Works !
Thats all for now :) if something looks wrong, just tell me and ill double verify.
i may have made a mistake or two when i wrote all my configs

A-10 Tank Killer requires IRQ 2/9 for the MT-32 according to Compatible Intelligent Mode Games.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2-3, Custom FX-6300
User avatar
Posts: 1036
Joined: 2013-8-14 @ 03:10
Location: United States of America

Re: SoftMPU project needs your help! (game & sound card testing)

Postby escarioth » 2017-10-05 @ 22:26

oh damn XD
i didnt saw this one.
then it explain why :)
ill update my current infos
thx ;)
even if they're old....those old dos games are still the best!!!
User avatar
Posts: 43
Joined: 2016-10-01 @ 03:18

Re: SoftMPU project needs your help! (game & sound card testing)

Postby gmcn » 2017-10-10 @ 09:38

Hi everyone!

In the last days I refitted an old Thinkpad 570 for DOS gaming. It has a PII 333MHz, VESA-2.0-compliant graphics and a Crystal SoundFusion CS4280 PCI which emulates a SBPro with FM synth using a TSR to set Address/IRQ. Unfortunately the Gameport-MIDI interface is deactivated in DOS mode, it needs W9x to work.

So I built a serial interface for my first-gen Roland SC-55 using an Arduino. Basically, there is a Mosfet to level-shift the incoming RS232 signal and everything else is just the arduino and cables. It relays the 38400 Baud serial data from the PC to the Roland's 31250 Baud Midi in. The Setup is compatible with the Roland serial MIDI drivers for SC-55mkII and up on W3.11 and 95.

In DOS 6.22 I tried out SoftMPU with COM1 output. Here are my results:
Quest for Glory I -- Works (sounds terrible on the SC-55's MT-32 emulation though ;) )
Monkey Island I -- Works great (didn't even need to disable cache and works well with SC-55 in MT32 mode)
dosmid.exe (MIDI player) -- Works great, plays every MIDI file I throw at it

The Settlers II Gold -- Doesn't work. When I set it to play MIDIs instead of CD-Audio, the game will become choppy and there is no music. Game works fine, when set to use SBPro FM synth.
Sam & Max Hit the Road -- Freezes on startup if set to MPU401 output. Throttling CPU/disabling caches doesn't help. Game works fine with SBPro FM synth.

I tried all games with and without MPU interrupts enabled, did not make any difference. I did not try to set my soundcard to IRQ2/9 yet. I might try later today. Anyone else have experience with these last 2 games and SoftMPU?

Cheers and many thanks to the people developing this stuff in their free time :)

Update: Just tried setting IRQ to 2/9, unfortunately the SoundFusion config program only accepts 5 or 7. Guess I may be SOL with this sound hardware.
Posts: 1
Joined: 2017-10-10 @ 09:10

Re: SoftMPU project needs your help! (game & sound card testing)

Postby bjt » 2017-10-12 @ 15:00

Hi, unfortunately SoftMPU will only work with real-mode software. Believe both Settlers II and Sam & Max are protected mode.
This is a limitation of the port-trapping tech that SoftMPU uses. It isn't a problem for SoftMPU's primary application (intelligent mode games) as these are all older and real-mode, but it does restrict the serial output mode somewhat.

So this laptop has a gameport that works in Win9X? What about a Win9x DOS box?
User avatar
Posts: 1427
Joined: 2013-2-06 @ 10:40
Location: UK

Re: SoftMPU project needs your help! (game & sound card testing)

Postby escarioth » 2017-10-13 @ 04:20

Some new small update with 4 games (updated my big list on page 16)

Leisure Suit Larry VI - No Need for softmpu
Lure of the Temptress - Works ! but you need to use /Delaysysex, else overflow happens
Police Quest IV Open Season - No Need for softmpu
Space Quest IV - Works !
even if they're old....those old dos games are still the best!!!
User avatar
Posts: 43
Joined: 2016-10-01 @ 03:18

Re: SoftMPU project needs your help! (game & sound card testing)

Postby dr.zeissler » 2017-10-13 @ 08:30

Beside the fantastic support through softmpu, is there a way to get the SB digi-effects working on faster machines like a P4? Thx!
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
Posts: 1252
Joined: 2011-9-28 @ 15:33

Re: SoftMPU project needs your help! (game & sound card testing)

Postby AmiSapphire » 2017-10-30 @ 19:55

The onboard ESS ES1878 Audiodrive from the Compaq Armada 1573DM works well with SoftMPU and is supports port 2/9. The IRQ can either be changed in the BIOS or within Windows.


I do have a few cards that aren't on the sound card compatibility list (but I will have to retrieve my Socket 7 desktop from storage to test them):

Diamond branded K2Y-PRO16, (has OPTi 82C929A, uses Crystal CS4248-KL + Yamaha YM262-M) [does support IRQ 2/9]
Compaq Business Wavetable Sound Card (has ES1869F chip and onboard ES692S wavetable chip) [can't even remember if it supports IRQ 2/9]
Creative Sound Blaster CT2830 [does support IRQ 2/9, tested on apparent problematic 486]
Creative Sound Blaster AWE CT2760 (original revision) [does support IRQ 2/9, tested on apparent problematic 486]
Creative Sound Blaster CT3670 [Can't remember if it supports IRQ 2/9]

For the ones tested on the 486, I will test them again on the Socket 7 desktop with a clean DOS startup disk.
I normally test Princess Maker 2, but I will now primarily test Ecargxus, a demo by The Phoney Coders. That uses IRQs 2-7 and only a Roland MT-32. I have an MT-32 (Rev.0) on hand as well. I'll start testing on Tuesday, because of music school Monday. :happy:

Edit 2017/11/01

[Pentium MMX 233 MHz with L1 cache disabled in the BIOS - S3 Trio64V2/DX - MT-32 test]
K2Y-PRO16 is a no-go. Likely configuration is wrong, but SoftMPU does recognize the SB port, but not the IRQ, apparently.
ESS1869F with wavetable: same issue as CT2760 and CT2830, though this needs more testing.
Sound Blaster CT2760 and CT2830 music freeze after a few notes are played, in both Princess Maker 2 and Ecargxus, though even then, it's not that consistent.
Sound Blaster CT3670 is most stable, but even then, it's a crap shoot as to when it hangs. This is in both programs.

[486 machine with Intel 486SX/20, turbo off - Cirrus Logic CL5428 - MT-32 test]
Sound Blaster CT2760 and CT2830 - similar results as the Pentium build.
Sound Blaster CT3670 - similar results as the Pentium build.

For comparison, I dug out my first Sound Blaster card, a CT4170, has mostly Rubycon caps. Got it in 2004.
In the Pentium build, Princess Maker 2 music ran (mostly) perfectly [some complex songs pretty much hangs the music], but Ecargxus music hangs when the first 3D vector model shows up (consistent). Not tested on my 486 yet. Will also have to test the CT4170 I grabbed in 2012, because at one point the original started to show issues (no sound) but disappeared after letting it sit for a while and no issues ever since.

If I can get the timing issues solved on both machines, I think the CT3670 would be the usable one. Not confident on the CT2760 and CT2830 (yet).

My Compaq laptop seems to handle SoftMPU quite well. Have to run CuteMouse 2.1b4 as 2.0a4 locks up the laptop. Also have to use SetMul to disable the L1 cache. Either way, it's the most usable.

Edit 2017/11/05

Did manage to get my serial MIDI module, the Roland SC-7, to work with Princess Maker 2 on my Compaq yesterday, but I had to use SlowDown 3.10 instead to use a higher clock than usual in comparison to my MT-32 (the music would lag in places otherwise). It was 559 slowdown units maximum there, any higher and the music does not play.
Computer in my collection that had too much work done is... Compaq Armada 1573DM!

- Original DSTN panel replaced with an HPA panel
- Left hinge repaired twice
- Front panel replaced twice as a result of the left hinge issue
- Replaced busted inverter
User avatar
Posts: 10
Joined: 2016-7-12 @ 15:01
Location: Detroit, MI

Re: SoftMPU project needs your help! (game & sound card testing)

Postby robertmo » 2018-3-01 @ 08:09

have a version of:
that require intelligent mode.
Anyone wants to test it?
User avatar
Posts: 4214
Joined: 2003-6-18 @ 10:35

Re: SoftMPU project needs your help! (game & sound card testing)

Postby TrekkiesUnite118 » 2018-3-12 @ 06:10

So using QEMM 7.3 and SoftMPU 1.91 I was able to get Warcraft 2 to work on my Roland SC-88 over the Serial Connection on my IBM PS/2 Model 50 486. That surprised me quite a bit as things like Doom didn't work which I expected after hearing that protected mode games didn't work.

All I did to get Warcraft 2 to work was set the music to use General MIDI and point it to port 330. I had Soft MPU running with settings MPU:330 and Output:COM1
Posts: 13
Joined: 2018-1-29 @ 02:12


Return to SoftMPU

Who is online

Users browsing this forum: No registered users and 1 guest