Common searches


Topic actions

First post, by monsterbaldy

User metadata
Rank Newbie

Hey all... I recently got a Roland MT-32 for my Pentium 2 with an AZT2320 and in some games it works great, like Jones in the Fast Lane and Monkey Island 2.

However, for a lot of the Sierra games I get the "Unable to initialize sound hardware". This was an issue when I was using the Adlib setting as well, but using a slowdown utility I fixed it. With the MT-32 slow-down doesn't help so I thought maybe it was something else.

I noticed the setup for KQ4 says it needs to program a sound bank on the Roland MT32, yadda yadda yadda, I am thinking maybe I need to install SOFTMPU.

So in trying softmpu 1.91 I run it with the correct parameters:

SOFTMPU /mpu:330 /sb:220 /irq:5 /delaysysex

and I get MPU-401 detected at port 330, and then it hangs.

Any ideas what I am doing wrong? Maybe the AZT2320 isn't supported? Maybe I don't need softmpu at all?

Any help is appreciated.

Reply 2 of 2, by bjt

User metadata
Rank Oldbie

I haven't had any reports of success with the AZT2320, however the faster machines are often problematic. If a slowdown utility doesn't help I would try something from the compatibility list e.g. SB16.