VOGONS


WIP versions

Topic actions

  • This topic is locked. You cannot reply or edit posts.

Reply 401 of 1111, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

I didn't yet upgrade to Spring Creators Update (still on 1709 (16299.371)). Is the Alt-Tab issue with it been solved meanwhile?

lowenz wrote:

I get a terrible performance with Glide (Unreal) and a mobile 9600 GT, way too far BAD confronting to DDRAW!
I will test with a more modern GT 750 Ti.

Yes, 9600 GT is just too old for dgvoodoo. That's why I didn't want to add 10.0 support in the beginning, and later intended that for late DX10 hardware after all.
Pure DDraw (without D3D) is much cheaper than Glide.

Reply 402 of 1111, by djc5166

User metadata
Rank Newbie
Rank
Newbie
lowenz wrote:
Solved! :D […]
Show full quote
Dege wrote:
Yes, I explained that in dgVoodoo 2 for DirectX 11 […]
Show full quote

Yes, I explained that in
dgVoodoo 2 for DirectX 11

It clearly shows that crash occurs in ReShade's dxgi. I even gave a tip for the possible problem.
dgVoodoo does nothing special tricky thing that should be 'fixed', especially if previous ReShade versions worked with it. 😖

Solved! 😁

https://github.com/crosire/reshade/commit/d0c … d10e9da83c5f7c7

And I confirm it's working as ever, now 😁

Built from github this morning, can also confirm it is working.

Reply 403 of 1111, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie
Dege wrote:

I didn't yet upgrade to Spring Creators Update (still on 1709 (16299.371)). Is the Alt-Tab issue with it been solved meanwhile?

Isn't that something you can fix by disabling focus assist (a feature somewhat relating to notifications)? I don't notice any alt-tab issues, but it could be because I've turned off notifications earlier and I'm not a heavy alt-tab user (though I did test with the 15 games I have installed).

Reply 404 of 1111, by Dege

User metadata
Rank Oldbie
Rank
Oldbie
ZellSF wrote:

Isn't that something you can fix by disabling focus assist (a feature somewhat relating to notifications)? I don't notice any alt-tab issues, but it could be because I've turned off notifications earlier and I'm not a heavy alt-tab user (though I did test with the 15 games I have installed).

Indeed! I forgot about that. I'm going to upgrade to it soon.

-----------

I share the newest thing for testing:

=========================
WIP46:
=========================

A little addition to WIP45:

- Forceable internal bit depth of depth buffers
- minor bug fixed related to alphablending, again

http://dege.fw.hu/temp/dgVoodooWIP46.zip
http://dege.fw.hu/temp/dgVoodooWIP46_dbg.zip

Forcemin24 should be the default for 'DepthBuffersBitDepth' (like 32 bit quality is the default for color buffers) but I didn't do extensive testing and I'm afraid it would break some z-sensitive games like Gorky17.

Reply 406 of 1111, by KainXVIII

User metadata
Rank Member
Rank
Member
ZellSF wrote:

I Was An Atomic Mutant, Simon the Sorcer 3D and Treasure Planet: Battle at Procyon all look a lot better now. They definitely were made with 24 bit depth buffers in mind.

Simon 3d? I need to check it out =)
Or someone will post comparison screenshots before me 😎

Reply 408 of 1111, by KainXVIII

User metadata
Rank Member
Rank
Member
ZellSF wrote:

It's not really easy to show z-fighting problems in screenshots. Here's a video comparison though:
https://www.youtube.com/watch?v=_7KN30r9WVg

Difference is clear, great upgrade!
I did not even know that DgVoodoo had "hidden" [DirectXExt] section in config file though..need to RTFM it somehow

Reply 409 of 1111, by Dreadmoth

User metadata
Rank Newbie
Rank
Newbie

Nice, forcemin24bit considerably improves Mechwarrior 3 and Heavy Gear 2.

So far I've only noticed one minor artifact - in Shogo, the shading of the player hands with pistols equipped misbehaves and flickers in motion:
appdriven
forcemin24bit
Maybe the faces are duplicated and the default z-precision hides the issue...

Windows 7 64-bit | Intel Core i7-4770 @ 3.4GHz | MSI GeForce GTX 1070 Ti Titanium 8GB | Samsung S23A700D, 1920x1080@120Hz | Gigabyte GA-Z87-HD3 | Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | Samsung 840 PRO 256GB | Samsung 860 EVO 2TB

Reply 411 of 1111, by Dege

User metadata
Rank Oldbie
Rank
Oldbie
KainXVIII wrote:
ZellSF wrote:

It's not really easy to show z-fighting problems in screenshots. Here's a video comparison though:
https://www.youtube.com/watch?v=_7KN30r9WVg

Difference is clear, great upgrade!
I did not even know that DgVoodoo had "hidden" [DirectXExt] section in config file though..need to RTFM it somehow

The current concept is the CPL exposes only the options used and changed frequently or may vary game by game.
All others are rarely needed and treated as 'special' and they are in different sections in the config file.

I may move some of them into the CPL sections though for future releases (but not for patches of 2.55).

Dreadmoth wrote:

Maybe the faces are duplicated and the default z-precision hides the issue...

Yes, the imprecision of 16 bit z-buffers has some advantage over its drawbacks. For example, it can suppress z-fighting more than 24 bit ones.
That's one of the reasons why I think forcing 24bit by default wouldn't be a good idea.

Reply 412 of 1111, by szabozadam

User metadata
Rank Newbie
Rank
Newbie
Dege wrote:

Things are going slowly nowadays so I share a little WIP compiled from the branch of 2.55 (I want some more fixes in the patch version though):

Sorry to bother you, the fix regarding Soldiers of Anarchy is only half good the game still makes dgVoodoo lose the light part of the stateblock when you move the camera (I think the actual trigger is a new mesh being added to the scene as a result of frustum culling but that is just speculation)

Here is a demo with WIP45 or WIP46:
https://www.youtube.com/watch?v=2cMQxBYOafI

Reply 413 of 1111, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie
lowenz wrote:

Can anybody check MechCommander Gold on the lastest Win10 update?
With dgVooodoo2 the game can't even initialize (without it works).

Not even a log file created......

Besides insisting on running a window, it works fine for me. You need to disable mouse capture if you haven't. Also set desktop resolution to game resolution (because losing focus = crash and it only works windowed).

mcx.jpg
Filename
mcx.jpg
File size
166.57 KiB
Views
1478 views
File license
Fair use/fair dealing exception

Reply 414 of 1111, by UCyborg

User metadata
Rank Member
Rank
Member

Regarding Windows 10 Build 17134, among other things:

Microsoft broke the ICopyHook interface in Windows 1803. Until Microsoft fixes the bug in Windows, drag & drop from FileZilla into Explorer will not work on Windows 1803.

https://filezilla-project.org/

Arthur Schopenhauer wrote:

A man can be himself only so long as he is alone; and if he does not love solitude, he will not love freedom; for it is only when he is alone that he is really free.

Reply 415 of 1111, by Dege

User metadata
Rank Oldbie
Rank
Oldbie
szabozadam wrote:
Sorry to bother you, the fix regarding Soldiers of Anarchy is only half good the game still makes dgVoodoo lose the light part o […]
Show full quote
Dege wrote:

Things are going slowly nowadays so I share a little WIP compiled from the branch of 2.55 (I want some more fixes in the patch version though):

Sorry to bother you, the fix regarding Soldiers of Anarchy is only half good the game still makes dgVoodoo lose the light part of the stateblock when you move the camera (I think the actual trigger is a new mesh being added to the scene as a result of frustum culling but that is just speculation)

Here is a demo with WIP45 or WIP46:
https://www.youtube.com/watch?v=2cMQxBYOafI

Not a problem! Thanks for the feedback!
So, stilll there is something wrong with it, I'll check it out!

Reply 416 of 1111, by WSH303

User metadata
Rank Newbie
Rank
Newbie

Hello,

Would that be possible to check why mouses with high pooling rates have issues with dgVoodoo? For example, in Aliens vs Predator 2 (LithTech) everything works fine only with 125Hz pooling rate. The higher the rate the more choppy the games becomes. And it only happens with dgVoodoo, native works fine.

Reply 417 of 1111, by djc5166

User metadata
Rank Newbie
Rank
Newbie
WSH303 wrote:

Hello,

Would that be possible to check why mouses with high pooling rates have issues with dgVoodoo? For example, in Aliens vs Predator 2 (LithTech) everything works fine only with 125Hz pooling rate. The higher the rate the more choppy the games becomes. And it only happens with dgVoodoo, native works fine.

I've seen this even with modern games, setting 1000hz in my logitech panel makes some games entirely broken. Probably just has to do with when/where the mouse is read.

Reply 418 of 1111, by Dege

User metadata
Rank Oldbie
Rank
Oldbie
szabozadam wrote:
Sorry to bother you, the fix regarding Soldiers of Anarchy is only half good the game still makes dgVoodoo lose the light part o […]
Show full quote
Dege wrote:

Things are going slowly nowadays so I share a little WIP compiled from the branch of 2.55 (I want some more fixes in the patch version though):

Sorry to bother you, the fix regarding Soldiers of Anarchy is only half good the game still makes dgVoodoo lose the light part of the stateblock when you move the camera (I think the actual trigger is a new mesh being added to the scene as a result of frustum culling but that is just speculation)

Here is a demo with WIP45 or WIP46:
https://www.youtube.com/watch?v=2cMQxBYOafI

Could you attach the .mis file you're loading in the video, plz?
I tried with several other but couldn't reproduce it. Or maybe I'm using a different version of the game? (some patch is not installed or sg)

Reply 419 of 1111, by szabozadam

User metadata
Rank Newbie
Rank
Newbie
Dege wrote:

Could you attach the .mis file you're loading in the video, plz?
I tried with several other but couldn't reproduce it. Or maybe I'm using a different version of the game? (some patch is not installed or sg)

Ah I see, the difference in our setups should be the shadow setting (the issue was independent of the .mis file, and the exe version on my end), I just realised that you can only enable shadows with the options menu outside the game (you should be able to open the menu if you run the exe from a cmd like:

soa -o

) there is a "Shadow detail" option (on/off) in the options tree on the left which I enabled but had forgotten I did.

It become a nonissue though as without shadows the lighting works as it should and it seems this feature was so unfinished the ingame menu can't even be used to enable it (I didn't experience any natively (years and years ago on an era appropriate pc) but it is entirely possible that the shadow rendering has/had glitches as a result of this state of incompleteness and should be kept disabled, nevertheless the current(win8.1 "current") default windows supplied ddraw.dll manages them somehow so for the sake of completeness it may be worth looking into (if indeed I'm correct and enabling shadows will mess up the stateblocks on your end aswell) but that is your call)

Thanks for taking a look though, helped me figure I should test the possible settings again 😀

(furthermore I managed to modify reshade (I didn't use this while investigating the lighting issue) to cut the scene composition in half and inject the depth dependent effects under the UI which further invalidates the need for the shadows as I personally think AO looks nicer (this is a very niche thing to do as I learnt so I totally understand if anyone finds the original to be the better looking )
81a2l66mltqa6o2zg.jpg
qy5wqts85yco6kyzg.jpg
)