Wizards and Warriors

General information and assistance with dgVoodoo.

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-1-31 @ 22:48

galneon wrote:I was just trying to play Wizards and Warriors for the first time on this rig. Looks like the only way to play it with a recent nvidia card (with recent drivers), even having tried modified exes, is with dgVoodoo 2 which fortunately works flawlessly from my limited testing.


When you say flawlessly, do you mean all graphics look correct? Wizards and Warriors is one of the nastier early 2000 games to get working completely perfect on Windows 7 64. I have made it work in software mode near perfect, but even with dgVoodoo2 2.53, in D3D mode, textures get corrupt/blacked out with the character models and landscape models. Even with all the unofficial patches, dgVoodoo2, DXGL, etc. the game has texture problems anytime you run in D3D mode that I have found. I just run @ 1024x768, all settings high in software mode. Game works great then as long as you don't install the unofficial graphics patch otherwise software mode gets that super mouse lag problem.
Last edited by liqmat on 2017-2-01 @ 17:21, edited 1 time in total.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby Dege » 2017-2-01 @ 12:31

liqmat wrote:
galneon wrote:I was just trying to play Wizards and Warriors for the first time on this rig. Looks like the only way to play it with a recent nvidia card (with recent drivers), even having tried modified exes, is with dgVoodoo 2 which fortunately works flawlessly from my limited testing.


When you say flawlessly, do you mean all graphics look correct. Wizards and Warriors is one of the nastier early 2000 games to get working completely perfect on Windows 7 64. I have made it work in software mode near perfect, but even with dgVoodoo2 2.53, in D3D mode, textures get corrupt/blacked out with the character models and landscape models. Even with all the unofficial patches, dgVoodoo2, DXGL, etc. the game has texture problems anytime you run in D3D mode that I have found. I just run @ 1024x768, all settings high in software mode. Game works great then as long as you don't install the unofficial graphics patch otherwise software mode gets that super mouse lag problem.


I gave it a very quick try (latest dgVoodoo WIP I think), applied some unofficial patches, etc. and from a quick-play it seemed to work (almost) perfectly.
If resolution is forced then one with ISF must be applied otherwise the mouse cursor draws blurred trails. Also with ISF it's not perfect, but it's unsignificant enough not to be disturbing.
Also, v-sync shouldn't be forced.
Dege
Oldbie
 
Posts: 954
Joined: 2003-9-04 @ 11:06

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-01 @ 18:04

Dege wrote:
liqmat wrote:
galneon wrote:I was just trying to play Wizards and Warriors for the first time on this rig. Looks like the only way to play it with a recent nvidia card (with recent drivers), even having tried modified exes, is with dgVoodoo 2 which fortunately works flawlessly from my limited testing.


When you say flawlessly, do you mean all graphics look correct. Wizards and Warriors is one of the nastier early 2000 games to get working completely perfect on Windows 7 64. I have made it work in software mode near perfect, but even with dgVoodoo2 2.53, in D3D mode, textures get corrupt/blacked out with the character models and landscape models. Even with all the unofficial patches, dgVoodoo2, DXGL, etc. the game has texture problems anytime you run in D3D mode that I have found. I just run @ 1024x768, all settings high in software mode. Game works great then as long as you don't install the unofficial graphics patch otherwise software mode gets that super mouse lag problem.


I gave it a very quick try (latest dgVoodoo WIP I think), applied some unofficial patches, etc. and from a quick-play it seemed to work (almost) perfectly.
If resolution is forced then one with ISF must be applied otherwise the mouse cursor draws blurred trails. Also with ISF it's not perfect, but it's unsignificant enough not to be disturbing.
Also, v-sync shouldn't be forced.


Thanks for trying it out. So I I tried out the latest dgVoodooWIP29.zip and the same results. Everything looks good in the game until you get out into the 3D world and you will notice your character model in the top left disappears or in some cases gets corrupted textures, etc. Software mode seems to be the only way to get the game looking exactly as intended for now. One of my favorite RPGs that never got enough TLC from its devs. It's unfortunate.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby Dege » 2017-2-02 @ 12:00

liqmat wrote:Thanks for trying it out. So I I tried out the latest dgVoodooWIP29.zip and the same results. Everything looks good in the game until you get out into the 3D world and you will notice your character model in the top left disappears or in some cases gets corrupted textures, etc. Software mode seems to be the only way to get the game looking exactly as intended for now. One of my favorite RPGs that never got enough TLC from its devs. It's unfortunate.


Could you plz post a screenshot about the texture corruption?
This game may worth a new thread, I might able to do with it something, later.
Or, I should play a little more with it than just a quick try and that should be enough (but I was always killed shortly after entering the forest :D).
Dege
Oldbie
 
Posts: 954
Joined: 2003-9-04 @ 11:06

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-02 @ 20:00

Dege wrote:Could you plz post a screenshot about the texture corruption? This game may worth a new thread, I might able to do with it something, later. Or, I should play a little more with it than just a quick try and that should be enough (but I was always killed shortly after entering the forest :D).


After uninstalling everything and reinstalling the core game and then applying the following unofficial patches in listed order:

Note: All unofficial patches and the town AVI fix for W&W can be downloaded here: http://www.jeffludwig.com/wizardswarriors/download.php

1.) Heuristic Park's unofficial Wizards and Warriors Patch v1.0
2.) Ross Ridge's Wizards and Warriors DirectX Graphics fix
3.) Wizards and Warriors Town AVI XP fix
4.) dgVoodoo WIP29

Now the character models show up properly in the top left hand corner (at the inn) and the FMVs play properly, BUT I still have an issue with the characters disappearing completely in said top right hand corner when you enter the game world (forest in this case) from the 2D town screen. Once you enter the game world and then go into your inventory and add/remove an article of clothing the character model reappears. If you go back into the 2D town screen and then back into the game world again the character model once again disappears. Screens below with descriptions.

I also noticed that with dgVoodoo enabled the game screen is much brighter now, but more whitewashed looking even though the in-game gamma is set to lowest. When I turn the brightness down in dgVoodoo it still has that hazy whitewash look. Maybe add a contrast setting in dgVoodoo might help with this? Just an idea.

Software mode without dgVoodoo everything works fine after patches except FMVs are unplayable and usually crash the game. Can only display in 640x480 in software mode. Software mode has slight mouse lag, but usable:

w&wsoftware1.jpg
w&wsoftware2.jpg


Direct3D mode without dgVoodoo has texture corruption with the character models (certain body parts are black and/or warped) and game world (tree trunks are black, etc.) Very little mouse lag.

w&wd3d1024x768_raw_install_1.jpg
w&wd3d1024x768_raw_install_2.jpg


Direct3D mode with dgVoodoo WIP29 installed character models/landscape objects are no longer corrupted/missing textures, but now character models disappear in the top left hand corner when entering the game world. Very little mouse lag if at all. FMVs play properly. If you change to software mode while dgVoodoo is installed there is unusable mouse lag especially around menu buttons (the mouse pointer gets caught).
Last edited by liqmat on 2017-2-04 @ 21:59, edited 2 times in total.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-02 @ 21:24

My dgVoodoo WIP29 settings:

settings1.jpg
settings2.jpg
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-03 @ 20:11

Dege wrote:
liqmat wrote:Thanks for trying it out. So I I tried out the latest dgVoodooWIP29.zip and the same results. Everything looks good in the game until you get out into the 3D world and you will notice your character model in the top left disappears or in some cases gets corrupted textures, etc. Software mode seems to be the only way to get the game looking exactly as intended for now. One of my favorite RPGs that never got enough TLC from its devs. It's unfortunate.


Could you plz post a screenshot about the texture corruption?
This game may worth a new thread, I might able to do with it something, later.
Or, I should play a little more with it than just a quick try and that should be enough (but I was always killed shortly after entering the forest :D).


One last note on this. I was able to duplicate the character model disappearing while at the inn when creating characters. It seems something funky is going on in that box where the character model is rendered and it seems like a redraw of the background behind the model. I actually have no idea what it's doing, I'll leave that to the experts. In one instance the background behind the model turned solid white when I entered the game world. It seems to happen when I create a character and when I enter the game world. I have included two additional screen shots. The first showing the model gone at the inn and the other where the model disappears while in the game world, but you can see the top of the model's hat (circled in red) after the model gets possibly overlaid by the background. Of course adding or removing equipped items brings the model to the foreground again. This only happens when dgVoodoo is enabled. Software mode nor D3D mode have this issue when dgVoodoo is disabled, but of course then you have the D3D corrupted textures or the 640x480 limit of software mode.

modelinn.jpg
modelworld.jpg
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-03 @ 23:51

So I fixed the character models disappearing by unchecking "Fast video memory access" in the DirectX tab, but now that creates a new problem. Once you leave the city gates you can't get back in! You literally can't click on the entrance gates of the city in the 3D game world to get back into the city. This is nuts. Going to play around some more.

FASTVID.jpg
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: dgVoodoo 2 for DirectX 11

Postby liqmat » 2017-2-04 @ 00:41

So Wizards & Warriors finally works perfectly for me with dgVoodoo in Windows 7 64. It seems simple now, but getting there was painful. It turns out this game hates "Fast video memory access" and the GUI interface not responding when you turn off "Fast video memory access" resolves itself when you force the Output API to "Direct3D 11 (feature level 10.0)" instead of 10.1. It still would be extremely nice to have a contrast or gamma setting under the "Color adjustments" in dgVoodoo.

Wizards and Warriors final dgVoodoo2 settings that worked for me after applying all unofficial patches that I mentioned above:

w&wfinal1.jpg
w&wfinal2.jpg
Last edited by liqmat on 2017-2-07 @ 16:35, edited 1 time in total.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Wizards and Warriors

Postby Dege » 2017-2-04 @ 13:37

Thanks for the info!!
Meanwhile I opened a separate thread for Wizards and Warriors, and moved the related posts here.

So Wizards & Warriors finally works perfectly for me with dgVoodoo in Windows 7 64. It seems simple now, but getting there was painful. It turns out this game hates "Fast video memory access" and the GUI interface not responding when you turn off "Fast video memory access" resolves itself when you force the Output API to "Direct3D 11 (feature level 10.0" instead of 10.1. It still would be extremely nice to have a contrast or gamma setting under the "Color adjustments" in dgVoodoo.


Fast vidmem access can cause problems, indeed, I experienced some issues with it myself.
Altough in dgVoodoo docs I wrote that if it was 100% safe then there wouldn't even be an option for choosing it, I must change my opinion.
Fast/nonfast both have its benefits and drawbacks (I use (and even try) 'fast' only when a game/demo stutters or has low performance because of continuously accessing a GPU buffer via CPU).

FL 10.0 vs 10.1 is interesting on the other hand... Shouldn't be any difference between the two for this game.
I must have a look at it.
Dege
Oldbie
 
Posts: 954
Joined: 2003-9-04 @ 11:06

Re: Wizards and Warriors

Postby liqmat » 2017-2-04 @ 19:12

Dege wrote:Thanks for the info!!
Meanwhile I opened a separate thread for Wizards and Warriors, and moved the related posts here.

So Wizards & Warriors finally works perfectly for me with dgVoodoo in Windows 7 64. It seems simple now, but getting there was painful. It turns out this game hates "Fast video memory access" and the GUI interface not responding when you turn off "Fast video memory access" resolves itself when you force the Output API to "Direct3D 11 (feature level 10.0" instead of 10.1. It still would be extremely nice to have a contrast or gamma setting under the "Color adjustments" in dgVoodoo.


Fast vidmem access can cause problems, indeed, I experienced some issues with it myself.
Altough in dgVoodoo docs I wrote that if it was 100% safe then there wouldn't even be an option for choosing it, I must change my opinion.
Fast/nonfast both have its benefits and drawbacks (I use (and even try) 'fast' only when a game/demo stutters or has low performance because of continuously accessing a GPU buffer via CPU).

FL 10.0 vs 10.1 is interesting on the other hand... Shouldn't be any difference between the two for this game.
I must have a look at it.


Actually the fast vid mem works for me most of the time with older games, but W&W is a very tricky little booger and have you seen its file and folder structure? I think this game wins an award for most free standing wav files. This game has over 11,000 files and over 170 folders.

Anyways, I reinstalled again, but systematically tested with the fast vid mem off and 10.1 enabled at each step.

1.) Once I installed the game (large install) I installed dgVoodoo without any of the game patches. Both 10.0 and 10.1 worked fine.
2.) I then applied the "Heuristic Park's unofficial Wizards and Warriors Patch v1.0". Once again both 10.0 and 10.1 worked fine.
3.) Applied the "Wizards and Warriors Town AVI XP fix". Both 10.0 and 10.1 worked fine.
4.) Installed the "Ross Ridge's Wizards and Warriors DirectX Graphics fix". This is where the problem comes up if you use 10.1 and you have to use 10.0 with the fast vid mem disabled.

So when you go out in the 3D game world the ctrl key does not function, you can't click/interact with game objects like enemies or city gates, etc. under 10.1. 10.0 fixes all that. So it looks like its that graphics patch. Hope that helps a little. I tried all three resolutions in the graphics fix to see if that made a difference and it did not. So I do not know if this is a problem with dgVoodoo or Ross Ridge's graphics fix or they just don't play well together. At least it works in 10.0. Could it be something with direct input? I know nothing about these things so I'll leave that to your expertise.

Note: I also use the imagecfg.exe affinity tool and set the W&W exe deep6.exe to CPU 0 with the command "imagecfg -a 0x1 deep6.exe". I thought that might even have something to do with it, but it did not.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: Wizards and Warriors

Postby liqmat » 2017-9-30 @ 15:47

I have no idea why all the images in this thread are gone. I did not remove them.
liqmat
Member
 
Posts: 421
Joined: 2015-7-07 @ 21:59

Re: Wizards and Warriors

Postby Stiletto » 2017-10-02 @ 03:13

liqmat wrote:I have no idea why all the images in this thread are gone. I did not remove them.


Sorry man, there's nothing in the logs. I even asked Qbix to check, but we don't know what happened to your attachments.
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 3714
Joined: 2002-7-01 @ 21:57


Return to dgVoodoo General

Who is online

Users browsing this forum: No registered users and 1 guest