dgvoodoosetup 2.53 doesn't launch

General information and assistance with dgVoodoo.

dgvoodoosetup 2.53 doesn't launch

Postby yuljk » 2017-2-18 @ 19:58

Hi guys - I'm trying the new 2.53 release out - when I double click on dgvoodoosetup.exe nothing happens. I've tried running it as administrator and with various compatibility options.

Any ideas why this won't launch? (I'm running Windows 10 with an 8600m GT)

Many thanks
yuljk
Newbie
 
Posts: 3
Joined: 2017-2-17 @ 23:08

Re: dgvoodoosetup 2.53 doesn't launch

Postby Dege » 2017-2-19 @ 16:05

I've totally forgotten about this (WIP CPL apps doesn't start).
It was reported earlier.
I have no idea what's wrong, but 8600GT is capable only of FL10.0, maybe that.
Experimentally I limited the max DX feature level, for myself, to 10.0 in DX CPL but the app worked, detected FL10.0 as a max output API, as expected.
I guess the process vanishes right after its launch from the process list if you have a look into task manager.
If it does then it must be a silent crash.
If it doesn't the it stucks at some point.

Hmm...
I don't know how to check it. Do you have an Visual Studio installed, to launch it from that and see what happens? :blush:
I have my old 8600GT hiding somewhere, I could put it into the Win7 machine to try it out.
Dege
Oldbie
 
Posts: 953
Joined: 2003-9-04 @ 11:06

Re: dgvoodoosetup 2.53 doesn't launch

Postby ZellSF » 2017-2-19 @ 17:02

I've had dgVoodoo2 setup fail to start if the profile (%appdata%\dgVoodoo) was corrupted. Try deleting that folder?
ZellSF
Oldbie
 
Posts: 886
Joined: 2006-1-01 @ 18:19

Re: dgvoodoosetup 2.53 doesn't launch

Postby yuljk » 2017-2-19 @ 18:07

Dege wrote:I've totally forgotten about this (WIP CPL apps doesn't start).
It was reported earlier.
I have no idea what's wrong, but 8600GT is capable only of FL10.0, maybe that.
Experimentally I limited the max DX feature level, for myself, to 10.0 in DX CPL but the app worked, detected FL10.0 as a max output API, as expected.
I guess the process vanishes right after its launch from the process list if you have a look into task manager.
If it does then it must be a silent crash.
If it doesn't the it stucks at some point.

Hmm...
I don't know how to check it. Do you have an Visual Studio installed, to launch it from that and see what happens? :blush:
I have my old 8600GT hiding somewhere, I could put it into the Win7 machine to try it out.


Thanks for the quick reply! - Yeah the 8600m GT only supports up to DX 10.0 - I am able to use one of your WIP releases without issue (WIP_20). Seems any of the CPL WIPS don't work too. Yeah, the process flashes up for a few seconds in task manager and closes. It does create an folder in %APPDATA%

I'll install Visual Studio and give it a whirl.

ZellSF - I'd already deleted the dgvoodoo folder before trying out the new release :(
yuljk
Newbie
 
Posts: 3
Joined: 2017-2-17 @ 23:08

Re: dgvoodoosetup 2.53 doesn't launch

Postby yuljk » 2017-2-20 @ 16:40

OK - I just did a test on one of my virtual machines with Visual Studio and the .exe launched correctly. I suspect the issue is due to the 8600M GT only supporting up to DX level 10.0. Is there a possibility of a release that is backwards compatible with older cards? That would be awesome :)

Many thanks
yuljk
Newbie
 
Posts: 3
Joined: 2017-2-17 @ 23:08

Re: dgvoodoosetup 2.53 doesn't launch

Postby Dege » 2017-2-22 @ 09:35

2.53 should be compatible with 10.0-only cards.
I tested the CPL again, with limited feature level set (to 10.0) and it worked. That's why I found this issue weird.
Dege
Oldbie
 
Posts: 953
Joined: 2003-9-04 @ 11:06

Re: dgvoodoosetup 2.53 doesn't launch

Postby Myloch » 2017-2-24 @ 13:18

Dege wrote:It was reported earlier.

yeah, by me :cool:
I own a 9600m gt one though.

yuljk wrote:Hi guys - I'm trying the new 2.53 release out - when I double click on dgvoodoosetup.exe nothing happens.

U can use configuration tool exe v2.52 as a workaround.
"Gamer & collector for passion, I firmly believe in the preservation and the diffusion of old/rare software, against all personal egoisms"
User avatar
Myloch
Member
 
Posts: 362
Joined: 2007-4-18 @ 22:13

Re: dgvoodoosetup 2.53 doesn't launch

Postby Myloch » 2017-3-08 @ 22:19

Myloch wrote:
yuljk wrote:Hi guys - I'm trying the new 2.53 release out - when I double click on dgvoodoosetup.exe nothing happens.

U can use configuration tool exe v2.52 as a workaround.

Update: this trick works no more with latest wip31, settings made with tool v2.52 doesn't apply to new dlls :(
"Gamer & collector for passion, I firmly believe in the preservation and the diffusion of old/rare software, against all personal egoisms"
User avatar
Myloch
Member
 
Posts: 362
Joined: 2007-4-18 @ 22:13

Re: dgvoodoosetup 2.53 doesn't launch

Postby Dege » 2017-3-09 @ 09:53

It's a bug in the WIP version I already found and fixed.
However being unable to run the latest CPL is not normal, so I'd like to fix it.

I found my 8600GT and could put it in an old Win7 machine to test. The question is, the problem is Win10-specific or expected on Win7 too.
Dege
Oldbie
 
Posts: 953
Joined: 2003-9-04 @ 11:06

Re: dgvoodoosetup 2.53 doesn't launch

Postby Myloch » 2017-3-09 @ 18:01

Dege wrote:The question is, the problem is Win10-specific or expected on Win7 too.

I cannot verify that, sorry!
"Gamer & collector for passion, I firmly believe in the preservation and the diffusion of old/rare software, against all personal egoisms"
User avatar
Myloch
Member
 
Posts: 362
Joined: 2007-4-18 @ 22:13

Re: dgvoodoosetup 2.53 doesn't launch

Postby Dege » 2017-3-10 @ 19:32

I tried my 8600GT under Win7.
The setup app launched and worked as expected, FL 10.0 was detected correctly. So, it seems to be a Win10 problem.

My surprise was however that dgVoodoo itself didn't work. DX debug layer told me that the card doesn't support structured buffers... :dead:
Since I run early version of Glide rendering on that hw, now I'm not sure how I did that.
Either the driver was a never one, or that version of dgVoodoo didn't use structured buffers which I doubt. I'll try it with the newest driver later.
Dege
Oldbie
 
Posts: 953
Joined: 2003-9-04 @ 11:06

Re: dgvoodoosetup 2.53 doesn't launch

Postby Myloch » 2017-3-12 @ 13:57

Dege wrote:So, it seems to be a Win10 problem

Win8.1 + 9600m gt here, it doesn't work
"Gamer & collector for passion, I firmly believe in the preservation and the diffusion of old/rare software, against all personal egoisms"
User avatar
Myloch
Member
 
Posts: 362
Joined: 2007-4-18 @ 22:13

Re: dgvoodoosetup 2.53 doesn't launch

Postby Dege » 2017-3-16 @ 08:56

I had a chance to try 2.53 on an old Win10 machine with a 8600GT.
The setup app launched, popped up for a moment and disappeared. The reason is, it's a machine at my workplace having **** antivirus installed. When I switched that off temporarily then there were no problems.
Even the wrapper itself worked, not with a great performance though.
Dege
Oldbie
 
Posts: 953
Joined: 2003-9-04 @ 11:06

Re: dgvoodoosetup 2.53 doesn't launch

Postby Myloch » 2017-3-20 @ 11:41

No AV activated here, clicking on control panel exe just does nothing
"Gamer & collector for passion, I firmly believe in the preservation and the diffusion of old/rare software, against all personal egoisms"
User avatar
Myloch
Member
 
Posts: 362
Joined: 2007-4-18 @ 22:13


Return to dgVoodoo General

Who is online

Users browsing this forum: No registered users and 2 guests