Tech demos - general discussion

General information and assistance with dgVoodoo.

Re: Tech demos - general discussion

Postby kolano » 2018-1-29 @ 10:12

SteveC wrote:Interestingly I'm trying to get the G400 tech demo working on an actual G400 and it used to work (Windows XP) but since changing around graphics cards (had a Parhelia and some NVidia 8400GS card in the PC since the G400) it just goes black screen, you get 1/2 second of sound then dumps you back to the desktop. There's a 'matrox.txt' file that's created and that says it 'can't load video texture'. I've tried the patched exe Dege posted but that made no difference. Argh I guess I'll have to reinstall a clean Windows XP and try again...

Yeah, I'd also like to get it running again.

Addomg "i_promise_i_will_go_buy_a_matrox_g400" at the end of matrox.cfg is supposed to get it running on non-Matrox hardware, but on modern hardware I don't think that alone get's it running anymore, nor can the installer be run.
User avatar
Posts: 527
Joined: 2010-12-26 @ 21:03

Re: Tech demos - general discussion

Postby Dege » 2018-1-29 @ 19:26

Try the attached .sdb compatibility file. It contains FaultTolerantHeap and WinXPSp2 fixes, but as CoolGamer said in an earlier post, EmulateHeap may also be needed. And single thread affinity.
With this sdb installed I got it working with dgVoodoo on Win10. Well, more or less: I cannot guarantee it will work for you, the reason of the crash is very misterious.

You can modify the sdb (adding new compatibility options) with Compatibility Administrator 32 bit.
I'm not sure if this application is part of the OS by default or should be installed additionally.
(655 Bytes) Downloaded 6 times
Posts: 1300
Joined: 2003-9-04 @ 11:06

Re: Tech demos - general discussion

Postby SteveC » 2018-1-29 @ 21:42

I am actually trying on a G400 in Windows XP SP3 on old hardware (Athlon 1900XP). Using that sdb file didn't help. HOWEVER I have got it to run! I had to set the render depth to 16 bit (render_depth 0) in the config file. No idea why though as this is the original G400 32MB I've had for about 20 years from when I used to beta test for Matrox :)

I'm just wondering if it SP3 that's breaking it as I do remember upgrading this old HDD at some point from SP2 when messing around. I only have the SP3 ISO now though and not sure I can be bothered going through XP setup again now it works (albeit in 16bit colour).
Posts: 68
Joined: 2017-11-25 @ 22:05
Location: Rayleigh, Essex, UK


Return to dgVoodoo General

Who is online

Users browsing this forum: closer1000, FulValBot, MrEWhite and 2 guests