dgVoodoo2 and Dungeon Siege: Legends of Arrana

General information and assistance with dgVoodoo.

dgVoodoo2 and Dungeon Siege: Legends of Arrana

Postby emperorsfist » 2017-12-04 @ 09:58

Hello!

I've discovered a strange issue with the original Dungeon Siege. When you use dgVoodoo and you move the mouse cursor ingame, the game drops like 20 fps (in my case from 60 to cca 40fps). This only happens when you move the mouse cursor. Once you stop moving it, the fps almost immediately recovers. I've tried fiddling with dgVoodoo's settings, but no luck.
User avatar
emperorsfist
Newbie
 
Posts: 11
Joined: 2017-11-23 @ 16:46

Re: dgVoodoo2 and Dungeon Siege: Legends of Arrana

Postby ZellSF » 2017-12-04 @ 16:27

You need to force v-sync off in your graphic driver settings. Quite a few games have problems with dgVoodoo2+vsync.

If you can't tolerate the tearing, a workaround to get full speed and a tearing free experience is to tell dgVoodoo2 to run in window mode, even though the GPU won't vsync the game, it will still be synced to the desktop window manager.

Expanding a bit on that, if you want a borderless fullscreen set your desktop resolution to the game resolution before launching it and make sure to check "Disable Alt-Enter to toggle screen state" in dgVoodoo2 settings. On my computer that makes dgVoodoo2 behave weirdly in window mode. Also obviously disable "Application controlled fullscreen/windowed state".
ZellSF
Oldbie
 
Posts: 935
Joined: 2006-1-01 @ 18:19

Re: dgVoodoo2 and Dungeon Siege: Legends of Arrana

Postby emperorsfist » 2017-12-04 @ 17:09

ZellSF wrote:You need to force v-sync off in your graphic driver settings. Quite a few games have problems with dgVoodoo2+vsync.

If you can't tolerate the tearing, a workaround to get full speed and a tearing free experience is to tell dgVoodoo2 to run in window mode, even though the GPU won't vsync the game, it will still be synced to the desktop window manager.

Expanding a bit on that, if you want a borderless fullscreen set your desktop resolution to the game resolution before launching it and make sure to check "Disable Alt-Enter to toggle screen state" in dgVoodoo2 settings. On my computer that makes dgVoodoo2 behave weirdly in window mode. Also obviously disable "Application controlled fullscreen/windowed state".


Thanks for the input. Your suggestions worked so far.
User avatar
emperorsfist
Newbie
 
Posts: 11
Joined: 2017-11-23 @ 16:46


Return to dgVoodoo General

Who is online

Users browsing this forum: No registered users and 1 guest