"Frank Herbert's Dune" Bug report

General information and assistance with dgVoodoo.

"Frank Herbert's Dune" Bug report

Postby Silanda » 2018-2-09 @ 13:27

I suspect the game is doing something funny as natively most of the textures are displaying as rainbow colours, looking like some kind of palette problem. This has been the case since ~Windows 7 I believe, and I cannot find a resolution using compatibility modes or other wrappers.

In dgVoodoo the textures that are rendered are rendered in the correct colour, but not everything is rendered. For example, there are logos missing when the game loads, and in the intro the narrator is rendered as a disembodied face, with their entire body missing. I've tried changing settings in dgVoodoo to no avail, and the game's own settings don't completely work properly (32-bit Z-buffer doesn't work natively or with dgVoodoo, so I'm going to assume its support is broken).

Using WIP 42.
Silanda
Member
 
Posts: 151
Joined: 2005-9-08 @ 01:24

Re: "Frank Herbert's Dune" Bug report

Postby Dege » 2018-2-09 @ 21:37

I had a little time and had a look at this.

Yes, the game does something funny: it uses bump map texture formats for color textures...
The texture format enumerator doesn't even check if an enumerated format is a color type or not.
I don't know how it worked back in its time because it's a DX7 game so bump-luminance formats were available at that time. Maybe old DX enumerated the bump formats before the color ones, and the last one won.

Anyway, I patched the exe to make it bump/luminance-proof.

http://dege.fw.hu/temp/Dune_patched.zip

It now almost works fine for me natively. Almost, because I get flashing polygons in the narrator's room.

Shadows gets corrupted with dgVoodoo and forced resolution.
I tried the new 'RTTexturesForceScaleAndMSAA' option introduced in WIP42 but the debug layer found potential problems for this game with that option disabled.
In spite of that, shadows and the game itself seemed to work fine that way, altough I only did a quick test.
Dege
Oldbie
 
Posts: 1169
Joined: 2003-9-04 @ 11:06

Re: "Frank Herbert's Dune" Bug report

Postby Silanda » 2018-2-10 @ 06:07

Thanks for doing that!

How strange. Seems it didn't necessarily work back then either: I found a post from 2002 complaining of the same problem. Perhaps it was dependent on graphics card\driver. I guess QA wasn't Cryo's priority at the time seeing as even the exit option in the menu doesn't work.
Silanda
Member
 
Posts: 151
Joined: 2005-9-08 @ 01:24

Re: "Frank Herbert's Dune" Bug report

Postby stranno » 2018-2-10 @ 12:55

Thanks for the patch Dege. I get flashing polygons, at least, in the first cinematic, in the desert. But the rest dont seem to have this problem.

It could be related to MODE_Z_DEPTH, i had to set it to 16 instead of 32 since i got a "renderer initialization error" (with or without dgVoodoo).

The game can be forced in custom resolutions through configpc.cfg file, widescreen resolution just screw a bit the menu but the rest of the game looks fine.
User avatar
stranno
Newbie
 
Posts: 94
Joined: 2016-2-28 @ 19:55


Return to dgVoodoo General

Who is online

Users browsing this forum: No registered users and 2 guests