VOGONS


First post, by Zaragon

User metadata
Rank Newbie
Rank
Newbie

Has anyone ever gotten TA: Kingdoms to work 100% with dgVoodoo? I just recently tried the newest version (2.62) and several issues are still present. It didn't work with 2.53/2.54 either, so I don't think these are regressions.

1) Intro Movies are just a black screen. I know something is playing because there's audio, and the dgVoodoo water mark appears (as does the FRAPs display, when I have it on). But there's no video. This doesn't work in native DirectX either, it only works with the Software Renderer or Glide Renderer.

2) Font Corruption in the menu screens (not during the game). I play at 1920x1200 or 1600x1200 (depending on the renderer, as Glide doesn't support widescreen resolutions). The menu seems to render at 640x480 regardless, so I don't think that's the issue. The font is corrupted when using dgVoodoo compared to native DirectX/Glide/Software Renderer (this problem only occurs with dgVoodoo).

I've uploaded screenshots taken with FRAPs of both dgVoodoo and Native DirectX--and left the dgVoodoo watermark on, so it's easy to see which image is which.

Attachments

  • Native DirectX 2.png
    Filename
    Native DirectX 2.png
    File size
    357.05 KiB
    Views
    394 views
    File license
    Fair use/fair dealing exception
  • dgVoodoo Corruption 2.png
    Filename
    dgVoodoo Corruption 2.png
    File size
    411.52 KiB
    Views
    394 views
    File license
    Fair use/fair dealing exception
  • Native DirectX 1.png
    Filename
    Native DirectX 1.png
    File size
    380.94 KiB
    Views
    394 views
    File license
    Fair use/fair dealing exception
  • dgVoodoo Corruption 1.png
    Filename
    dgVoodoo Corruption 1.png
    File size
    399.73 KiB
    Views
    394 views
    File license
    Fair use/fair dealing exception

Reply 1 of 6, by willow

User metadata
Rank Member
Rank
Member

Dgvoodoo is only used in software MMX mode and not accelerated mode (direct3d and glide).

With nglide, glide renderer is present. If you copy glide*x.dll in TA kingdoms folder, glide renderer is not present like if dgvoodoo is not initialized.

I you select direct3d mode, black screen and not dgvoodoo watermark

in software mmx mode, dgvoodoo watermark and movie works. No display bug

it's strange.

Reply 2 of 6, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

Thanks. I made some changes in version info of Glide modules, now dgVoodoo is usable too (Glide3x).
D3D hw accelerated seems to get stuck with 3 monitors in the device enumeration. What if you enable only one monitor through the dgVoodoo config?

For D3D accelerated, use the ATI Radeon 8500 virtual card. Or just use the Glide renderer, D3D seems to be the worst in quality.

Reply 3 of 6, by Zaragon

User metadata
Rank Newbie
Rank
Newbie

The problem with using the Glide renderer is that it doesn't support widescreen (1920x1200) on my machine, only 1600x1200 (at least with nGlide). I didn't try dgVoodoo in Glide mode, because despite the fact it's in the name, I forget that dgVoodoo actually does Glide.

Both D3D and Software rendering mode support 1920x1200.

Reply 4 of 6, by willow

User metadata
Rank Member
Rank
Member
Dege wrote:

Thanks. I made some changes in version info of Glide modules, now dgVoodoo is usable too (Glide3x).
D3D hw accelerated seems to get stuck with 3 monitors in the device enumeration. What if you enable only one monitor through the dgVoodoo config?

For D3D accelerated, use the ATI Radeon 8500 virtual card. Or just use the Glide renderer, D3D seems to be the worst in quality.

How enable only one monitor through the dgVoodoo config?
Where can I download your new version of dgvoodoo?

Reply 6 of 6, by willow

User metadata
Rank Member
Rank
Member
Dege wrote:

One monitor: select your graphics card from the 'Adapters' list and then select a monitor attached to it from the 'Full screen' list.
Try WIP67 for the Glide3 renderer.

Glide renderer works with wip67

Dege wrote:

One monitor: select your graphics card from the 'Adapters' list and then select a monitor attached to it from the 'Full screen' list.

I have tried and it doesn't works.