VOGONS


First post, by MrPepka

User metadata
Rank Newbie
Rank
Newbie

I can't force the game mentioned in the topic name to work properly with dgvoodoo 2. The game starts under this wrapper, but in such a way that the screen is cut off and it's so that I can't see any options in the main menu. It helps to reduce the resolution in options, however, the graphics quality is deteriorated.
Dgvoodoo 2 I have in the latest version 2.62.3. Is there a way to do this?

Reply 1 of 16, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Compatbility options for the game, set "Disable fullscreen optimizations" , make sure that under "Change high DPI settings" "Override High DPI Scaling behavior. Scaling performed by:" is set to "Application".

Make sure dgVoodoo isn't set to windowed mode.

It should work then, but the game seems to do some resolution switching dgVoodoo isn't aware of, so you can't force resolution and dgVoodoo's scaling mode must be set to "Unspecified", "Centered" or "Stretched" or it will look really bad.

Seems resolution forcing isn't needed as if you edit config.pc it will happily set a 4K resolution (though who knows, it might crash later):

monstersinc.jpg
Filename
monstersinc.jpg
File size
210.38 KiB
Views
610 views
File license
Fair use/fair dealing exception

Don't see the point in using dgVoodoo for this though? It runs fine natively.

Reply 2 of 16, by MrPepka

User metadata
Rank Newbie
Rank
Newbie

And how to force the resolution to be changed in the config.pc file? I can't read it in the notepad, and in the hex editor I don't see any hex values ​​that match the set resolution
As for the problem, I noticed that when I start the game natively, first there is a black screen with the cursor for a moment, and only after about 10 seconds the game starts (i.e. there is some resolution adjustment), and under dgvoodoo this is not there and probably the game starts with the screen cut off

Reply 3 of 16, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Why haven't you tried the compatibility modes I mentioned, and if you have, why haven't you posted the result?

MrPepka wrote:

And how to force the resolution to be changed in the config.pc file? I can't read it in the notepad, and in the hex editor I don't see any hex values ​​that match the set resolution

Do you have a different config.pc than me or can't you read hex?

monstershex.png
Filename
monstershex.png
File size
49.16 KiB
Views
566 views
File license
Fair use/fair dealing exception

E0 01 = 480
80 02 = 640

https://www.wsgf.org/article/hex-editing-tuto … mcity-4-example
https://www.wsgf.org/article/common-hex-values

Also remember UAC file virtualization, if you have the game installed in a location you don't have write access to, config.pc will be written to VirtualStore, so the one in the game folder won't have the value you set.

Reply 4 of 16, by MrPepka

User metadata
Rank Newbie
Rank
Newbie

I will try compatibility modes in a moment. Okay, I've already changed the resolution. I will let you know the results soon
I forgot to mention. I have Windows 8.1 so all I have is "Disable display scalling on high DPI settings" option. Should I select it or not? Dgvoodoo is in full screen mode so it remains to change the "Scalling mode" setting

Reply 5 of 16, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie
MrPepka wrote:

I will try compatibility modes in a moment. Okay, I've already changed the resolution. I will let you know the results soon
I forgot to mention. I have Windows 8.1 so all I have is "Disable display scalling on high DPI settings" option. Should I select it or not? Dgvoodoo is in full screen mode so it remains to change the "Scalling mode" setting

You should select "Disable display scaling", yes.

Reply 6 of 16, by MrPepka

User metadata
Rank Newbie
Rank
Newbie

It doesn't help either changing the "Scalling mode" setting in dgvoodoo, or checking "disable display scalling" in the compatibility settings. An interesting case.
BTW: The game from what I see has a frame limit of up to 30. As I understand it, there is no chance to turn it off?

Reply 7 of 16, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Try placing dgVoodoo.conf from the dgVoodoo download in the game's directory. That's the stock configuration file, something might be wrong with your configuration (you did check that window mode wasn't enabled right? could be some other setting too...).

Maybe try setting Windows global DPI scaling setting to 100% to rule that out entirely:
https://www.eightforums.com/threads/dpi-scali … dows-8-1.28310/

If neither is the problem then it's probably some compatibility issue with Windows 8.1 specifically.

Reply 12 of 16, by MrPepka

User metadata
Rank Newbie
Rank
Newbie

Resolution as I understand you have set to Full HD? In the game settings level of detail you have set to High or to another? Do you have any compatibility settings enabled in the game properties?

Reply 15 of 16, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

That different language builds would have different window handling code seems much more unlikely to me than there just being differences between Windows 8.1 and Windows 10.

Could be some other factor specific to your system too, but I can't think of what it could be.

Reply 16 of 16, by Brandondorf9999

User metadata
Rank Newbie
Rank
Newbie
MrPepka wrote on 2019-12-06, 19:25:

And how to force the resolution to be changed in the config.pc file? I can't read it in the notepad, and in the hex editor I don't see any hex values ​​that match the set resolution
As for the problem, I noticed that when I start the game natively, first there is a black screen with the cursor for a moment, and only after about 10 seconds the game starts (i.e. there is some resolution adjustment), and under dgvoodoo this is not there and probably the game starts with the screen cut off

If you want widescreen support extending the FOV, try my Flawless Widescreen script:

https://community.pcgamingwiki.com/files/file … and-fws-script/