VOGONS


First post, by benadnam

User metadata
Rank Newbie
Rank
Newbie

I'm not sure if it's a bad idea to post this,

Hello,
I am trying to run Gruntz. The game runs awfully slow natively on Windows 10, there were a few workarounds for a DirectDraw wrapper and dgVoodoo seems to be the most efficient way. However, there is only one problem. There are windows in the game that are normally displayed in-game. But with dgVoodoo, the game gets minimized to desktop and only the window that's popped up stays. This does not happen normally. I was wondering if there is a way to stop dgVoodoo from doing that because i can't get it to work on the CPL.

This is what should happen:
1.png
This is what happens:
2.png

Reply 1 of 3, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

Yes, there is. You have to run the game in fake fullscreen mode and disable the default lose-focus behavior (minimizing).
So, for fake fullscreen, set:

General\ScalingMod = 'Stretched, keep aspect ratio'
General\FullScreenMode = false
General\CenterAppWindow = true
GeneralExt\WindowedAttributes = 'borderless', 'fullscreensize'
DirectX\AppControlledScreenMode = false

and to disable the minimizing mode, set

DirectX\DisableAltEnterToToggleScreenMode = false

(You can enable the additional tabs on the CPL by a right-click, and selecting the command popping up.)

Reply 2 of 3, by benadnam

User metadata
Rank Newbie
Rank
Newbie

Thank you for the response.

I did what you said, and the window works now as you said. However, on the main menu, when i click on the buttons, it doesn't enter to the selected button. There is a part in the top-left corner that gets the mouse inputs. I suppose there is an actual game screen there and it works for the mouse input instead of the stretched game screen. The mouse works well in the windows and in-game, but i noticed that the cursor gets out of the screen in game. I suppose this happens to make the window work and it's (currently) unfixable.

Reply 3 of 3, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

The game always expects the mouse input in the top-left coordinate space because it doesn't know about the upscaled window.
dgVoodoo has mouse emulation which means it draws its own mouse cursor to the upscaled position.

But, it's true that this mouse emulation isn't present in windowed mode. I think the only solution would be introducing the concept of real fake fullscreen into dgVoodoo (instead of the current magic done with the windowing options).