VOGONS


First post, by Instandhaltung

User metadata
Rank Newbie
Rank
Newbie

Hey everyone,

new, noob and not native speaker here. I was trying to play some games with dgVoodoo, and they all work great in widescreen resolution, but 4:3 aspect ratios are always stretched, and the windowed mode does not work (the game screen stays at the upper left corner without a window).
Specs:
Notebook with IntelHD and NVidia graphics. Full HD resolution

What I tried so far:
-Checked the scaling of my IntelHD software. The scaling is set to "maintain aspect ratio", and works well when not using dgVoodoo2. Also, the "center image" option does actually center the image, even with dgVoodoo. NVidia scaling does not work, because the configuration is disabled on notebooks with Intel chipsets

-Changed the scaling modes in dgVoodoo: Unspecified stretches the image. Centred centers the image. Stretched- Keep aspect ratio does not work for some games (Anno 1602) or in fact do work (Anno 1503), but the mouse is only moveable on the upper left corner of the screen, the movement space is related to the original resolution of the game. "Capture Mouse" and "Free Mouse" did not help much.

-Tried to play the game in windowed mode. The game is stuck to the upper left corner of the screen, without a window: Changing "App controlled Fullscreen", "Disable Alt-Enter", Scalings,"windowed mode attributes" did not help.

-Some other things I may not remember right now.

Does somebody know what I could do (preferably without changing the resolution every time I want to play a 4:3 game)?

Thanks in advance!

Reply 1 of 3, by Delfino Furioso

User metadata
Rank Newbie
Rank
Newbie

I usually change the following settings by editing the configuration file directly
They work pretty well most of the times - the only exception being some games that require FullScreenMode to be set to TRUE

on the left the default settings, on the right my custom settings

Screenshot-196.png

Reply 2 of 3, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

The recommended ways for keeping the AR is the following:

- Set it through the GPU control panel (with unspecified scaling mode set in dgVoodoo cfg)
- Setting 'Stretched, Keep aspect ratio' in dgVoodoo config

The latter one is not guaranteed to work, especially because of the mouse emulation it brings in. You wrote none of them works for those games, so I think I should check out the games themselves to see what the particular problem is there.

The fake fullscreen mode (as nicely posted by Delfino) also worth a try.

Reply 3 of 3, by Instandhaltung

User metadata
Rank Newbie
Rank
Newbie

All right, thanks a bunch for answering, you two! Sadly, the fake fullscreen mode didn't work, I really wonder why my machine doesn't accept the 4:3 ratio of dgVoodoo and stretches it. Also, I think I do not have the capabilities to look into the games to check out what's wrong with them :'). They are both made by a smaller studio back in the day, probably custom made engine, but that's about it. Anyway thanks guys, I do now now that there is nothing I may have missed! I can still install a VM and play that way if nothing else works.