VOGONS


First post, by MrFlibble

User metadata
Rank Member
Rank
Member

Recently I found the Voodoo version of the Scorched Planet demo and tried to run it, and it does work for me with both nGlide or dgVoodoo, but with one problem:
Y6MigKN.png
I get exactly the same issue with nGlide. The demo seems to work fine in every other aspect.

I'm on Windows 8.1 64-bit. For simplicity's sake I did not change anything in the dgVoodoo configuration file, although changing something I already forgot fixed the display of the mission briefing (it is not shown at all with the default settings).

The installer provided with the demo did not work for me (it says the OS is not Windows 95 even if compatibility is set to it) but I just extracted the game data into a separate directory (I made sure it sits in the root and the directory name does no exceed 8 characters). The game does not seem to use the Windows registry anyway, relying on its own configuration file instead, like the DOS version.

You can get the demo here, I found it on a magazine coverdisk.

DOS Games Archive | List of free open source games | List of free closed source games

Reply 1 of 1, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

Sorry, late respond but I tested the demo.

The problem is that the game doesn't enable LFB bypass for the HUD. Experimentally I forced it and it looked as expected in that case.
For my curiosity I looked into the executable and found that LFB bypass is only enabled temporarily in a small piece of code but even that one seems to be dead code (never executes).
I don't know why it worked back when the demo was released, maybe it was based on an early buggy Glide driver where LFB bypass was enabled by default.

It all could be patched though, but I don't know if it worths. What about the full game version?