VOGONS


First post, by UCyborg

User metadata
Rank Member
Rank
Member

I used modified DLL to run at the native resolution. I don't remember whether DLL mods were needed years ago to run at 1920x1080, when I had Radeon 4890 and Windows 7.

So it's apparently a bit more problematic than I knew, PCGW says shadows don't work on AMD cards among other things. Might have been playing it years ago unaware of that fact. Possibly only applies to certain (older) cards or just older drivers.

Equipped with my trusty NVIDIA GeForce GTX 750 Ti, I tried the game with and without dgVoodoo and came across the shadow problem with dgVoodoo, even if I set ID Type to NVIDIA on DirectXExt tab and also both vendor ID and device ID matching my GPU (does any game check subsystem ID and rev ID as well?).

Comparison with and without dgVoodoo:

I3lhuHJ.png
There is a simple character shadow here, reminds me of Quake III default shadow.

A6c30U1.png
That's better! Lightning as well.

Finally, the game hangs when switching away from it. It may hang even natively under certain seemingly rare circumstances. I tested on latest and greatest WIP74.

Arthur Schopenhauer wrote:

A man can be himself only so long as he is alone; and if he does not love solitude, he will not love freedom; for it is only when he is alone that he is really free.

Reply 1 of 2, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

I don't know what to say about this.
I've just given a try to the game but both Alt-Tab and the shadows works fine both with DX11/12. At least, it seems to.
Low shadow settings: simple 'circle' shaped shadow for the player (and maybe for the other characters) but no static shadows
Medium/High shadow settings: true projected shadows

It seems that the circle shadow is always rendered though.

Do you miss the shadow generally or is it location specific like on your screenshots?

Reply 2 of 2, by UCyborg

User metadata
Rank Member
Rank
Member

You're right about the circle shadow always being rendered. And yeah, on my end, running the game with dgVoodoo always makes it look like as if shadows were set to low, even when I've set them to high.

I also tried making the game re-create profile.bin file with settings while running with dgVoodoo, it didn't help. I also tried selecting WARP, very slow, but looks the same. Doesn't have to do with modded prototypeenginef.dll neither.

Location in the game world doesn't matter.

No trouble alt-tabbing today though.

Arthur Schopenhauer wrote:

A man can be himself only so long as he is alone; and if he does not love solitude, he will not love freedom; for it is only when he is alone that he is really free.