VOGONS


First post, by lowenz

User metadata
Rank Oldbie
Rank
Oldbie

I ask the mighty Dege for help/explanation 😁
dgVoodoo2 is not the cause, but maybe can be A solution for this strange issue this 2 games ("UE 1.5") have since 2003/2004.

https://www.ttlg.com/forums/showthread.php?t= … l=1#post2466094

Here's what I mean as "blur", you'll see it really well using 1/4 resolution (1280x720 instead of 2560x144) and then integer-upscaling

PNG images so NO compression artifacts!
No wrappers, no reshade, only dx8+visible upgrade ( https://www.moddb.com/mods/deus-ex-2-visible- … -update-edition )
And of course Bloom is DISABLED!

2560 (slightly visible blur)
https://www.mediafire.com/file/sitzusogol5bmng/2560.png/file

1280 (visible blur along the door lightbar profile - no possible fullscreen problem 'cause it's done in windowed mode and then integer-upscaled -> and as you can see the HUD IS NOT AFFECTED BY BLURRING )
https://www.mediafire.com/file/xcj3gl9kbm2kmg … 280+IS.png/file

So it's something before in the rasterization pipeline!

Just take a look to the "jaggies" (aliasing), they're not right (not SHARP, as they must be in a PNG lossless image), like there's some kind of filtering already applied (no AA, no Bloom) or wrong internal resolution.
Always thought (since 2003, 🤣 ! ) it was a bloom side-effect, turned out to be false!

You can see the issue very well on a Quad HD monitor using 1280x720 and then an integer upscaler (upscaling with no bilinear filtering, just brutal 1 pixel -> 4 pixels ).
There's something smoothing the image in the rasterization pipeline, as you can see in the 1280x720->2560x1440 image. That blurring along the contours would NOT be present otherwise.

Last edited by lowenz on 2021-02-05, 16:11. Edited 1 time in total.

Reply 2 of 5, by lowenz

User metadata
Rank Oldbie
Rank
Oldbie
ZellSF wrote on 2021-02-05, 14:10:

Those links aren't valid.

Pardon!

https://www.mediafire.com/file/sitzusogol5bmng/2560.png/file
https://www.mediafire.com/file/xcj3gl9kbm2kmg … 280+IS.png/file

Integer scaling version (lossless PNG, so no visual artifacts) shows really well this strange issue.

Reply 3 of 5, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

The "blur" (jagged line) is present even on the 2560x1440 image. It's barely visible by eye but open the picture in Paint.NET (or plain Paint) and zoom into the edges of 3D objects, you'll see it. So, that's what rendered in lower resolutions and get thicker by pixel multiplying.
Isn't it plain MSAA working well generally but working very badly for the lightbar edges? Or maybe the oldschool edge-antialasing (drawing lines along the edges of objects to soften it)?

Anyway, it should be investigated with a graphics debugger if the same happens through dgvoodoo.

Reply 4 of 5, by lowenz

User metadata
Rank Oldbie
Rank
Oldbie

No AA in any form (UE 1.5 only supports MSAA and it is disabled here) !
For years I've thought it was a byproduct of bloom, but now I can see it disabling the bloom too!

The logo/ intro map is not showing this issue at all!

Last edited by lowenz on 2021-02-05, 22:19. Edited 1 time in total.

Reply 5 of 5, by lowenz

User metadata
Rank Oldbie
Rank
Oldbie

Thief DS behaviour:

As you can see the "logo" map has no blurring at all, the Moira map shows.....both!

https://www.mediafire.com/file/vf6zcp9knye8ujo/0.png/file
https://www.mediafire.com/file/69b1m9hyztco25w/1.png/file