VOGONS


First post, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member

When I use dgVoodoo 2, a common problem that I encounter is that the game switches to Windowed mode automatically, even if the game doesn't have the feature. If I uncheck the feature which 'disables the Alt+Enter function to switch to fullscreen', the game will then switch to fullscreen mode using Alt+Enter. However this feature is provided only in DirectX. I have the same problem with a game called Starshot Circus Fever, the game works on both nGlide and dgVoodoo 2 but none of the cutscenes work in nGlide which instead work in dgVoodoo 2. However the game goes to Windowed mode and since the switching feature is not provided in dgVoodoo 2, I have to stick to windowed mode. Could you please add this feature to the 3Dfx mode too along with the DirectX mode?

Or if I am not aware, is there an option to make this function work or at least prevent the game from switching to windowed mode?

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 1 of 4, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

Alt-Enter is always enabled for Glide, there is no particular option for that. I must admit, it doesn't always work because not all old games pump their message queue so Alt-Enter's get absorbed and unprocessed.
However, windowed mode is not part of the Glide API, so an application can't switch to windowed mode on it own behalf.
If General\FullScreenMode is set to true but the game changes to windowed mode in spite of that then it must be because of an event or fact independent on dgVoodoo: losing window focus and/or having a (child) window on top of the game window or such.

Reply 2 of 4, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member

I decided to launch from the desktop and this thing occurs again. The mouse cursor is frozen in the centre of the screen, when I Alt+Enter it changes from windowed to fullscreen but then reverts back immediately.
download/file.php?mode=view&id=103299

As you see in the picture, the window is in the top-left of the screen.

Attachments

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 4 of 4, by Dege

User metadata
Rank Oldbie
Rank
Oldbie

Do you play this game with dgVoodoo ddraw.dll and d3dimm.dll copied into the game folder or natively?

For me, natively the game doesn't even start up. With dgVoodoo the video playback is missing, only blank screen (not clear why, but nothing is rendered into the dd surfaces from the game side).
Aside from that, Glide works as expected and I can toggle fullscreen/windowed by Alt-Entering.