VOGONS


First post, by aha2940

User metadata
Rank Member
Rank
Member

Hello everyone, I'm trying to run original DOS Quake 1.08 under Windows 98 SE on my Pentium 4 2.4GHz, 512MB RAM machine. It runs, however it seems to run too fast if I run it at any resolution below 800x600, and at that resolution it seems the video card (nvidia GeForce 2 MX400) can't really cope with it since it starts lagging and it feels slow, so I can't get a perfect experience with the game. Is this speed sensitiveness normal? is there anything I can do about it (other than using another PC)?

Thanks!

Reply 1 of 5, by foil_fresh

User metadata
Rank Member
Rank
Member

it should be capped at 72fps (timedemo will reach higher frames). when going over 72fps you will notice some phyiscs bugs/irregularities. Specifically with jumping and landing. Going down ramps can become weird and jitterry.

Reply 2 of 5, by Joseph_Joestar

User metadata
Rank Oldbie
Rank
Oldbie

Press the tilde key (~) to open the console and check your game version. If it's currently 1.01 then patch it to version 1.06. After that, apply patch 1.08 which is the final DOS release.

Next, edit config.cfg and add this line (or modify the existing one if it's already there). It's not a typo, there's an underscore before the command too:

_vid_wait_override "1"

This will turn VSync on which should eliminate any tearing and stutter, but it will reduce your FPS by roughly one half.

Lastly, to get optimal performance, you need to run either FASTVID or MTTRLFBE before starting Quake. Use just one of those tools, not both at once.

Using Audigy drivers with a Sound Blaster Live
Installing DOS drivers on an Audigy2 ZS
OPL3 vs. ESFM vs. CQM vs. SBLive
OPTi 82C930 review

Reply 3 of 5, by aha2940

User metadata
Rank Member
Rank
Member
Joseph_Joestar wrote on 2021-01-14, 04:44:
Press the tilde key (~) to open the console and check your game version. If it's currently 1.01 then patch it to version 1.06. A […]
Show full quote

Press the tilde key (~) to open the console and check your game version. If it's currently 1.01 then patch it to version 1.06. After that, apply patch 1.08 which is the final DOS release.

Next, edit config.cfg and add this line (or modify the existing one if it's already there). It's not a typo, there's an underscore before the command too:

_vid_wait_override "1"

This will turn VSync on which should eliminate any tearing and stutter, but it will reduce your FPS by roughly one half.

Lastly, to get optimal performance, you need to run either FASTVID or MTTRLFBE before starting Quake. Use just one of those tools, not both at once.

Changing this "_vid_wait_override" option from 0 to 1 in my id1\config.cfg file has done the trick. The game feels better now, running at 800x600. Perhaps not perfect, but maybe I've been spoiled by how well the darkplaces engine plays on modern computers. Thanks for your help.

Reply 4 of 5, by auron

User metadata
Rank Member
Rank
Member

the resolution limit is due to DOS quake only allocating 8mb when run under windows, i think. there's the -winmem argument to fix that but why not just use winquake in the first place? or just run it under real DOS.

Reply 5 of 5, by aha2940

User metadata
Rank Member
Rank
Member
auron wrote on 2021-01-15, 09:37:

the resolution limit is due to DOS quake only allocating 8mb when run under windows, i think. there's the -winmem argument to fix that but why not just use winquake in the first place? or just run it under real DOS.

WinQuake looks like a nice option. Will try it, since I've never used it. Running in real DOS is a no go for me because this is a Pentium 4 machine, with no ISA slot and the DOS support for the SB Live PCI I have is not that great.