VOGONS


windows 3.11 share drive problems

Topic actions

Reply 20 of 35, by dosgamer

User metadata
Rank Newbie
Rank
Newbie

Sorry, wrong again. 😁

sambawfw311_2.jpg

Here's what I did:

1. Install WfW (network card is autodetected)
2. Install TCP32
3. Remove all protocols except TCP/IP
4. Setup TCP/IP, select DHCP
5. Enter net usershare [...] in Linux shell
6. Open Windows File Manager, map network drive, select share on my Linux PC
7. Done-ski

Coppermine Celeron 800 @ 1.12GHz (8x140) - Asus P2B Rev. 1.12 - 256MB PC133 CL2 - Voodoo5 5500 AGP - SB AWE64 CT4520 - Roland SCC-1 - Intel Pro/1000GT - 1.44MB Floppy - ATAPI ZIP 100 - 120GB IDE - DVD-ROM - DVD-R/RW/RAM - Win98SE

Reply 21 of 35, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
dosgamer wrote:

5. Enter net usershare [...] in Linux shell
6. Open Windows File Manager, map network drive, select share on my Linux PC

Then you are fortunate enough to have a Linux configuration in which NetBIOS over TCP/IP is enabled by default. 😒
http://www.techradar.com/news/networking/samb … ndows-1154705/2

(Of course there would be no setting in Windows 3.x to enable or disable NetBIOS over TCP/IP, because it is impossible for Windows 3.x to use anything else.)

Reply 22 of 35, by dosgamer

User metadata
Rank Newbie
Rank
Newbie

It's just the default Debian install. Just for shits and giggles, I added disable netbios = yes to smb.conf, made no difference, WfW can still access everything just fine. Anything else? 😁

Coppermine Celeron 800 @ 1.12GHz (8x140) - Asus P2B Rev. 1.12 - 256MB PC133 CL2 - Voodoo5 5500 AGP - SB AWE64 CT4520 - Roland SCC-1 - Intel Pro/1000GT - 1.44MB Floppy - ATAPI ZIP 100 - 120GB IDE - DVD-ROM - DVD-R/RW/RAM - Win98SE

Reply 24 of 35, by dosgamer

User metadata
Rank Newbie
Rank
Newbie

Here ya go:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:33320 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
tcp6 0 0 ::1:25 :::* LISTEN
tcp6 0 0 :::445 :::* LISTEN
tcp6 0 0 :::45374 :::* LISTEN
tcp6 0 0 :::139 :::* LISTEN
tcp6 0 0 :::111 :::* LISTEN
udp 0 0 0.0.0.0:51580 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*
udp 0 0 0.0.0.0:735 0.0.0.0:*
udp 0 0 127.0.0.1:761 0.0.0.0:*
udp 0 0 0.0.0.0:5353 0.0.0.0:*
udp 0 0 0.0.0.0:19824 0.0.0.0:*
udp 0 0 0.0.0.0:38831 0.0.0.0:*
udp 0 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 10.0.0.109:123 0.0.0.0:*
udp 0 0 127.0.0.1:123 0.0.0.0:*
udp 0 0 0.0.0.0:123 0.0.0.0:*
udp 0 0 10.0.0.255:137 0.0.0.0:*
udp 0 0 10.0.0.109:137 0.0.0.0:*
udp 0 0 0.0.0.0:137 0.0.0.0:*
udp 0 0 10.0.0.255:138 0.0.0.0:*
udp 0 0 10.0.0.109:138 0.0.0.0:*
udp 0 0 0.0.0.0:138 0.0.0.0:*
udp6 0 0 :::53947 :::*
udp6 0 0 :::735 :::*
udp6 0 0 :::44230 :::*
udp6 0 0 :::5353 :::*
udp6 0 0 :::111 :::*
udp6 0 0 fe80::21e:64ff:fe40:123 :::*
udp6 0 0 ::1:123 :::*
udp6 0 0 :::123 :::*
udp6 0 0 :::55630 :::*

BTW, disable netbios = yes doesn't change any of the ports.

Coppermine Celeron 800 @ 1.12GHz (8x140) - Asus P2B Rev. 1.12 - 256MB PC133 CL2 - Voodoo5 5500 AGP - SB AWE64 CT4520 - Roland SCC-1 - Intel Pro/1000GT - 1.44MB Floppy - ATAPI ZIP 100 - 120GB IDE - DVD-ROM - DVD-R/RW/RAM - Win98SE

Reply 25 of 35, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
dosgamer wrote:

BTW, disable netbios = yes doesn't change any of the ports.

Well, if it's listening on ports 137-139, that would seem to indicate NetBIOS over TCP/IP is enabled. I can't imagine why it would be listening on those ports otherwise. As to why editing smb.conf has no effect, I would not know. (I assume you're restarting smbd after editing.)

ETA: A little more Googling suggests that nmbd (which is part of Samba) might also have to be stopped/configured.

It is strange that, considering Linux seems to emphasize security, this legacy protocol is apparently enabled by default even when it has no use with modern versions of Windows.

Reply 26 of 35, by dosgamer

User metadata
Rank Newbie
Rank
Newbie

Oh ok, I only issued "service smbd restart", that would explain why it still worked. Yes, it seems NetBIOS is enabled by default in Samba, you have to explicitly add the "disable netbios = yes" line to disable it. Maybe some distros do it? I just checked the distros currently installed on my HDD and neither Debian, Ubuntu nor CentOS disable NetBIOS in their default smb.conf. In any case, I don't see how it's more of a security risk than the rest of SMB, and of course it makes things easy for us retro users. 😁

Coppermine Celeron 800 @ 1.12GHz (8x140) - Asus P2B Rev. 1.12 - 256MB PC133 CL2 - Voodoo5 5500 AGP - SB AWE64 CT4520 - Roland SCC-1 - Intel Pro/1000GT - 1.44MB Floppy - ATAPI ZIP 100 - 120GB IDE - DVD-ROM - DVD-R/RW/RAM - Win98SE

Reply 28 of 35, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
Robhalfordfan wrote:

try that with win 10 pc and did nothing same thing happening

You mean you followed the instructions in http://searchenterprisedesktop.techtarget.com … in10-NAS-Access ?

Reply 29 of 35, by Robhalfordfan

User metadata
Rank Oldbie
Rank
Oldbie
Jorpho wrote:
Robhalfordfan wrote:

try that with win 10 pc and did nothing same thing happening

You mean you followed the instructions in http://searchenterprisedesktop.techtarget.com … in10-NAS-Access ?

yeah followed it and did nothing

Reply 31 of 35, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
watlers_world wrote:

Windows 10 is still sold by Microsoft.
MS Tech support should be able to provide you with full help and support.

Come on, seriously? Windows 3.x is not sold by Microsoft anymore and they couldn't care less if you're trying to connect a Windows 3.x computer to a Windows 10 computer.

Reply 32 of 35, by y2k se

User metadata
Rank Newbie
Rank
Newbie
Ampera wrote:

Try an FTP server. There probably exists a client for Win16. Samba didn't really do much until 95-98, and really was only good on NT5 up.

++ on using an FTP server to move files around. IIRC, the TCP/IP package for Windows 3 includes a FTP client.

Tualatin Celeron 1.4, ASUS P2B, 512 MB, GeForce 3 Ti 200, Voodoo2 SLI, AWE64, WD 80GB SE HDD, Dell 2007FP

Reply 33 of 35, by Brickpad

User metadata
Rank Member
Rank
Member
tayyare wrote:

This is similar to my experience. I had no problem reaching to a shared folder in a Windows 3.11 or Windows 9x shared folder but not otherwise. But I also am quite sure that not only first two octecs, but first three should be same according to my experience : like 192.168.1. 10 and 192.168.1.15. Being in the same "workgroup" might also help (mine are in the same workgroup but I'm not sure what happens if they were not).

You are correct. Not sure what I was thinking, but yes the first three octets must be in the same.

Reply 35 of 35, by Jade Falcon

User metadata
Rank BANNED
Rank
BANNED
Ampera wrote:

Try an FTP server. There probably exists a client for Win16. Samba didn't really do much until 95-98, and really was only good on NT5 up.

This. Was going to post it myself.