Win98/Me Setup hangs at Copying files needed..

Getting old software/games running on older hardware.

Win98/Me Setup hangs at Copying files needed..

Postby appiah4 » 2017-5-15 @ 05:36

This strange issue is driving me nuts.

Lucky Star 6P2BX2 board with Wimbios patched BIOS for HDD up to 128G
Pentium III 450 Slot 1
2x 128MB PC133 CL7 RAM
Voodoo 3 3000 AGP
Creative SB Live Value CT4780
Seagate 7200.8 Barraccuda 80G IDE
NEC 16x DVD-RW
USB keyboard

Partitioned the harddrive with gparted live cd and set a 4gb primary Fat32 as bootable.
Ran WinMe setup and it formatted the primary partition.
Ran scandisk and found empty space misreported. Fixed it.
Went to black screen, Copying files needed for setup message and hangs.

I said wat and immediately blamed Me so I tried installing 98SE instead.
Setup found the formatted primary partition, scanned it and ran scandisk reporting there were issues with the FAT so it would reveet latest changes to prior state.
Went to black screen, Copying files needed for setup message and hangs.

Booted WinMe command prompt ran fdisk /mbr then fdisk to delete all partitions and repartition in case gparted fucked up.
Tried to reinstall, same issue.
Booted WinMe command prompt to manually format C: only to find the 4G partition shows up as 3.2G after format and realized it might be a cluster size issue.. Ran fdisk to wipe partitions AGAIN and reduce primary partition to 2G.

Too tired so went to bed.

Most issues online seem to be caused by boot virus protection, people are advised to turn this off. My Award bios only has the Virus Warning option and its set to disabled (possibly works ass backwards abd I should enable it?). I will also try copyinf the files to the HDD to try installing from there.

Open to all suggestions..
A500:+512K|ACA500+|C1084S
i386:Am386SX-25|4M|TVGA9000B|ES688
i486:U5S-33|8M|GD5428|CT2290/MUNT-Pi
i586:P133|32M|S3T64+/MX2|V1|CT3980/32M
i686:K6-2/400|64M|V2/SLI|CT4500/32M
S370:P3-1200|384M|GF4Ti4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 3752
Joined: 2017-2-19 @ 07:36

Re: Win98/Me Setup hangs at Copying files needed..

Postby Ampera » 2017-5-15 @ 06:29

Why are you using a 4GB partition on an 80GB drive?

Do the whole drive and come back.

Other things to try are using a different drive (maybe smaller too), different HBA, different optical drive.
User avatar
Ampera
Oldbie
 
Posts: 901
Joined: 2016-11-16 @ 22:31

Re: Win98/Me Setup hangs at Copying files needed..

Postby appiah4 » 2017-5-15 @ 07:50

Ampera wrote:Why are you using a 4GB partition on an 80GB drive?

Do the whole drive and come back.

Other things to try are using a different drive (maybe smaller too), different HBA, different optical drive.


I also set up the rest of the drive as a single extended partition with multiple logical drives in it (including fat32, linux swap and ext4), so the rest of the drive is not empty. I reduced the primary partition to 2GB in case primary partitions over 3.2gb cause issues for FAT32 Win98/Me installs, but haven't had the chance to try that yet.

As a side note, I know that it's not motherboard, RAM, DVD-ROM or IDE cable related because I can boot and use multiple Linux Live CDs no issues. What remains is either the HDD being bad (unlikely, as linux can read, partition and install onto it fine..), patched BIOS issue (again, unlikely, works fine in Linux) or some stupid Windows issue (most likely, but what it is I have no idea)..
A500:+512K|ACA500+|C1084S
i386:Am386SX-25|4M|TVGA9000B|ES688
i486:U5S-33|8M|GD5428|CT2290/MUNT-Pi
i586:P133|32M|S3T64+/MX2|V1|CT3980/32M
i686:K6-2/400|64M|V2/SLI|CT4500/32M
S370:P3-1200|384M|GF4Ti4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 3752
Joined: 2017-2-19 @ 07:36

Re: Win98/Me Setup hangs at Copying files needed..

Postby Jorpho » 2017-5-15 @ 13:52

Did you let the BIOS automatically detect the hard drive parameters, or did you input them manually? I've seen strange behavior when the parameters weren't auto-detected. Also, is the drive jumpered correctly, e.g. master with no slave present? (Avoid Cable Select.)
User avatar
Jorpho
l33t++
 
Posts: 7043
Joined: 2003-2-14 @ 19:50
Location: Canada

Re: Win98/Me Setup hangs at Copying files needed..

Postby appiah4 » 2017-5-15 @ 13:57

Jorpho wrote:Did you let the BIOS automatically detect the hard drive parameters, or did you input them manually? I've seen strange behavior when the parameters weren't auto-detected. Also, is the drive jumpered correctly, e.g. master with no slave present? (Avoid Cable Select.)


IDE Auto Detection finds the drive as a proper 80GB and that's how it was set up.

The HDD is master and DVD-ROM is Slave, they work fine under Linux live distributions..
A500:+512K|ACA500+|C1084S
i386:Am386SX-25|4M|TVGA9000B|ES688
i486:U5S-33|8M|GD5428|CT2290/MUNT-Pi
i586:P133|32M|S3T64+/MX2|V1|CT3980/32M
i686:K6-2/400|64M|V2/SLI|CT4500/32M
S370:P3-1200|384M|GF4Ti4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 3752
Joined: 2017-2-19 @ 07:36

Re: Win98/Me Setup hangs at Copying files needed..

Postby cyclone3d » 2017-5-15 @ 14:37

Scandisk finding issues with the FAT every time you try to install sounds like a drive that is going bad to me.

I would definitely try a different drive.

It could also possibly be a bad stick of RAM.
User avatar
cyclone3d
l33t
 
Posts: 3080
Joined: 2015-4-08 @ 06:06
Location: Huntsville, AL USA

Re: Win98/Me Setup hangs at Copying files needed..

Postby Ampera » 2017-5-15 @ 15:55

Paritions over 3.2 GB don't have issues with FAT32. IIRC, It's 32 GB and that's only for LBA issues with machines that can't actually address a drive that big.

On that machine you should be fine up to around 130GB for disk size, and FAT32 is fine up to 2, to even 16 TiB in some cases.
User avatar
Ampera
Oldbie
 
Posts: 901
Joined: 2016-11-16 @ 22:31

Re: Win98/Me Setup hangs at Copying files needed..

Postby chinny22 » 2017-5-15 @ 18:54

yeh scandisk finding errors each time, on a new partition isn't a good sign.
Can imagine Linux being more forgiving then win9x

I would partition the fist drive with fdisk (MS should be fine with a MS created partition)
Just leave the rest of the drive unallocated, for the time being. Install windows.
You can then create the extended partition with gparted or fdisk. after windows is installed.
User avatar
chinny22
l33t
 
Posts: 2366
Joined: 2011-8-26 @ 12:02
Location: Australian but living in the UK for now

Re: Win98/Me Setup hangs at Copying files needed..

Postby appiah4 » 2017-5-15 @ 19:17

Installation works fine with 2GB Primary partition, WinMe installed 100% fine today. Out of curiosity I deleted the whole PT and repartitioned for 4096MB primary and the install hanged at the same spot with the same symptoms.

I do not know what it is, but with this board, and this BIOS, Win9x/Me refuse to install onto partitions larger than 3.2Gb (max partition size for 8K cluster size IIRC). It doesn't mind having an extended partitions of 74Gb though.

I will leave this here for the sake of anyone who goes nuts trying to figure something similar out: Try a partition size smaller than 3.2Gb.
A500:+512K|ACA500+|C1084S
i386:Am386SX-25|4M|TVGA9000B|ES688
i486:U5S-33|8M|GD5428|CT2290/MUNT-Pi
i586:P133|32M|S3T64+/MX2|V1|CT3980/32M
i686:K6-2/400|64M|V2/SLI|CT4500/32M
S370:P3-1200|384M|GF4Ti4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 3752
Joined: 2017-2-19 @ 07:36

Re: Win98/Me Setup hangs at Copying files needed..

Postby 95DosBox » 2017-5-23 @ 19:18

Ampera wrote:Paritions over 3.2 GB don't have issues with FAT32. IIRC, It's 32 GB and that's only for LBA issues with machines that can't actually address a drive that big.

On that machine you should be fine up to around 130GB for disk size, and FAT32 is fine up to 2, to even 16 TiB in some cases.

Can you elaborate your setup for 16TiB on FAT32?
User avatar
95DosBox
Member
 
Posts: 343
Joined: 2017-5-23 @ 09:34

Re: Win98/Me Setup hangs at Copying files needed..

Postby 95DosBox » 2017-5-23 @ 19:20

appiah4 wrote:Installation works fine with 2GB Primary partition, WinMe installed 100% fine today. Out of curiosity I deleted the whole PT and repartitioned for 4096MB primary and the install hanged at the same spot with the same symptoms.

I do not know what it is, but with this board, and this BIOS, Win9x/Me refuse to install onto partitions larger than 3.2Gb (max partition size for 8K cluster size IIRC). It doesn't mind having an extended partitions of 74Gb though.

I will leave this here for the sake of anyone who goes nuts trying to figure something similar out: Try a partition size smaller than 3.2Gb.


It could be the age of the BIOS causing this. But if you can partition the first partition as 2GB FAT16 you should be fine. The rest is extended partition. Then you will have to create logical drives. I wouldn't recommend a drive say over 60GB for Windows 98 legacy system since it doesn't like it. FDISK doesn't work properly unless you get the updated version.
User avatar
95DosBox
Member
 
Posts: 343
Joined: 2017-5-23 @ 09:34

Re: Win98/Me Setup hangs at Copying files needed..

Postby mrau » 2017-5-23 @ 19:25

95DosBox wrote:
Ampera wrote:Paritions over 3.2 GB don't have issues with FAT32. IIRC, It's 32 GB and that's only for LBA issues with machines that can't actually address a drive that big.

On that machine you should be fine up to around 130GB for disk size, and FAT32 is fine up to 2, to even 16 TiB in some cases.

Can you elaborate your setup for 16TiB on FAT32?


whats the cluster size on that?
mrau
Oldbie
 
Posts: 1089
Joined: 2015-11-28 @ 12:43

Re: Win98/Me Setup hangs at Copying files needed..

Postby Jorpho » 2017-5-24 @ 02:40

16 terabytes = 17,592,186,044,416 bytes

Divide by 2^32 = 4,294,967,296 and you get 4,096, so 4K clusters.

(In comparison, 2 GB = 2,147,483,648 bytes; divide by 2^16 = 65536, and you get 32,768, the 32K cluster size of a 2 GB FAT16 partition.)
User avatar
Jorpho
l33t++
 
Posts: 7043
Joined: 2003-2-14 @ 19:50
Location: Canada


Return to Software

Who is online

Users browsing this forum: AlessandroB, Caluser2000, nemail and 1 guest