VOGONS


First post, by Smack2k

User metadata
Rank Member
Rank
Member

What are the must have app /drivers / plug-ins needed for the following OS's to make sure you have most game needs covered, so when an attempt to install a game is made, the pre-reqs are already there?

Windows 95
Windows 98
Windows 2000
Windows XP

Reply 1 of 3, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

The various unofficial service packs would have you covered. If you're not inclined to install everything, the various Autopatcher distributions are limited to official packages and will let you be selective about what you install.

Offhand:
DirectX (and DirectX Media)
The runtimes for the various versions of Visual Basic and Visual C++
The .NET runtimes
Quicktime (but best avoided unless absolutely necessary)
The Intel Indeo 5 codecs (iv5play.exe)
The latest available Windows Media Player (or at least the applicable codecs)
The common dialog update for Windows 95 (include with IE4, but also available separately)
The windows installer update (I think that was Win95 only?)

Reply 2 of 3, by chinny22

User metadata
Rank l33t
Rank
l33t

For the most part I don't install any of the above, I'm a minimalist with my installs.
Usually Windows, latest version of IE, Office, Media player, Direct X and service pack for NT flavours, drivers (usually Intel based motherboard, NVidia video, Creative sound) D tools lite, WinRAR, WinRAR, that's it, no updates.

Office or IE installs the installer update, (needed by Dtools) and none of the drivers I use need .net or C++

I do have 1 troublesome game Dark Reign needs Direct 7 from memory and only 7 The installer wont let you pass if it cant find it.
But as long as you install, copy the game somewhere else, reinstall windows and install whatever version of DirectX you want. The game runs fine without going though the install routine.
Think Mist had similar thing with QuickTime