Video playback disables mouse and keyboard

Getting old software/games running on older hardware.

Video playback disables mouse and keyboard

Postby leonardo » 2018-7-02 @ 21:00

So I built this retro rig for a friend to game on. Intel 440BX-based system. Had many like it (though not with these EXACT components).

We ran into a strange issue: playing a .avi video file (game intro) will completely disable mouse and keyboard input on the system. The video will play back just fine, but the computer will have to be powered down to get the keyboard and mouse to work again. That's right, not even resetting the computer will work (cannot enter BIOS setup or anything).

This is pretty run-of-the-mill hardware: an Abit BH-6 Slot1 motherboard, Celeron 333 MHz CPU, 128 MB RAM, Diamond Viper V770 video card, ESS AudioDrive ES1869 sound...

Operating system is Windows 95 OSR2.

Solutions attempted:
I installed DirectX 7, vanilla nVidia Detonator drivers, ESS AudioDrive drivers are either from Vogons archive or from Phil's Computer Lab, don't recall.
I installed Windows Media Player 6.4 thinking it might be a codec issue, but that just made things worse; now explorer will crash (Illegal Operation) whenever I close System Properties (thru right-click 'My Computer'->Properties, or Control Panel: System).

Any takers? Since all I seem to be able to do, is to add problems. :D
My retro rigs
Methuselah, AMD K6-III+ 400 MHz, Voodoo 3 PCI, etc...
Longbottom, Pentium III 1 GHz, RivaTNT 2, Aureal Vortex 2 etc...
User avatar
leonardo
Newbie
 
Posts: 81
Joined: 2013-8-17 @ 14:42

Re: Video playback disables mouse and keyboard

Postby mrau » 2018-7-03 @ 17:19

what other player did You try?
it sounds like software corruption on system level;
playing without video acceleration helps?
mrau
Oldbie
 
Posts: 950
Joined: 2015-11-28 @ 12:43

Re: Video playback disables mouse and keyboard

Postby leonardo » 2018-7-15 @ 09:13

mrau wrote:what other player did You try?
it sounds like software corruption on system level;
playing without video acceleration helps?


OK - so I'm not 100% sure which of the things I did ended up fixing the problem:

I reinstalled Windows 95 from scratch.
This time I installed the USB-supplements even though I don't plan on using USB on this system.
This time I also installed the unofficial Service Pack (1.05) but deselecting DirectX 8, Windows Media and Windows Media Player 6.4.

I thought the explorer.exe crashes might have been caused by Windows Media/Windows Media Player 6.4 installation when one doesn't have Internet Explorer installed (as per my Windows 95 setup guide) but it turns out the culprit was the Cacheman optimisation that I had enabled (Windows 95->Average System). Once I disabled that, explorer no longer crashes.

Now I wonder if I dare try to install Windows Media/Media Player. I'd hate to have to do this ALL over again... :blah:
My retro rigs
Methuselah, AMD K6-III+ 400 MHz, Voodoo 3 PCI, etc...
Longbottom, Pentium III 1 GHz, RivaTNT 2, Aureal Vortex 2 etc...
User avatar
leonardo
Newbie
 
Posts: 81
Joined: 2013-8-17 @ 14:42

Re: Video playback disables mouse and keyboard

Postby leonardo » 2018-7-15 @ 09:22

...and here's the star of the show. 1999 called. They want this thing back.

IMG_3490.jpg


Fairly period correct. The new owner is going to be pleased for sure. :)
My retro rigs
Methuselah, AMD K6-III+ 400 MHz, Voodoo 3 PCI, etc...
Longbottom, Pentium III 1 GHz, RivaTNT 2, Aureal Vortex 2 etc...
User avatar
leonardo
Newbie
 
Posts: 81
Joined: 2013-8-17 @ 14:42


Return to Software

Who is online

Users browsing this forum: No registered users and 2 guests