Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Getting old software/games running on older hardware.

Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Postby GabrielKnight123 » 2018-11-26 @ 17:51

I have been playing QG4 the CD talkie version on my slot 1 Pentium 3 450MHz using a Sound Blaster AWE64 Value and I have noticed one thing that puzzles me about the part of the character Igor hitting a tomb stone with a hammer in the town next to the adventures guide building, with my setup there is no sound effect for the hammer hitting the tomb stone but on my Pentium 3 500MHz laptop using a ESS Maestro 2E PCI based sound card the sound effect is there. The laptop is using Windows 98se Dos mode from the start menu "restart in dos mode" as I cant use real Dos 6.21 because there is no Dos drivers for the PCI Maestro and it is using the usual SET BLASTER=A220 I5 D1 T4 after Maestro.com and a SYS file is loaded in autoexec.bat and config.sys and my AWE 64 is using something very similar only it has an SC55 for MIDI music, Does anyone know a way to get this sound effect to work? Its not all that important to game play as all the other sound effects work its just this one thing that would be great to have a solution or an explanation to why everything else works but not this one effect.
GabrielKnight123
Member
 
Posts: 316
Joined: 2017-3-03 @ 15:39

Re: Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Postby Spikey » 2018-11-28 @ 04:19

What settings do you have in resource.cfg? Especially for digital sound. And how are other sound effects doing besides the tombstone?
User avatar
Spikey
Member
 
Posts: 231
Joined: 2003-2-04 @ 10:36
Location: South Australia

Re: Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Postby GabrielKnight123 » 2018-12-01 @ 08:56

Well I found out why this one effect does not work its because its not a sound effect but a part of the music side, If you use MIDI and my SC55 has MT32 (emulation?) setting and GS and general MIDI (im not sure if this is right) setting and in the game settings if you use general MIDI the sound effect is not there but if you use game setting of MT32 the sound effect is there but it is played as a piano effect or something no matter which setting I use on the SC55, if you use Sound Blaster Pro as the music setting in the game the sound effect is there, as I remember it from many years ago so im wondering before looking this up on google if this game was made to utilize the MT32 with a specific sound font. long story short if you want this sound effect to work it needs a sound blaster set up in the game settings and if you want to use a sound module I don't know how to set this up unless you like the sound effect as a piano which sound a bit weird every time he hits the stone and a C note is played.
GabrielKnight123
Member
 
Posts: 316
Joined: 2017-3-03 @ 15:39

Re: Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Postby Spikey » 2018-12-06 @ 14:00

The game is intended to use a SC-55 in GM or GS mode, possibly a SC-55mkII due to polyphony requirements.

What MIDi setting are you using in the install program/resource.cfg config file?
User avatar
Spikey
Member
 
Posts: 231
Joined: 2003-2-04 @ 10:36
Location: South Australia

Re: Quest For Glory 4 - Igor Hitting Tomb Stone Sound Effect Help

Postby GabrielKnight123 » 2018-12-08 @ 18:45

Spikey wrote:The game is intended to use a SC-55 in GM or GS mode, possibly a SC-55mkII due to polyphony requirements.

What MIDi setting are you using in the install program/resource.cfg config file?


In the Resource.CFG file I have:

VideoDrv = VGA.DRV
SoundDrv = GenMIDI.DRV
AudioDrv = DACBlast.DRV
JoyDrv = NO
CMD = QG4CD
MouseDrv = NONE
MemoryDrv = NONE
MinMemory = 1600K
Brightness = 0
Language = 1
MinCPU = 386
CD = NO

resAUD = E:\QG4
resSFX = E:\QG4
PatchDIR = E:\QG4;E:\QG4\PATCHES
audiosize = 63K

I have set the music setting in the game settings to "General MIDI Sound Driver" and my autoexec.bat has:

SET BLASTER =A220 I7 D1 H5 P330 E620 T6
SET MIDI = SYNTH:2 MAP:E MODE:0

At the moment I have tried to get the music to work again with the MT32 MIDI setting in the game setup but I cant get it to work as just past the first "Sierra" logo the game crashes back to dos with a large font and a page or two of error codes, im not sure why now it does this as it was working before - I will have to play around with it by trying other settings. I think it might be from an IRQ change I started with I5 but now its I7 I will test this.

I dont think this will matter but I have copied the CD contents to my E:\QG4 drive and im using the patch from here:
http://sierrahelp.com/Patches-Updates/P ... dates.html
its meant to fix a few things, and in my E:\QG4 folder I have made a Patches folder (E:\QG4\Patches) as the default DVD drive G:\Patches were to old and not making the game run smoothly, I made sure all the files needed were where they had to be so I dont think this sound effect is a problem because of copying the CD to a Drive (E:\QG4) as I have setup the Resource.CFG to point to all the files it needs. One question of the top of my head would be what would the difference be if I changed the "MAP:E and MODE:0" settings in my autoexec.bat?
GabrielKnight123
Member
 
Posts: 316
Joined: 2017-3-03 @ 15:39


Return to Software

Who is online

Users browsing this forum: No registered users and 1 guest