Games running badly on 486

Getting old software/games running on older hardware.

Games running badly on 486

Postby Ultrax » 2019-7-12 @ 04:41

This is a bit of an interesting one, posting this for a friend. I keep telling him that he should get a Vogons account!

My friend is starting to get into DOS gaming and has a Compaq Presario 425 at stock spec - 486SX-25 with 4 MB of RAM. He's been looking for more DOS games to play recently, and one of the games he wanted to try out was Jill Of The Jungle. The game apparently runs at twice the speed it should. I personally have not seen how fast it runs with my own eyes, but I'll take his word for it. We've heard of people playing Jill on Pentium machines, and he says it runs too fast on a 25 MHz SX. What gives? Apparently a lot of games are like this - they "either run too fast or like crap". DOOM doesn't even load, and we've heard of people playing the game on 386 machines of lower clock speeds. Perhaps it's his installation of DOS? Back in June of 2018 he completely formatted the hard drive and reinstalled DOS. As far as I know, it's still a fairly clean install of DOS. The only thing that I suppose might be causing this is the sound card drivers. Personally, I'm stumped. I've never seen this happen on any 486 of this variety. Any ideas?

The machine is configured as follows:
i486 SX 25 MHz
4 MB RAM
Sound Blaster 2.0
214 MB hard drive
DOS 6.22/Win3.11
Ultrax
~
Presario 425|DX2-50|8MB|SB V16S|D622/WFW3.11
Deskpro XE 450|DX2-50|32 MB|NT4.0/95
SR2038X|Athlon 64 X2 3800|2G|GT710 WINXP
Dimension 4400|P4 NW 2 GHz|256M|R128U AGP|WINXP
970a-g43|FX8350 4 GHz|16G|GTX660|WIN10
Late 2013 iMac|i5-4570 2.8 GHz|8G|10.13
User avatar
Ultrax
Member
 
Posts: 128
Joined: 2018-7-30 @ 22:30
Location: Texas, USA

Re: Games running badly on 486

Postby treeman » 2019-7-12 @ 05:37

First thing I would check if internal/external cache is disabled make sure both are on, has it ever worked good? is the turbo button connected perhaps in the wrong position?
and naturally run some benchmarks eg speedsys to see what his system is comparable to
treeman
Oldbie
 
Posts: 513
Joined: 2017-8-16 @ 11:05
Location: Australia, Melbourne

Re: Games running badly on 486

Postby derSammler » 2019-7-12 @ 07:51

On a 4 MB machine, DOOM only runs if you don't load smartdrive or other stuff that eats too much memory. Since DOOM doesn't require any memory manager, it's best to just press F5 when DOS boots to bypass autoexec.bat and config.sys.

However, DOOM on a 486-25 isn't that much fun. You either need to play in low-res or with a small window. If possible, upgrade to 8 MB RAM and install a faster CPU (a DX2-50 will work as a drop-in replacement, so will a DX4 Overdrive).
derSammler
Oldbie
 
Posts: 1854
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Games running badly on 486

Postby Ultrax » 2019-7-12 @ 08:06

treeman wrote:First thing I would check if internal/external cache is disabled make sure both are on, has it ever worked good? is the turbo button connected perhaps in the wrong position?
and naturally run some benchmarks eg speedsys to see what his system is comparable to

I'll send him to the setup menu and check the cache settings. No turbo button, it's one of those really neat all in one systems (integrated monitor) :)

derSammler wrote:On a 4 MB machine, DOOM only runs if you don't load smartdrive or other stuff that eats too much memory. Since DOOM doesn't require any memory manager, it's best to just press F5 when DOS boots to bypass autoexec.bat and config.sys.

However, DOOM on a 486-25 isn't that much fun. You either need to play in low-res or with a small window. If possible, upgrade to 8 MB RAM and install a faster CPU (a DX2-50 will work as a drop-in replacement, so will a DX4 Overdrive).

I'm trying to get him to buy a 486 DX2-50 Overdrive, because I personally couldn't imagine a 25 MHz SX for the kind of tasks I typically do on my 486 boxen.

Coincidentally, those are my 425's exact specs XD (DX2-50 with 8 MB)

Thanks for the advice! I'll show him the thread.
Ultrax
~
Presario 425|DX2-50|8MB|SB V16S|D622/WFW3.11
Deskpro XE 450|DX2-50|32 MB|NT4.0/95
SR2038X|Athlon 64 X2 3800|2G|GT710 WINXP
Dimension 4400|P4 NW 2 GHz|256M|R128U AGP|WINXP
970a-g43|FX8350 4 GHz|16G|GTX660|WIN10
Late 2013 iMac|i5-4570 2.8 GHz|8G|10.13
User avatar
Ultrax
Member
 
Posts: 128
Joined: 2018-7-30 @ 22:30
Location: Texas, USA

Re: Games running badly on 486

Postby derSammler » 2019-7-12 @ 08:19

Ultrax wrote:Coincidentally, those are my 425's exact specs XD (DX2-50 with 8 MB)

I have such a machine as well, though it's from Alcatel. A DX2-50 with 8 megs is really a nice configuration for a 486. I like it more than the omnipresent DX2-66 configurations.
derSammler
Oldbie
 
Posts: 1854
Joined: 2017-4-14 @ 11:30
Location: Germany


Return to Software

Who is online

Users browsing this forum: keropi and 3 guests