Trying to get Redguard to run

Getting old software/games running on older hardware.

Trying to get Redguard to run

Postby xDeathCon » 2019-7-16 @ 02:39

My DOS/Win 3.11 PC should have the specs to run Redguard (Pentium MMX 233MHz 64MB RAM).

My CD drive doesn't work so I used FakeCD to emulate a CD drive of disc 2. The game gets gets into the loading screen fine and gets to initializing combat before throwing some text I can't see because the font is invisible. I might be able to solve the issue if I knew what the error was. I am using the normal RG.EXE because my graphics card is not a voodoo card.

Haven't found anything about this specific issue on the internet so anything would be useful.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53

Re: Trying to get Redguard to run

Postby xDeathCon » 2019-8-02 @ 00:30

Got an update. Crash log reads as so:

DOS/4GW error (2001): exception 0Eh (page fault) at 160:0081BA95
TSF32: prev_tsf32 528C
SS 168 DS 168 ES 168 FS 0 GS 40
EAX 50A451DF EBX 50A451DF ECX 0 EDX FF
ESI 8E6381 EDI 8676E0 EBP FF ESP 96612C
CS:IP 160:0081BA95 ID 0E COD 0 FLG 10202
CS= 160, USE32, page granular, limit FFFFFFFF, base 0, acc CF9B
SS= 168, USE32, page granular, limit FFFFFFFF, base 0, acc CF93
DS= 168, USE32, page granular, limit FFFFFFFF, base 0, acc CF93
ES= 168, USE32, page granular, limit FFFFFFFF, base 0, acc CF93
FS= 0, USE16, byte granular, limit 0, base 14, acc 0
GS= 40, USE16, byte granular, limit FFF, base 400, acc 93
CR0: PG:1 ET:1 TS:0 EM:0 MP:0 PE:1 CR2: 50A451EB CR3: 37000
Crash address (unrelocated) = 2:00246A95

No idea if this helps at all.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53

Re: Trying to get Redguard to run

Postby derSammler » 2019-8-02 @ 06:50

Try a clean boot with no startup files (press F5 when it says "Starting MS-DOS...") and/or try to replace dos4gw.exe with a different version.

btw, what kind of game is this? Never heard of it before.
derSammler
l33t
 
Posts: 2021
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Trying to get Redguard to run

Postby xDeathCon » 2019-8-06 @ 02:15

I have to have startup files because my network must load due to storing the game on a network drive. I already tried different versions and alternatives to dos4gw. I'll move it off the network onto my pc once i beat a different game and can clear some space. I did read something that network drivers may interfere with memory and could be a possible reason.

This game is An Elder Scrolls Adventure: Redguard.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53

Re: Trying to get Redguard to run

Postby derSammler » 2019-8-06 @ 08:25

This game is An Elder Scrolls Adventure: Redguard.

Err... that's a Windows 9x game from 1999. Could you please expain where the DOS/4GW error comes from then? Windows games do no and can not use DOS/4GW. Also, you use fakecd and DOS-based network drivers. Not that it matters, since the game requires Windows 95 minimum and you try to run it on 3.11. I guess you have Win32s installed, but that won't turn 3.11 into 95.
derSammler
l33t
 
Posts: 2021
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Trying to get Redguard to run

Postby zirkoni » 2019-8-06 @ 18:44

derSammler wrote:since the game requires Windows 95 minimum

Nope, there's a DOS executable as well
rg.exe => DOS
rgfx.exe => DOS Glide
redguard.exe => windows 9x

Although, IIRC the game installer is Win9x only so it kind of requires Win9x. But you can install/extract the files on a Windows PC and play on a DOS PC.
User avatar
zirkoni
Member
 
Posts: 186
Joined: 2014-7-17 @ 08:54

Re: Trying to get Redguard to run

Postby xDeathCon » 2019-8-06 @ 21:39

zirkoni wrote:Although, IIRC the game installer is Win9x only so it kind of requires Win9x. But you can install/extract the files on a Windows PC and play on a DOS PC.

Yes, that is exactly what I am trying to do. I don't know for sure if running RG.EXE standalone checks if the CD directory is legitimate or not (I know attempting to launch from Windows does check), so I went with using FakeCD to be on the safe side.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53

Re: Trying to get Redguard to run

Postby i2lgames » 2019-8-08 @ 11:07

Hi. Maybe there is a configuration file that is written when you install the game in windows 98. Try to install the game on another machine, copy the files from there, create the same directory in the pentium mmx pc and see if it works.
i2lgames
Newbie
 
Posts: 31
Joined: 2003-11-14 @ 17:20

Re: Trying to get Redguard to run

Postby xDeathCon » 2019-8-08 @ 12:10

I already did that before.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53

Re: Trying to get Redguard to run

Postby i2lgames » 2019-8-08 @ 12:19

xDeathCon wrote:I already did that before.


Have you tried running it on the windows 98 machine? In pure dos or in windows 98?
i2lgames
Newbie
 
Posts: 31
Joined: 2003-11-14 @ 17:20

Re: Trying to get Redguard to run

Postby xDeathCon » 2019-8-09 @ 01:51

I'd do this but sadly my win 98's hard drive died a year or so ago. I installed using a win 10 pc.
xDeathCon
Newbie
 
Posts: 29
Joined: 2017-11-23 @ 00:53


Return to Software

Who is online

Users browsing this forum: No registered users and 1 guest