VOGONS


First post, by boomlinde

User metadata
Rank Newbie
Rank
Newbie

Hi all,
I've been having some trouble getting ROTT to run on a Libretto 100 CT. It would crash and hang just as it finished loading. By coincidence, I found out why today. If I use the maximum screen size (no HUD) it works fine...any other size and it crashes immediately as the game starts (if I don't start with the maximum screen size) or when I decrease the screen size during the game! I have tried with both 1.2 and 1.3 versions of the game.

I am using DOS 7 from Windows 98SE (cobbled together from a sysdisk) and my CONFIG.SYS and AUTOEXEC are REMed out. Any ideas what might cause this? I don't have any similar problems with other games.

Reply 1 of 1, by boomlinde

User metadata
Rank Newbie
Rank
Newbie

Bumping because I have narrowed the issue down further. I tried emptying AUTOEXEC.BAT and CONFIG.SYS to no avail. Finally, I tried disabling the cache in BIOS. When I do this, the game works, albeit slowly. This further allowed some other games to run that had similar freezing issues (Lost Vikings, Tempest 2000). Because I've run both ROTT and Tempest 2000 on a much faster Pentium II before, I doubt that it's simply a speed issue. To further narrow it down, I tried doing the same thing with SetMul. It works fine when I use the parameters L1DX (disable L1 cache exclusively) or CCD (disable L1 code cache).

There aren't many options for the cache in BIOS. I can enable or disable the cache, and while it's enabled I can switch between write-back and write-through. Neither of the latter two options have any effect on the issue.

So by disabling the code cache, the computer doesn't freeze when the ROTT HUD is enabled...seems strange to me, but please let me know if any of you recognize this error or have an idea of what's going on.