VOGONS


First post, by GL1zdA

User metadata
Rank Oldbie
Rank
Oldbie

I have a PC with an AWE32 card (actually the goldfinch upgrade for an on-board Vibra). When I run the Descent setup utility in the Windows 95 DOS box, I can't find a way to configure the AWE32 for music, it will just fail with "driver not found". On the other hand if I "Restart in DOS mode" everything works: the setup utility can use the AWE32 and it works in game.

Is there any way to make the "DOS box" aware of the AWE32?

getquake.gif | InfoWorld/PC Magazine Indices

Reply 1 of 4, by leileilol

User metadata
Rank l33t++
Rank
l33t++

I think I remember some AWE music with some games that way causing some musical chaos when it tries through Windows (i.e. Duke3D) in which using General MIDI instead was the stable option. I wonder if that also happens for your card?

A DOS game that should work with the AWE32 through Windows 95 is Eradicator, which uses the AWE for a few spatialized higher quality sounds, so that's also worth trying. Start it up, enable AWE and whack a wall and hopefully you should hear a clear, spatialized CLANG!!! noise.

by the way, DOSBox is not for running Windows 9x

Reply 3 of 4, by GL1zdA

User metadata
Rank Oldbie
Rank
Oldbie
leileilol wrote on 2020-03-16, 01:01:

I think I remember some AWE music with some games that way causing some musical chaos when it tries through Windows (i.e. Duke3D) in which using General MIDI instead was the stable option. I wonder if that also happens for your card?

A DOS game that should work with the AWE32 through Windows 95 is Eradicator, which uses the AWE for a few spatialized higher quality sounds, so that's also worth trying. Start it up, enable AWE and whack a wall and hopefully you should hear a clear, spatialized CLANG!!! noise.

Thanks, it's -75% on GOG now, so I bought it 😉 Looks like Eradicator also loads custom soundbanks. I will try next time on the physical machine and report back.

getquake.gif | InfoWorld/PC Magazine Indices

Reply 4 of 4, by auron

User metadata
Rank Member
Rank
Member
GL1zdA wrote on 2020-03-15, 23:30:

I have a PC with an AWE32 card (actually the goldfinch upgrade for an on-board Vibra). When I run the Descent setup utility in the Windows 95 DOS box, I can't find a way to configure the AWE32 for music, it will just fail with "driver not found". On the other hand if I "Restart in DOS mode" everything works: the setup utility can use the AWE32 and it works in game.

Is there any way to make the "DOS box" aware of the AWE32?

descent 1.5 works for me with awe64 under 98se, so not sure what to suggest here. the GM option would need mpu401 emulation toggled on in the awe control panel, but i guess you weren't using that.

leileilol wrote:

I think I remember some AWE music with some games that way causing some musical chaos when it tries through Windows (i.e. Duke3D) in which using General MIDI instead was the stable option.

true, i suppose apogee sound system does some things that really don't mesh with whatever the 9x drivers do with the emu8k. to be fair though, 3d realms did explicitly exclude win95 support so they probably just did not care. and then came along blood just playing FM music when that AWE option was selected...