VOGONS


First post, by feipoa

User metadata
Rank l33t++
Rank
l33t++

I read this post which states how to run the timedemo, but I don't see the "city intro" when starting the game. The game just starts. There is no demo play as with Unreal (classic). https://arstechnica.com/civis/viewtopic.php?f=20&t=1026284

Anyone know how to run the timedemo with UT99 patch version 436? Thanks.

Ultimate 486 Benchmark | Ultimate 686 Benchmark | Cyrix 5x86 Enhancements | 486 Overkill Graphics | Worlds Fastest 486

Reply 2 of 6, by feipoa

User metadata
Rank l33t++
Rank
l33t++

Ahh, I figured it out. I didn't realise that the video that plays immediately after opening the game, that is, before even the dialogue box appears, is the cityintro. I have a conditioned habit of hitting ESC immediately after seeing these intro movies.

Is this intro at 640x480 by default? Or does it use the screen resolution that was used when you previously had the game open?

Ultimate 486 Benchmark | Ultimate 686 Benchmark | Cyrix 5x86 Enhancements | 486 Overkill Graphics | Worlds Fastest 486

Reply 3 of 6, by DracoNihil

User metadata
Rank Oldbie
Rank
Oldbie

Be sure to run without vsync or a software frame limiter as that is the only way to get the engine to "execute as fast as possible".

Also, the engine defaults to that 512x384 something resolution usually. Check Default.ini just to be sure. Unreal can use any resolution whatsoever in windowed mode however.

Steam Profile
YouTube Channel
Seal of Nehahra

Reply 4 of 6, by Dochartaigh

User metadata
Rank Member
Rank
Member
DracoNihil wrote on 2020-04-02, 21:43:

Be sure to run without vsync or a software frame limiter as that is the only way to get the engine to "execute as fast as possible".

Are these found in the Unreal settings I assume? Or maybe for the vsync that's found in the Windows video card panel where you have to turn it off?

What's the cap on FPS with these if you don't turn those off?

Reply 5 of 6, by auron

User metadata
Rank Member
Rank
Member

no vsync option in stock ut iirc, unless you install the utglr renderer, then it's SwapInterval=0 for off in the .ini.

the engine starts breaking at ~100 fps, as in too fast game speed, can't go up stairs etc

Reply 6 of 6, by DracoNihil

User metadata
Rank Oldbie
Rank
Oldbie

If you're using the default D3DDrv that UT99 first came with there's two options "UsePageFlipping" and "UseTrippleBuffering", but I don't remember if those actually properly communicated to the GPU to do what is essentially "vsync" or not. Turning them off should dramatically speed up the rendering process though because it wouldn't have to wait for those operations all the time.

It really depends on the hardware you're trying to use, graphics cards in the 90's were pretty wild west at the time. D3DDrv is notorious for not properly functioning on some of those cards even.

If you're using Glide though, try seeing if "FastUglyRefresh" set to true does anything, but it'd probably be up to the Glide device drivers themselves in whether or not you want vsync enabled, and not actually UT99 itself.

Steam Profile
YouTube Channel
Seal of Nehahra