VOGONS


First post, by AlephZaku

User metadata
Rank Newbie
Rank
Newbie

System:
P3 @ 700mhz
Yamaha 744 with latest vxd drivers
GeForce 2MX
256mb RAM

Kyrandia settings: Tried this with both Sound Blaster Pro and Sound Blaster.

In Windows 98, Kyrandia hangs shortly after a voice clip starts playing, and usually only plays the first part of the voice clip. In DOS, the full clip plays and then the game crashes, at which point the PC speaker plays a loud, constant tone until I hit the power button.

This does not happen if I turn off voices in Options (or, in the case of DOS, just remove the set blaster line to force them to not play). (I could definitely play through this with the voices off, really. I'm mostly just curious about why this isn't working).

I've tried using Throttle to drop speed down to about 12.5% in Windows, which didn't help. I have not tried using setmul to disable cache as this generally seem to make things too slow to be really usable (unless this works better from DOS?)

For booting into DOS, I did try swapping out himem.sys for himemx.exe and using the /max=8194 switch with it, which didn't help either.

Also tried using both 5 and 7 as the IRQ and got the same issue.

(Kyrandia 2 seems to work fine in both DOS and Windows. No idea if that's really relevant though).

config.sys
FILES=30
BUFFERS=20
STACKS=9,256
LASTDRIVE=Z
DOS=HIGH,UMB
DEVICE=C:\HIMEMX\HIMEMX.ECE /max=8194
DEVICE=C:\WINDOWS\EMM386.EXE RAM NOEMS I=B000-B7FF
DEVICEHIGH=C:\DRIVERS\VIDECDD.SYS /D:OPTICAL
SHELL=C:\COMMAND.COM /c lh C:\COMMAND.COM /e:512 /p

Autoexec is loading mscdex, USBUHCIL, USBMOUSE, and cutemouse high, doing the SET BLASTER=A220 I5 D1 T4, and then running the Yamaha setup programs.

Reply 1 of 3, by carlostex

User metadata
Rank l33t
Rank
l33t

This might be an issue with AIL drivers + Yamaha PCI cards. I had the same problem with Dune 2 and my Yamaha 724 which uses AIL as well.

Try Dune 2 in your system, you can also try more games that use Audio Interface Library drivers.

There is source code for AIL drivers, so i wonder this might be something fixable, provided the issue is what i'm suggesting. If more AIL games experience the same type crash on Yamaha PCI cards then there's the answer.

Reply 2 of 3, by AlephZaku

User metadata
Rank Newbie
Rank
Newbie
carlostex wrote on 2020-06-23, 21:10:

This might be an issue with AIL drivers + Yamaha PCI cards. I had the same problem with Dune 2 and my Yamaha 724 which uses AIL as well.

Try Dune 2 in your system, you can also try more games that use Audio Interface Library drivers.

There is source code for AIL drivers, so i wonder this might be something fixable, provided the issue is what i'm suggesting. If more AIL games experience the same type crash on Yamaha PCI cards then there's the answer.

Would the first two lists in the fourth post here be a good place to start with?

Innovation SSI-2001 MIDI driver

I'll go check out Dune 2 and a few of those and update my findings here.

-- Update --

Dune 2's doing the same thing once I get to Great House selection. Eye of the Beholder 3 also crashed as soon as a sound effect played.

Blackthorne worked for me but it had some issues (crashed on IRQ 7. Worked fine on 5). Kyrandia 2 worked fine in game from what I saw, but the speech in the intro was cutting out (that could've been for other reasons though).

Do the ISA Yamaha cards like the YMF719 have the same issue? Thinking I might grab one of those and use that instead if it would be more compatible. 😖

Last edited by AlephZaku on 2020-06-24, 04:34. Edited 6 times in total.

Reply 3 of 3, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

Looks like there's a patch at The Patches Scrolls. Maybe that's worth a try?
https://www.patches-scrolls.de/patch/2436/7/27096

(I don't suppose there's any point in noting that the game is supported by ScummVM.)