VOGONS


First post, by treeman

User metadata
Rank Oldbie
Rank
Oldbie

on my 5x86 when I launch street rod 2 I get prompted for graphics, chose vga then it goes directly to the game with pc speaker.

For those that know the game after the gfx menu there is a second menu for adlib/pc speaker.

I found the info somwhere that in faster hw turning off turbo or cache fixes the problem.

So on my system internal and external cache needs to be turned off in tbe bios then the sound menu appears and adlib works fine.

The game speed is unaffected plays same speed cache on and cache off.

It would be cool not to reset and change bios each time I want to enjoy sound in sr2.

If there is a solution would anybody share it? thank you

Reply 2 of 5, by treeman

User metadata
Rank Oldbie
Rank
Oldbie
Grzyb wrote on 2020-09-07, 14:31:

There's some software to disable/enable CPU cache, eg. ICD.EXE/ICE.EXE
So you can simply make a .BAT file...

Thanks this will be really useful, ill look it up

Reply 3 of 5, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

"cpucache.com on / off" works too but does require qemm386 if you are using EMS.
with EMM386.EXE it locks up the machine.

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 4 of 5, by treeman

User metadata
Rank Oldbie
Rank
Oldbie

I tried 2 utilities
icd/ice and atslow
Unfortunately both programs just hang after saying disabling cache/slowing down system

was worth a try, guess disabling in bios still does the job