VOGONS


First post, by moknok

User metadata
Rank Newbie
Rank
Newbie

If a think a game runs better using DX5 but have DX7 I don't think I can downgrade what are my options? Use Dx5 wrapper?

| WIN98SE non OEM | PII MMX | 350Mhz | 384RAM | Voodoo3 2000 PCI | DX7 | 126GB+ | Yamaha DS-XG Sound |

Reply 2 of 7, by leileilol

User metadata
Rank l33t++
Rank
l33t++

Be warned that video drivers will have D3D HALs written for a minimum DirectX version.

(i personally think DX downgrading's all crap advice anyway as the APIs separate their major releases in different DLLs)

apsosig.png
long live PCem

Reply 3 of 7, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
leileilol wrote on 2022-05-19, 01:29:

(i personally think DX downgrading's all crap advice anyway as the APIs separate their major releases in different DLLs)

+1

Downgrading DirectX never made any sense to me at all.

Reply 4 of 7, by swaaye

User metadata
Rank l33t++
Rank
l33t++

The only time I've seen it be useful is for some Aureal Vortex 2 VXD-based sound drivers (> version 2015) that can BSOD the system on any DirectX after 7.0a for some reason after playing a game.

However that alone makes me prefer not to run a newer DirectX than necessary for the games and hardware. And prefer 2K/XP for games that actually need a newer version.

Reply 5 of 7, by Socket3

User metadata
Rank Member
Rank
Member
leileilol wrote on 2022-05-19, 01:29:

Be warned that video drivers will have D3D HALs written for a minimum DirectX version.

(i personally think DX downgrading's all crap advice anyway as the APIs separate their major releases in different DLLs)

Here's an example: Dungeon Keeper 2 doesn't play nice with DX9b. Works fine with dx8.1.... Video card is an FX5700LE, OS is win98se....I accidentally installed dx9 from a windows update CD and noticed DK2 crashing to desktop randomly... After getting rid of dx9 everything worked as expected.

Reply 6 of 7, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
Socket3 wrote on 2022-05-25, 14:27:
leileilol wrote on 2022-05-19, 01:29:

Be warned that video drivers will have D3D HALs written for a minimum DirectX version.

(i personally think DX downgrading's all crap advice anyway as the APIs separate their major releases in different DLLs)

Here's an example: Dungeon Keeper 2 doesn't play nice with DX9b. Works fine with dx8.1.... Video card is an FX5700LE, OS is win98se....I accidentally installed dx9 from a windows update CD and noticed DK2 crashing to desktop randomly... After getting rid of dx9 everything worked as expected.

Dungeon Keeper 2 doesn't use the DX9 API (let alone touch the DLLs related to DX9). 😜

Reply 7 of 7, by leileilol

User metadata
Rank l33t++
Rank
l33t++

DK2 has a software renderer fallback mode that it probably went to when it couldn't initiate a DX9 class card's D3D HAL backend anymore from the version mismatch. I can't recall having issues with DK2 starting on DX9 with ATI cards in the day. This "DirectX9 problem" sounds very nVidia driver related (and not surprising given the history of nvidia problems being blamed on everything else)

leileilol wrote on 2022-05-19, 01:29:

Be warned that video drivers will have D3D HALs written for a minimum DirectX version.

apsosig.png
long live PCem