Sound Blaster 16 Clones

Discussion about old sound cards, MIDI devices and sound related accessories.

Re: Sound Blaster 16 Clones

Postby appiah4 » 2018-9-07 @ 07:35

The Serpent Rider wrote:Am i missing something or ALS100+ actually can't properly emulate SB16? 16-bit mixing has DMA range from 0 to 3, but Duke3D, ROTT and others allow only DMA 5 of higher.


I have in the past manually edited the config file for Duke3D to set high DMA as 3 and it just worked with cards that don't support high DMA.
1989:A500|+512K|ACA500+|C1084S
1992:HIPPO-VL+|DX2-66|8M|GD5428|CT2290|S2
1995:PCI597-1|P133|32M|Trio64|V1|CT3980/2M
1998:S1573S|K6-2/400|64M|RagePro|V2/SLI|CT4500/32M
2001:GA-6OXT|PIII-1200|512M|GF3Ti200|MX300
2004:K8V-D|3200+|2G|X1950P|SB0350
User avatar
appiah4
l33t
 
Posts: 2568
Joined: 2017-2-19 @ 07:36

Re: Sound Blaster 16 Clones

Postby oohms » 2018-9-10 @ 11:49

The Serpent Rider wrote:Am i missing something or ALS100+ actually can't properly emulate SB16? 16-bit mixing has DMA range from 0 to 3, but Duke3D, ROTT and others allow only DMA 5 of higher.


It seems that high DMA support vanished with the plus version
DOS/w3.11/w98 | K6-III+ 400ATZ @ 550 | FIC PA2013 | 128mb SDram | Voodoo 3 3000 | Avancelogic ALS100 | Roland SC-55ST
DOS/w98/XP | Core 2 Duo E4600 | Asus P5PE-VM | 512mb DDR400 | Ti4800SE | ForteMedia FM801
oohms
Newbie
 
Posts: 76
Joined: 2018-5-30 @ 08:27
Location: Australia

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-03 @ 09:38

PARUS wrote:gerwin, I can't initialize AV310 in DOS on my motherboard. CMINIT.EXE doesn't see the card in pure DOS (but in Windows it works great). My motherboard is Itox G7S620-N-G, chipset i865G.
At the same time, for example, the card works perfectly on motherboards with chipsets i440ZX and i845E. It works excellent in Windows and in pure DOS with CMINIT.EXE on these motherboards.

Can you help, tell me about it? What can I do with this situation on motherboard i865?

Thank you. Sorry for my English.


PARUS, I hope you see this :). Just wondering if you ever got the AV310 to initalise in DOS? I have an IMB200 motherboard (i865, same chipset) but am facing the same initialisation issues. I do have i845 motherboards but would be reluctant to downgrade...

Cheers!
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Re: Sound Blaster 16 Clones

Postby PARUS » 2018-10-09 @ 21:40

mjr4077au, I tried it on IMB200 with the same result :) AV310 won't work on Axiomtek IMB200 motherboard. But I'm sure it is possible to change ISA initialization procedure in BIOS and AV310 will work. I'm sure because it's done already on my Itox G7S620-N. I have asked about it my friend (he knows BIOSes architecture and assembler very well) and he made it for me. Now AV310 works in DOS on my i865 motherboard with Core 2 Duo CPU! (CPU mod also made by him.)
User avatar
PARUS
Member
 
Posts: 362
Joined: 2013-4-14 @ 04:03

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-13 @ 02:32

PARUS wrote:mjr4077au, I tried it on IMB200 with the same result :) AV310 won't work on Axiomtek IMB200 motherboard. But I'm sure it is possible to change ISA initialization procedure in BIOS and AV310 will work. I'm sure because it's done already on my Itox G7S620-N. I have asked about it my friend (he knows BIOSes architecture and assembler very well) and he made it for me. Now AV310 works in DOS on my i865 motherboard with Core 2 Duo CPU! (CPU mod also made by him.)


Thank you so much for getting back to me! Do you think I could send you the latest BIOS I received from Axiomtek for the IMB200 and your friend could modify? Happy to send a little something both your way if you help me? :happy:
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Re: Sound Blaster 16 Clones

Postby PARUS » 2018-10-14 @ 21:12

mjr4077au, his nickname is LLC. You can find him on overclockers.ru, modlabs.net, just register and pm him. He knows IMB200 board. Of course I don't know if he agrees or not to solve this problem again on another board.
User avatar
PARUS
Member
 
Posts: 362
Joined: 2013-4-14 @ 04:03

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-14 @ 22:20

PARUS, thank you so much I'll mesage him now! :happy:
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Previous

Return to Sound

Who is online

Users browsing this forum: No registered users and 2 guests