VOGONS


Aztech Sound Galaxy cards

Topic actions

Reply 120 of 155, by dionb

User metadata
Rank l33t
Rank
l33t
Grzyb wrote on 2019-06-02, 21:45:
I mean 8-bit DAC/ADC, not 8-bit bus. WSS may only use 8-bit bus, but it surely supports 16-bit DAC/ADC. Which means the table in […]
Show full quote
Tiido wrote:

WSS works on purely 8bit bus so having only 8bit slot doesn't preclude it.

I mean 8-bit DAC/ADC, not 8-bit bus.
WSS may only use 8-bit bus, but it surely supports 16-bit DAC/ADC.
Which means the table in this post is wrong about WSS support, at least for those cards with no 16-bit sampling.

Bit of a necro-bump here.

I already had a much-loved NXPro and last week found a Basic 16 (MMSN810) for a nice price. Based on SaxxonPike's page and Rabanic's table I assumed it to be basically the same card with the only addition being a wavetable header of dubious utility due to it not supporting MPU-401. I certainly got that, but the differences were bigger. For starters where the NXPro has a volume knob and three 3.5mm connectors the Basic16 has no knob and four 3.5mm. Also my NXPro has a genuine YMF262 and the Basic16 has an "LS-212". But what really caught my attention was the DAC. The NXPro just has a simple Yamaha YAC512, but the Basic16 has a CS4248-KL codec, complete with two oscillators (16.9344 and 24.576).

Suddenly something clicked: I enjoy the WSS sound of my various Aztech 3rd gen cards but had not been able to get it working on the NXPro. I'd assumed driver issues or resource conflicts, but it looks more fundamental: no codec, no WSS - which shouldn't be a surprise as that's the situation with the - better documented - GUS vs GUS Max as well.

So I think the WSS support column in the table needs to be set to "No" for all the 1st gen cards without codec.

On the topic of 16b WSS, I don't think the table is wrong, it just needs qualification. WSS playback in DOS definitely has 16b resolution (just listen to it in Descent, it's as good as SB16 and vastly better than SBPro), but the table specifically mentions sampling i.e. recording. Can't confirm or deny that, but it sounds plausible enough.

Reply 121 of 155, by Grzyb

User metadata
Rank Oldbie
Rank
Oldbie
dionb wrote on 2020-03-06, 23:58:

sampling i.e. recording

I'm not sure, I've seen the term "sampling" as covering both recording and playback of samples.

Anyway, cards with 8-bit DAC typically have 8-bit ADC, same with 16-bit.
Exceptions are rare (see GUS Classic), and probably non-existent among Aztech cards.

Reply 122 of 155, by dionb

User metadata
Rank l33t
Rank
l33t
Grzyb wrote on 2020-03-07, 00:13:

[...]

I'm not sure, I've seen the term "sampling" as covering both recording and playback of samples.

Technically, sampling is specifically what the ADC does, not the DAC - but yeah, what's technically accurate isn't always leading in terminology unfortunately.

Anyway, cards with 8-bit DAC typically have 8-bit ADC, same with 16-bit.
Exceptions are rare (see GUS Classic), and probably non-existent among Aztech cards.

Thing is, it is a 16b ADC, otherwise it couldn't do that under Windows. So 8b sampling is a software limitation, not a hardware limit. That software limitation does not need to apply to both ADC and DAC portions. Again, on WSS supporting games the sound is extremely similar to SB16 and not at all like SBPro2, so I'm pretty sure it's doing 16b DAC under pure DOS.

Reply 123 of 155, by jesolo

User metadata
Rank Oldbie
Rank
Oldbie

Just to weigh in around the I38MMSN810.
This particular model happens to be the first sound card I bought (I still have it).

From my understanding and what I've read, the LS-212 is an exact (unofficial) clone of the Yamaha OPL-3 (YMF262) FM synthesis chip. Some models (of different makes of sound cards with the same model number) came with either one. For example, my I38-MMSN810 has the YMF262 onboard. You might just have a different revision.

Windows Sound System compatibility is good - some models came with the Analog Devices AD1848 Codec which offers the same functionality as the CS4248 Codec chip. Just a shame it wasn't so popular with game developers, since many clone cards had either of the two Codecs which provided WSS compatibility and, hence, 16-bit sound playback.

One thing you could test out for me is how "clear" your sound playback is. On my revision, I have to push up the treble to almost max to get a clearer sound, compared to my 3rd generation Aztech cards.

Reply 124 of 155, by MrSmiley381

User metadata
Rank Newbie
Rank
Newbie

Gonna throw my hat in the Aztech arena since this thread has already risen from the ashes. Recently acquired some variant of a Sound Galaxy card, labeled as a I38-MMSD802. It appears to be a Sound Galaxy NX Stereo Pro Extra, if TULARC is to be believed. The card works fine as a Sound Blaster Pro 2.0 and as a Disney Sound Source for Wolf 3D. Now, if I run this alongside a GUS MAX, I get all sorts of sound crackling and pops in Wolf 3D, and no music in DOOM. Testing machine is a 450 MHz K6-3+. Normally, I am able to have a Sound Blaster Pro 2.0 and the GUS MAX coexisting peacefully. I'll have to dig through the oddball Aztech software available and see what's happening. Pretty sure it's a simple resource conflict.

I spend my days fighting with clunky software so I can afford to spend my evenings fighting with clunky hardware.

Reply 125 of 155, by dionb

User metadata
Rank l33t
Rank
l33t
MrSmiley381 wrote on 2020-03-16, 01:56:

Gonna throw my hat in the Aztech arena since this thread has already risen from the ashes. Recently acquired some variant of a Sound Galaxy card, labeled as a I38-MMSD802. It appears to be a Sound Galaxy NX Stereo Pro Extra, if TULARC is to be believed. The card works fine as a Sound Blaster Pro 2.0 and as a Disney Sound Source for Wolf 3D. Now, if I run this alongside a GUS MAX, I get all sorts of sound crackling and pops in Wolf 3D, and no music in DOOM. Testing machine is a 450 MHz K6-3+. Normally, I am able to have a Sound Blaster Pro 2.0 and the GUS MAX coexisting peacefully. I'll have to dig through the oddball Aztech software available and see what's happening. Pretty sure it's a simple resource conflict.

The Doom music issue sounds like a resource conflict. What I/O, IRQ and DMAs do they have set? And which music is failing? AdLib, WSS or MIDI?

The noise could just be the utter lack of shielding in these cards. GUS manage to keep their own output fairly clean, but they're electrically noisy. I even get noises when pairing one with an AWE64 Gold, one of the quietest, best-shielded cards out there. It ingresses through the cable connecting the GUS line-out to the AWE line-in.

Reply 126 of 155, by MrSmiley381

User metadata
Rank Newbie
Rank
Newbie
dionb wrote on 2020-03-16, 13:31:
MrSmiley381 wrote on 2020-03-16, 01:56:

Gonna throw my hat in the Aztech arena since this thread has already risen from the ashes. Recently acquired some variant of a Sound Galaxy card, labeled as a I38-MMSD802. It appears to be a Sound Galaxy NX Stereo Pro Extra, if TULARC is to be believed. The card works fine as a Sound Blaster Pro 2.0 and as a Disney Sound Source for Wolf 3D. Now, if I run this alongside a GUS MAX, I get all sorts of sound crackling and pops in Wolf 3D, and no music in DOOM. Testing machine is a 450 MHz K6-3+. Normally, I am able to have a Sound Blaster Pro 2.0 and the GUS MAX coexisting peacefully. I'll have to dig through the oddball Aztech software available and see what's happening. Pretty sure it's a simple resource conflict.

The Doom music issue sounds like a resource conflict. What I/O, IRQ and DMAs do they have set? And which music is failing? AdLib, WSS or MIDI?

The noise could just be the utter lack of shielding in these cards. GUS manage to keep their own output fairly clean, but they're electrically noisy. I even get noises when pairing one with an AWE64 Gold, one of the quietest, best-shielded cards out there. It ingresses through the cable connecting the GUS line-out to the AWE line-in.

I did some further testing and the conflict is likely on the Adlib port. If I disable music in DOOM or Rise of the Triad via the setup program, sound effects work fine. If I disable all audio except Disney Sound Source for Wolfenstein 3D I can hear sound effects just fine. Curiously enough, the Duke Nukem 3D setup program will let me test music and it largely works aside from some occasional hanging notes.

This problem is the spiritual sequel to another post where I discovered that running Ultrinit can solve an Adlib port conflict on its own when running the GUS MAX alongside an actual Sound Blaster Pro 2.0. I was hoping it would do the same with the Sound Galaxy card, but I guess that's not the case. I think my only other hope to run these cards in tandem would be to determine how Ultrinit disables the Adlib port and make a tiny executable that only does that part, then try running that. Unfortunately, I'm more of a database developer than I am an assembly hacker, so that's a project for another day.

I spend my days fighting with clunky software so I can afford to spend my evenings fighting with clunky hardware.

Reply 127 of 155, by Oetker

User metadata
Rank Member
Rank
Member

Just wanted to share that a while back I posted about Doom only having sound after being started twice with my AZT2316. Now I've got an AZT2320 and it doesn't have that issue! It still does have the issue that Cosmo's Cosmic Adventure will only sporadically play Adlib music.

Reply 128 of 155, by Amigaz

User metadata
Rank Oldbie
Rank
Oldbie

Can someone please help me identify this Aztech model I have and what the daughterboard does, thanks

https://nextcloud.jjserver.net/s/FR5CTBmxiqin5C6

1607787.png

1607975.png

Reply 129 of 155, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++
Amigaz wrote on 2020-08-12, 16:51:

Can someone please help me identify this Aztech model I have and what the daughterboard does, thanks

https://nextcloud.jjserver.net/s/FR5CTBmxiqin5C6

What is the model number of the card? Probably hidden by the daughterboard. Looks like a Waverider 32+ to me - I38-MMSN826

Can we get pics of the other side of the daughterboard?

Last edited by cyclone3d on 2020-08-12, 19:28. Edited 1 time in total.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 130 of 155, by imi

User metadata
Rank l33t
Rank
l33t

http://www.amoretro.de/2013/08/aztech-waverider-32.html

idk what the add-on board does, maybe some kind of mixer? it has a "Dual 4-channel analog multiplexer/demultiplexer" chip on it.

Reply 131 of 155, by Amigaz

User metadata
Rank Oldbie
Rank
Oldbie
cyclone3d wrote on 2020-08-12, 18:02:
Amigaz wrote on 2020-08-12, 16:51:

Can someone please help me identify this Aztech model I have and what the daughterboard does, thanks

https://nextcloud.jjserver.net/s/FR5CTBmxiqin5C6

What is the model number of the card? Probably hidden by the daughterboard. Looks like a Waverider 32+ to me - I38-MMSN826

Can we get pics of the other side of the daughterboard?

Looks like the Waverider 32+
I'll try and get some more pics of the daughterboard .. maybe it's a fancy reverb module like the Adlib Gold had?

1607787.png

1607975.png

Reply 132 of 155, by Amigaz

User metadata
Rank Oldbie
Rank
Oldbie
imi wrote on 2020-08-12, 18:44:

http://www.amoretro.de/2013/08/aztech-waverider-32.html

idk what the add-on board does, maybe some kind of mixer? it has a "Dual 4-channel analog multiplexer/demultiplexer" chip on it.

Definately the Waverider 32 judging by the picture!
Have tried and used a ton of ISA sound card models but never this model.

Mixer or reverb module ... is what I suspect that the daughter board is.

1607787.png

1607975.png

Reply 134 of 155, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

My I38-MMSN850 has no Sound in JimPower regardless what I do. 🙁
Is there a tool that optimizes Soundblaster-Detection/Emulation for the aztech-cards.
I aslo recognized that I have no sound in PinballDreams on that card.
I am using standard-settings A220 I5 D1 on that aztech-card. Beside PinballDreams and JimPower the card works fine.

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 135 of 155, by Oetker

User metadata
Rank Member
Rank
Member
dr.zeissler wrote on 2020-08-12, 21:15:
My I38-MMSN850 has no Sound in JimPower regardless what I do. :( Is there a tool that optimizes Soundblaster-Detection/Emulatio […]
Show full quote

My I38-MMSN850 has no Sound in JimPower regardless what I do. 🙁
Is there a tool that optimizes Soundblaster-Detection/Emulation for the aztech-cards.
I aslo recognized that I have no sound in PinballDreams on that card.
I am using standard-settings A220 I5 D1 on that aztech-card. Beside PinballDreams and JimPower the card works fine.

I haven't tried those games but I've had luck with two fixes with another 2316 based card:
-Slowing down my PC
-Quitting a problematic game and starting it again

If the FM test that comes with the aztech DOS drivers gives you garbled sound, definitely try slowing down your PC.

Reply 136 of 155, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

Thx, but I am using my 486/66 without cache, so there must be another solution.
I will try setting the card in WSS-mode and use the WSS->SB compatibility tool.
Perhaps I can cheat on "Hülsbecks" automatic sound-detection in that game.

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 137 of 155, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

Another bump as I came across a bit of interesting info that probably indicates that the model number list in the OP needs to be updated.

1. SGBX21 is NOT the BX II, but instead the BX III as seen in these pics I found of the retail box: (I was mistaken.. looks like the BX II / BX II Extra / BX III use the same FCC ID / part number).

BX_III_box-front.JPG
Filename
BX_III_box-front.JPG
File size
90.93 KiB
Views
127 views
File license
Fair use/fair dealing exception
BX_III_box-back.JPG
Filename
BX_III_box-back.JPG
File size
88.61 KiB
Views
127 views
File license
Fair use/fair dealing exception

2. I have this card on the way, simply labeled BX II

bx_ii-front.jpg
Filename
bx_ii-front.jpg
File size
332.87 KiB
Views
127 views
File license
Fair use/fair dealing exception
bx-ii_back.jpg
Filename
bx-ii_back.jpg
File size
311.02 KiB
Views
127 views
File license
Fair use/fair dealing exception
bx-ii_io.jpg
Filename
bx-ii_io.jpg
File size
276.61 KiB
Views
127 views
File license
Fair use/fair dealing exception

Interesting thing about this card is that it has an FM Tuner built on. Could this be the Sound Galaxy BX II Extra?

Last edited by cyclone3d on 2020-09-21, 06:07. Edited 3 times in total.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 139 of 155, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++
imi wrote on 2020-09-19, 23:37:

well, I guess I ain't getting that card then ^^, but yeah it got me pretty intruiged too.

Heh. I was on the fence about getting it but then decided to go ahead and buy it since I hadn't seen one like that before.

From what I can tell, the BX, BX II and BX III are all essentially the same card just with different layouts? Am I missing something?

I don't have the BX, but I do have a few of the BX III cards.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself