VOGONS


First post, by UltimaPlayer12

User metadata
Rank Newbie
Rank
Newbie

Hey guys, yet another problem I'm having with my rig! I've detailed this in a thread a while ago and didn't want to bump that one in fear of breaking any rules, but I'd gone missing from VOGONS for a while after getting tired of the problems this computer was having. Now that I've got The Beast 2.0 set up, I'm wanting to play Blood and Duke3D, however my SB16 PnP is not working in DOS mode. I can't get any drivers to install as they say I'm running in a Win9x environment, even when I drop to DOS mode. Does anyone have any advice on setting this up? Am I just overlooking something really obvious? Most DOS games forward the sound just fine, but Build Engine games don't like Windows 9x controlling the sound card.

The Beast 2.0:
CPU: AMD K6-III 450MHz GPU: Nvidia FX 5600 128MB HDD: 20GB (Seagate?) Mobo: ASUS P5A-B RAM: 512MB Sound Card: SB 16 PnP ISA OS: Windows 98 SE

Reply 1 of 2, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

I think one of the driver packages includes items specifically intended to be run in Win9x DOS mode.

In any case, all it's really doing is looking at the MS-DOS version number; apparently if you use SETVER, you can trick the installer into thinking that you're running DOS 6. There's also a patched version of CTCM and CTCU here:
Re: Patched CTCM/CTCU to remove Windows detection

Reply 2 of 2, by jesolo

User metadata
Rank Oldbie
Rank
Oldbie

You can either try the above method or, just edit the ctpnp.cfg file under your Windows directory (if you want to use different resources to what Windows is using). The default is A220 I5 D1 H5 P330 T6 - these are also what you specify in your Autoexec.bat file next to your SET BLASTER= environment variable.

However, in order to initialise the PnP card under DOS 7.0/7.1, you need to make sure that CTCM is loaded as a device driver in your Config.sys file. You don't need CTCU, since the settings are read from the ctpnp.cfg file as mentioned above.

Just take note that if you do edit ctpnp.cfg, to make the file "read-only", since Windows will overwrite the file again.
I would recommend to stick with the default settings so that your DOS and Windows settings are the same.