Sound Blaster PCI 128 WDM drivers Windows 98?

Discussion about old sound cards, MIDI devices and sound related accessories.

Sound Blaster PCI 128 WDM drivers Windows 98?

Postby Totempole » 2017-1-31 @ 01:50

Does anyone know where I might be able to find these? The ones I have on my driver CD is for Windows 98.

I tried downloading "SBPCI_WebDrvsV5_12_01.exe" http://support.creative.com/downloads/download.aspx?nDownloadId=1843
from Creative's website and they do install, but I don't get any audio output. I'm not sure if it's perhaps just a bad card, or whether the drivers are incorrect.

Thanks.
My Retro Gaming PC:
Pentium III 450MHz Katmai Slot 1
Transcend 256MB PC133
Gigabyte GA-6BXC
MSI Geforce 2 MX400 AGP
Ensoniq ES1371 PCI
Sound Blaster AWE64 ISA
User avatar
Totempole
Member
 
Posts: 302
Joined: 2011-10-27 @ 22:45
Location: South Africa

Re: Sound Blaster PCI 128 WDM drivers Windows 98?

Postby Jorpho » 2017-1-31 @ 03:12

To be sure, you're using these on 98 SE, right? What are you using to test audio output?
User avatar
Jorpho
l33t++
 
Posts: 7043
Joined: 2003-2-14 @ 19:50
Location: Canada

Re: Sound Blaster PCI 128 WDM drivers Windows 98?

Postby Totempole » 2017-1-31 @ 13:22

Yes, sorry. Windows 98 SE. Just using Windows sounds to test.
My Retro Gaming PC:
Pentium III 450MHz Katmai Slot 1
Transcend 256MB PC133
Gigabyte GA-6BXC
MSI Geforce 2 MX400 AGP
Ensoniq ES1371 PCI
Sound Blaster AWE64 ISA
User avatar
Totempole
Member
 
Posts: 302
Joined: 2011-10-27 @ 22:45
Location: South Africa

Re: Sound Blaster PCI 128 WDM drivers Windows 98?

Postby yawetaG » 2017-1-31 @ 17:45

Are the speakers connected to the speaker output jack and not line-out? AFAIK, you don't get any sound if the speakers are connected to the wrong jack...
And you're sure the sound isn't muted in the Mixer control panel?

Your driver CD should also work in 98SE, by the way.
yawetaG
Oldbie
 
Posts: 1428
Joined: 2016-6-14 @ 14:36
Location: Netherlands

Re: Sound Blaster PCI 128 WDM drivers Windows 98?

Postby Jorpho » 2017-1-31 @ 17:52

yawetaG wrote:Your driver CD should also work in 98SE, by the way.
It might just be the VxD drivers, though. (The WDM drivers would be preferable from a stability standpoint, though I recall the audio from Grim Fandango was distorted unless I used the VxDs.)

Probably the easiest way to establish if the card is bad is to see if it works with the VxDs, or you can try booting up a live Linux distro. But I think Mr. yawetaG's suggestions make sense; if there was something seriously wrong with the card, I would expect that you'd be getting some kind of error message.
User avatar
Jorpho
l33t++
 
Posts: 7043
Joined: 2003-2-14 @ 19:50
Location: Canada

Re: Sound Blaster PCI 128 WDM drivers Windows 98?

Postby Totempole » 2017-1-31 @ 18:48

Thanks for the advice everyone. It was most likely a bad card I think. I replaced it with an Ensoniq ES1371 card and it works perfectly.

The original card was a CT4810, so only had one audio output.
My Retro Gaming PC:
Pentium III 450MHz Katmai Slot 1
Transcend 256MB PC133
Gigabyte GA-6BXC
MSI Geforce 2 MX400 AGP
Ensoniq ES1371 PCI
Sound Blaster AWE64 ISA
User avatar
Totempole
Member
 
Posts: 302
Joined: 2011-10-27 @ 22:45
Location: South Africa


Return to Sound

Who is online

Users browsing this forum: No registered users and 3 guests