Problem with ESS Solo-1 DOS Emulation

Discussion about old sound cards, MIDI devices and sound related accessories.

Problem with ESS Solo-1 DOS Emulation

Postby Colek » 2017-9-16 @ 12:35

Hey,

I've got problem with my ESS Solo-1 with DreamBlaster S2, I've installed VXD drivers 4.12.01.1165 on Windows 98 SE and sound and MIDI work just fine under Windows, but I have problems with DOS emulation.

Essolo runs at start up without any problems and I can reinitialize it, I've get following report back:
Code: Select all
Current PCI IRQ: 7 PCI IO Base: BC00
DMA Mode is TDMA

SBPro Game Settings:
SB IO=220h IRQ=7 DMA=1
MPU401 IO=320h
Game Port IO=201h


So, the MIDI through cards emulation or WaveBlaster is working just fine in any game I tested, but I can't get sound FX to work. I get no audio output on the said SB Pro settings in any game I tried. Any ideas what could be at problem?
User avatar
Colek
Newbie
 
Posts: 8
Joined: 2017-6-16 @ 01:03

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-16 @ 12:50

Please take a Picture of the card! Ess-Solo1 is not Ess-Solo1, there are differences. I get best results with this card: http://www.amoretro.de/2012/03/terratec ... e-pci.html
- My settings are always 220 IRQ5 DMA1, don't know why it's 7 by your card.
- Are you talking about dosgames running under started win98? or plain dos?
- What games have you tried.
- Please describe the other hardware, board, cpu, cards

I remember one driver with no sound under dos, it has some kind of issue with the mixer.
Installing the other one and everything is fine.

Thx
Doc
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby Colek » 2017-9-16 @ 13:11

Image

It's IRQ 7, because it's installed in my second PCI slot, first one is covered by GPU cooler.

DOS games under Windows 98 and DOS-Mode in Windows 98.

Doom and Terminator Future Shock (both only output MIDI music), but Chasm the Rift is working properly without any issues (just tried it).

Mobo: ASRock P4i65G
CPU: Pentium 4 3.4GHz (Prescott)
Cards: said soundcard and Nvidia Geforce 6800 Ultra
User avatar
Colek
Newbie
 
Posts: 8
Joined: 2017-6-16 @ 01:03

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-16 @ 13:28

Such a card did not work for me either. Check out the linked above. You will recognize it by the other line-out connector.
Last edited by dr.zeissler on 2017-9-16 @ 13:45, edited 1 time in total.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby derSammler » 2017-9-16 @ 13:40

dr.zeissler wrote:You will recognize it by the other line-out connector.

Actually, you'll recognize by the (missing) eeprom chip.
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Problem with ESS Solo-1 DOS Emulation

Postby gerwin » 2017-9-16 @ 18:36

I have a Terretac 128 PCI card with ESS Solo-1 like this:
-Green line out jack.
-No amplifier circuit.
-No EEPROM AT93C46.
-No plastic around CD connectors.
-No Wavetable connector.
The only feature it had was the SB-Link connector.

I soldered on a 26-pin wavetable connector years ago but never tested it until now. Well, everything works fine in pure DOS :) . That is without a windows driver installed. I had to disable the PnP OS option in the BIOS first, to prevent the driver form complaining. Also ESSOLO.INI has to be directly in the root of c:\, as kamerat pointed out before.

-Works with digitized sound as an ESS Audiodrive compatible. (16-bit, neat!)
-Works with digitized sound as an Sound Blaster Pro 2 compatible.
-Working MPU-401: I get Midi Music from a daughterboard that I connected to the card.
-Working FM music through ESFM; seemingly an exact Yamaha OPL3 FM clone.

I tried both essaudio.com and essolo.com, no difference really. I tried DDMA and TDMA (below): both work. The only downside is that the IRQ remains at 10, which I understand is a problem for games using the DOS/4G extender. Changing the 7th hex value of 09 to 05 or 07 does not help.

viewtopic.php?f=57&t=36118 (page 14) by kbs6271, 19-4-2016
ESS SOLO-1(ES1938) PCI DOS driver configuration file: Essolo.ini, hex values:
Code: Select all
20 02 01 00 88 03 09 00 01 02 30 03 00 00 00 00 === DDMA MODE
20 02 01 00 88 03 09 00 01 02 30 03 01 00 00 00 === TDMA MODE
20 02 01 00 88 03 09 00 01 02 30 03 02 00 00 00 === SB-link(PC/PCI) MODE
User avatar
gerwin
l33t
 
Posts: 2564
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-16 @ 18:52

gerwin wrote:-Works with digitized sound as an ESS Audiodrive compatible. (16-bit, neat!)


mine does not :(
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby gerwin » 2017-9-16 @ 18:54

dr.zeissler wrote:
gerwin wrote:-Works with digitized sound as an ESS Audiodrive compatible. (16-bit, neat!)

mine does not :(

I tested it with Doom MBF 2.04 in my signature. The setup.exe detects ESS Audiodrive.
User avatar
gerwin
l33t
 
Posts: 2564
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-16 @ 18:57

I'll have to check out the other ESS cards, there must be another one, but as far as I remember I got no sound under plain dos at all.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby gerwin » 2017-9-16 @ 19:01

MPXplay works too with its 16-bit ESS driver.

With the BIOS setting "IRQ 10 reserved for Legacy ISA" the ESS emulation went to IRQ 7. But it does not give digital sound anymore, Just music!? Same with IRQ 5. Back to IRQ 10 and everything works again. The CT-5RSA0 motherboard I am using now has no SB-Link connector.

Using "mem /c" I see no TSR installed.
User avatar
gerwin
l33t
 
Posts: 2564
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Problem with ESS Solo-1 DOS Emulation

Postby Kamerat » 2017-9-16 @ 21:39

I think you can add ESSOLO.SYS to CONFIG.SYS so it acts like a TSR that handles IRQ emulation.
User avatar
Kamerat
Oldbie
 
Posts: 856
Joined: 2014-3-14 @ 19:09
Location: Oslo, Norway

Re: Problem with ESS Solo-1 DOS Emulation

Postby gerwin » 2017-9-16 @ 22:37

Kamerat wrote:I think you can add ESSOLO.SYS to CONFIG.SYS so it acts like a TSR that handles IRQ emulation.

Indeed, that did the trick. Using ESSOLO.SYS the emulation is now on IRQ 5 and working well. As an extra test I removed ESSOLO.SYS from the CONFIG.SYS again and then it goes back to IRQ 10.
Thanks!
So I have no issues left with this card, but I don't know about the topic starter?
User avatar
gerwin
l33t
 
Posts: 2564
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-17 @ 05:52

The other ESS-Card (V1.2) with no Wavetable-Header behaves just the same in my system. It works, but has no advantages. So I was wrong that it did not work at all and only the linked 1.1 Version with the different audio out was the way to go. I will test DoomMBF (for Doom2,Heretic, Hexen) and report later.

But there are some Problem remaining. My card does not seem to work in games that use the high-dma for SB. E.g. Rampage, Duke3d, Rott, ShadowWarrior etc. In these games only midi- or fm-music or adlib digital is possible. But adlib sounds silly on rott.

It would be a real deal if a ess-audiodrive drivers exists that can be used in the problematic games. Beside the posted above are to mention: Turrican2, Pinball-Dreams, Fantasies, Illusion, ExtremePinball, EpicPinball. Dreams/Fantasies/Illusion work with adlib but that's not the best option.

Any idea how to fix this? These games do not have ess-audiodrive as an option. ESSaudio-drive games http://www.mobygames.com/browse/games/dos/tic,1/ti,568/

Btw. I use esssolo.sys in my config.sys, but I see no tsr via mem /c.

Greetings
Doc

I put my plain-dos-config in the ess-dos.zip With this you should be able to get an ess-pci card working under dos. The setup.exe does not work for all cards, but it's not necessary the rest will do fine.
Attachments
ESS-DOS.zip
(42.99 KiB) Downloaded 78 times
Last edited by dr.zeissler on 2017-9-17 @ 06:25, edited 5 times in total.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby Kamerat » 2017-9-17 @ 05:56

gerwin wrote:So I have no issues left with this card, but I don't know about the topic starter?

I think the issues boils down to the i865 chipset. For best compatibility on the ICH based Intel chipsets (i810-i875P) you need SBLINK. Unfortunately most Pentium 4 motherboard lacks that connector. VIA based motherboards are a much better option for the Solo-1, even the K8T890 PCIe chipset handles it in TDMA mode.
User avatar
Kamerat
Oldbie
 
Posts: 856
Joined: 2014-3-14 @ 19:09
Location: Oslo, Norway

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-9-17 @ 10:10

Can confirm that MBF (Port) finds my card and uses ESS-Audiodrive! cool!
Any dos-trackers available that use ESS-Audiodrive too? FT2 only works with 1.1 in SBpro. All later refuse to work. I do use FT2 (2.x) but only with Covox.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby gdjacobs » 2017-12-22 @ 01:35

OpenCubic Player for playback, I guess.
User avatar
gdjacobs
l33t++
 
Posts: 5684
Joined: 2015-11-03 @ 05:51
Location: The Great White North

Re: Problem with ESS Solo-1 DOS Emulation

Postby derSammler » 2017-12-22 @ 10:13

dr.zeissler wrote:But there are some Problem remaining. My card does not seem to work in games that use the high-dma for SB. E.g. Rampage, Duke3d, Rott, ShadowWarrior etc.

Probably because it doesn't do SB16 emulation..?
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-12-22 @ 12:11

but sbpro should work fine but does not in these games, within most others it does. it's the sound-engine.
e.g. a old doom1-soundengine works pretty fine, later doom1 version do not work anymore, so do any doom2 versions/heretec/hexen/duke3d/swarrior etc.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Re: Problem with ESS Solo-1 DOS Emulation

Postby derSammler » 2017-12-22 @ 12:23

But SB Pro has no high DMA. You must be confusing something. What are your settings exactly?
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Problem with ESS Solo-1 DOS Emulation

Postby dr.zeissler » 2017-12-22 @ 12:28

But the soundengine requires it, even in SBPRO, therefore I edit the cfg and use DMA1 for both High and Low.
I should take some pictures of the config-dialog in e.g. duke 3d.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1503
Joined: 2011-9-28 @ 15:33

Next

Return to Sound

Who is online

Users browsing this forum: No registered users and 5 guests